Jump to content
InsanelyMac Forum
Mohamed Khairy

{Guide} DELL INSPIRON N5110

Recommended Posts

Advertisement

 

Hello everyone. I have a problem with the HDMI port  in Windows  8.1 does not work (no video and no audio). Someone could fix this. 
thanks

 

using modded bios? UEFI bios? standard bios?

Share this post


Link to post
Share on other sites

I guess that his mean what is version of bios mod (UEFI or Legacy BIOS) that you are using.

 

Exactly as this!!, the reason I ask which bios, is because the UEFI bios is in effect, still being tested out by those who have wanted to try it out early, i.e., before a final release / guide.

 

There may well be a few bugs, including some in windows that have not been experienced by others yet.

 

It may not be bios related at all, in which case it would be interesting to know if HDMI was tested on this laptop previous to installing OSX, has another cable, and another monitor been tested to tule out external hardware issues.

 

Do you have dual graphics? is one of the graphics cards disabled? Does the HDMI on this laptop run from the HD3000 or other graphics card... another thing to check.

 

Does HDMI work in OSX?

 

Provide everyone with as much info as you can, what you have done, what you have tested etc.. 

Share this post


Link to post
Share on other sites

Hi,

I have i7 2670QM with 16 gb of ram, nvidia gt525m 1gb and I am stuck at the spinning logo or the black screen when using -v.

I followed precisely the pre install and the video on the first post.. what is wrong ? 

(PS - i also have the latest bios mod by florin2)

Share this post


Link to post
Share on other sites

Hi.is that the screen you are getting too?<br /><br /> uploadfromtaptalk1394216706348.jpg<br />

<br /><br />

Hi,<br />I have i7 2670QM with 16 gb of ram, nvidia gt525m 1gb and I am stuck at the spinning logo or the black screen when using -v.<br />I followed precisely the pre install and the video on the first post.. what is wrong ? <br />(PS - i also have the latest bios mod by florin2)

<br /><br />A screen like that?<br />I had some trouble too..but now is ok..

Share this post


Link to post
Share on other sites

In 10.8 my wifi card worked, now in 10.9 it doesn't work anymore..

wifi card :

Atheros_AR5B197 - Combo card - Wi-Fi (AR9287) 2x2 bgn + Bluetooth (AR3011)

bluetooth works but wifi don't

Share this post


Link to post
Share on other sites

Hi!

 

 

It seems everyone here talks about the last gen N5110's with upgraded CPU's, but will this tutorial also works on  the first gen DELL N5110 I5-480M HD5650?

 

A year ago I tried to patch bios with the file listed in the first page, but BIOS flashing soft said the file is not compactible with my current laptop, so I did not even went further.

Also , the laptop was running fine on 10.8, full graphics, sound support without any BIOS mod.

 

Last night I sucessfully installed Niresh's OSX 10.9 on GUID'ed partition.  I didn't have a time to play around, but things that didn't work:

1. resolution not correct

2. no graphics accelleration

3.  CPU on full power mode

4. SLEEP did not work

5. No brightness FN control, of course

 

Audio works, keyboard works , touchpad works.

 

I am sure I should start with modding bios, and only then try to install everything as per tutorial (clean install with pure Mavericks from itunes). But the main question is if it's possible to mod BIOS for this I5-480M N5110?  Is it even running compatible BIOS?

Or, perhaps I must get the last BIOS from DELL for this laptop and mod it myself as per this tutorial? http://www.insanelymac.com/forum/topic/279576-dell-inspiron-15r-n5110-native-speedstep-bios-modding/

 

 

Thanks for everyone sharing their experience and knowledge!

Share this post


Link to post
Share on other sites

Hi!

 

 

It seems everyone here talks about the last gen N5110's with upgraded CPU's, but will this tutorial also works on  the first gen DELL N5110 I5-480M HD5650?

 

A year ago I tried to patch bios with the file listed in the first page, but BIOS flashing soft said the file is not compactible with my current laptop, so I did not even went further.

Also , the laptop was running fine on 10.8, full graphics, sound support without any BIOS mod.

 

Last night I sucessfully installed Niresh's OSX 10.9 on GUID'ed partition.  I didn't have a time to play around, but things that didn't work:

1. resolution not correct

2. no graphics accelleration

3.  CPU on full power mode

4. SLEEP did not work

5. No brightness FN control, of course

 

Audio works, keyboard works , touchpad works.

 

I am sure I should start with modding bios, and only then try to install everything as per tutorial (clean install with pure Mavericks from itunes). But the main question is if it's possible to mod BIOS for this I5-480M N5110?  Is it even running compatible BIOS?

Or, perhaps I must get the last BIOS from DELL for this laptop and mod it myself as per this tutorial? http://www.insanelymac.com/forum/topic/279576-dell-inspiron-15r-n5110-native-speedstep-bios-modding/

 

 

Thanks for everyone sharing their experience and knowledge!

You should try patch your dsdt first.

Share this post


Link to post
Share on other sites

Hi!

 

 

It seems everyone here talks about the last gen N5110's with upgraded CPU's, but will this tutorial also works on the first gen DELL N5110 I5-480M HD5650?

 

A year ago I tried to patch bios with the file listed in the first page, but BIOS flashing soft said the file is not compactible with my current laptop, so I did not even went further.

Also , the laptop was running fine on 10.8, full graphics, sound support without any BIOS mod.

 

Last night I sucessfully installed Niresh's OSX 10.9 on GUID'ed partition. I didn't have a time to play around, but things that didn't work:

1. resolution not correct

2. no graphics accelleration

3. CPU on full power mode

4. SLEEP did not work

5. No brightness FN control, of course

 

Audio works, keyboard works , touchpad works.

 

I am sure I should start with modding bios, and only then try to install everything as per tutorial (clean install with pure Mavericks from itunes). But the main question is if it's possible to mod BIOS for this I5-480M N5110? Is it even running compatible BIOS?

Or, perhaps I must get the last BIOS from DELL for this laptop and mod it myself as per this tutorial? http://www.insanelymac.com/forum/topic/279576-dell-inspiron-15r-n5110-native-speedstep-bios-modding/

 

Follow the post installation steps...

 

Thanks for everyone sharing their experience and knowledge!

Share this post


Link to post
Share on other sites

Hi!

 

 

It seems everyone here talks about the last gen N5110's with upgraded CPU's, but will this tutorial also works on  the first gen DELL N5110 I5-480M HD5650?

 

Your model is not N5110, but N5010, which has HM57 chipset and first generation Intel Core i-processor. 

Share this post


Link to post
Share on other sites

 

Hi! I'm running Mavericks 10.9.2 on my Dell Inspiron N5110 (i7-2630QM, 6GB RAM DDR3, nVidia GT 525M and 640GB HDD), but I have three problems:

 

1. I couldn't find any AppleHDA.kext patched for my IDT 92HD87B1, so I'm using VoodooHDA, but I've got other issues:

i. The "Mute" button from the keyboard doesn't work. It shows that mute image, but the volume isn't muted. Originally, the volume slider didn't work either, but I fixed that editing the .plist file inside the .kext.
ii. The sound is fuzzy. 
 
2.My VGA port doesn't always work, it works only after sleep. 
 
3. If I boot my laptop now and set the brightness to 100% (it looks more like 50%), put the laptop to sleep and then wake it up, the display is even brighter (the real 100%). This is not a major issue, it's just for aesthetic purpose, but it might be related two 2.

 

YOu should try bios mod and dsdt patch on the Post#1 of this topic. my laptop every thing work fine!

Share this post


Link to post
Share on other sites

good day,

1)I updated the bios mod  A11, now a fan spinning at maximum speed .how old bios or what to do now? 

2)Maverics OS setup installation stops at   AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving). 

dell 5110-8507

 

sorry for my english , best regards.

Share this post


Link to post
Share on other sites

Please help me,

 

I'm using:

Dell Inspiron N5110
Intel Core i5 2430M
Intel HD Graphics 3000 and NVIDIA GeForce GT 525M
 

I'm sure that I've followed exactly the instruction on #1 post. I've also tried both Have Nvidia and No have Nvidia DSDT. But I still get set stuck in Apple Loading screen.

13480742903_844bab3ee3_b_d.jpg

Share this post


Link to post
Share on other sites

good day,

1)I updated the bios mod  A11, now a fan spinning at maximum speed .how old bios or what to do now? 

2)Maverics OS setup installation stops at   AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving). 

dell 5110-8507

 

sorry for my english , best regards.

same problem here :)

Share this post


Link to post
Share on other sites

Please help me,

 

I'm using:

Dell Inspiron N5110

Intel Core i5 2430M

Intel HD Graphics 3000 and NVIDIA GeForce GT 525M

 

I'm sure that I've followed exactly the instruction on #1 post. I've also tried both Have Nvidia and No have Nvidia DSDT. But I still get set stuck in Apple Loading screen.

 

You should delete AppleRTL8169Ethernet.kext then try boot again with flag: -f -x -v

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×