Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Mohamed Khairy

{Guide} DELL INSPIRON N5110

Recommended Posts

guys so after installing os 10.9 and updating to dev 5 my touch doesnt work  dont know why its not working i installed all kext and stuff , also mouse clicks some times dont work  using a usb mouse 

Share this post


Link to post
Share on other sites
Advertisement

yup cause it was super awesome now , if u could help me out getting this stupid touch pad to work and maybe get the usb mouse work better ,,, that would be great :D

Share this post


Link to post
Share on other sites

Hi, ive installed the system right the first post says. But a i have two "little" problems:

 

1. The trackpad doesnt work properly: when im going to tap (click) the cursor going crazy (moves by self so i can't click accurate)

 

2. The Wifi signal is almost null, and, when its connected, the connection drops out.

 

Ive tested all alphas and betas ALPS touchpad kexts in the thread but all of them doesnt work (no cursor and keyboard doesnt work). When i use the voodoops2 located in Post install, it works but the trackpad is almost unusable.

 

Im using the DSDT that posted Dr. Hurt on his Extra Folder attached to thread.

 

 

Thank you for reading

Share this post


Link to post
Share on other sites

Hi everyone. I have installed Mac Os X 10.8.3 on my Inspiron N5110.  A while it worked nice. Then I haven't run it about a month. Now I have problems with the display.
Here are some screenshots:

post-1165093-0-65082700-1377187914_thumb.jpg

post-1165093-0-66222700-1377187922_thumb.jpg

post-1165093-0-86694000-1377187931_thumb.jpg

Does anyone know how to make it show normally? What do I need to install or do?

Share this post


Link to post
Share on other sites

Dr. Hurt, how can I enable it. I don't know a thing in all this.

Thanks. It helped. Don't know for how much time, but I don't see artifacts at moment.

 

"reduced", it means that artefacts are something normal?

Share this post


Link to post
Share on other sites

Hey guys =) i've been trying to install mac to my laptop (specs are in my sig.) but i have few problems

 

- BIOS doesnt recognize hackintosh USBs, even when i try to write a rboot cd usb doesnt show up, I've tried iAtkos L and ML1 and 2 and also another Distro Turkish fellows made. (I thought if it would be about windows usbs but it recognizes Linux based USBs as well)

- When i try to use a DVD mostly even setup screen doesnt show up but i got it only in iAtkos ML1 DVD, mouse pad wasnt working and usb mouse was acting weird but after a couple of times of trying with -f -v or graphicsenabler = no i made it work but it always crashed after install. 

 

These are main problems for now. i couldnt even get to the post install part. Can anybody help me with those issues? Thanks!

Share this post


Link to post
Share on other sites

Hey guys =) i've been trying to install mac to my laptop (specs are in my sig.) but i have few problems

 

- BIOS doesnt recognize hackintosh USBs, even when i try to write a rboot cd usb doesnt show up, I've tried iAtkos L and ML1 and 2 and also another Distro Turkish fellows made. (I thought if it would be about windows usbs but it recognizes Linux based USBs as well)

- When i try to use a DVD mostly even setup screen doesnt show up but i got it only in iAtkos ML1 DVD, mouse pad wasnt working and usb mouse was acting weird but after a couple of times of trying with -f -v or graphicsenabler = no i made it work but it always crashed after install. 

 

These are main problems for now. i couldnt even get to the post install part. Can anybody help me with those issues? Thanks!

 

From what USB 2.0 or 3.0 will not boot?

Share this post


Link to post
Share on other sites

From what USB 2.0 or 3.0 will not boot?

From what USB 2.0 or 3.0 will not boot?

Nothing boots neither 2 nor 3.

Share this post


Link to post
Share on other sites

@SpartakusMd:

 

Enable Chameleon's graphics enabler. For me it reduced the artefacts a lot. 

Am I right in thinking enabling graphics via boot loader will bypass any DSDT edits for graphics?

 

I ask as my friends inspiron has been plagued with artifacts from day one, they are not too bad most of the time, but no nearly as good as my pro book..

 

Maybe this is an option he can try, any downsides to using graphics enabler?

Share this post


Link to post
Share on other sites

I am uncertain as to why some people seem to see these artifacts more than others. As this point, I believe only the HD 3000 has this problem, but I only saw it when I used an older version of FakeSMC. My steps to prevent them: patch my own DSDT as slight hardware differences could be an issue and always repair permissions and caches.

Share this post


Link to post
Share on other sites

I am uncertain as to why some people seem to see these artifacts more than others. As this point, I believe only the HD 3000 has this problem, but I only saw it when I used an older version of FakeSMC. My steps to prevent them: patch my own DSDT as slight hardware differences could be an issue and always repair permissions and caches.

I never did get that extracted DSDT patched fully... Just the modifed one that we modified, could be that, or the fact its still using an older fakeSMC..

Share this post


Link to post
Share on other sites

It was and old fakeSMC, version 4.2 perhaps...

 

I posted the DSDT extracted, untouched, but never got it patched..

 

whats the list of common patches applied to i core laptops, or a list specific to the inspiron?

 

If I had that list, I could find the patches and apply them myself and give it a go, along with the patch I have that fixed the black screen issue at boot.

Share this post


Link to post
Share on other sites

Most likely 4.2. Yes, there are Sandy Bridge specific patches, but there are also some other patches as well. For example, wifi, MCHC device, LAN is an option, and there are also cosmetic fixes/patches. 

Share this post


Link to post
Share on other sites

محمد  انا نزلت الماك تمام ع الجهاز بس مشكلتي مع الخطوات اللي بعد التنصيب ... انا بعمل كل الخطوات تمام لغايه الخطوه اللي المفروض انسخ فيها ال كيكست لما اجي انسخه الي لمسار ده  (System/Library/Extensions .)


 


بيجبلي ايرور ويقولي ان الملفات دي مش هتشتغل اعد تسطيبها مره اخري ؟؟؟


 


مع العلم اني عملت باقي الخطوات اللي قبل الخطوه دي تمااااااام بس بوصل للخطوه دي واقف


ملحوظه  انا معملتش اب ديت للماك لان النت عندي بطئ جداا ومش هعرف اعمله .... فياريت لو ده هو السبب قولي اتفادي الخطوه دي اذاي


 


اسف علي الاطاله وفي انتظار مساعدتك


Share this post


Link to post
Share on other sites

Hey guys =) i've been trying to install mac to my laptop (specs are in my sig.) but i have few problems

 

- BIOS doesnt recognize hackintosh USBs, even when i try to write a rboot cd usb doesnt show up, I've tried iAtkos L and ML1 and 2 and also another Distro Turkish fellows made. (I thought if it would be about windows usbs but it recognizes Linux based USBs as well)

- When i try to use a DVD mostly even setup screen doesnt show up but i got it only in iAtkos ML1 DVD, mouse pad wasnt working and usb mouse was acting weird but after a couple of times of trying with -f -v or graphicsenabler = no i made it work but it always crashed after install. 

 

These are main problems for now. i couldnt even get to the post install part. Can anybody help me with those issues? Thanks!

 

Ok weirdly i managed to boot iAtkos L1 for once after then it was mostly stuck on apple logo with loading circle. the problem was since that there was no internet i downloaded kexts to usb but this time none of the usbs recognized, not my thumb drive, and 1TB HDD. also Keyboard didnt work as well i had to use usb keyboard. i could use usb Mouse an keyboard but wasn't able to use any drives. My Cousin has an old macbook i'm waiting for her to make a Mountain Lion thumb drive with mac.

 

Can anybody help me?

 

Eren

Share this post


Link to post
Share on other sites

Ok weirdly i managed to boot iAtkos L1 for once after then it was mostly stuck on apple logo with loading circle. the problem was since that there was no internet i downloaded kexts to usb but this time none of the usbs recognized, not my thumb drive, and 1TB HDD. also Keyboard didnt work as well i had to use usb keyboard. i could use usb Mouse an keyboard but wasn't able to use any drives. My Cousin has an old macbook i'm waiting for her to make a Mountain Lion thumb drive with mac.

 

Can anybody help me?

 

Eren

What prevents to do everything as a guide in the first post? This is a 100% working guide.

Share this post


Link to post
Share on other sites

You need to specific _DSM patches, one for HDEF and one for iGPU, to facilitate HDMI audio. With that in mind, you also need patched AppleHDA for your system. I saw a user configuration that included a patched SNBGraphicsFB.kext, but I'm not sure that's necessary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×