Jump to content
Mohamed Khairy

{Guide} DELL INSPIRON N5110

3,262 posts in this topic

Recommended Posts

so is lagy gfx fixed or not ?

Not completely. Has improved. Before it always did the same situation (generate a payment), can generate the payment, but still have little freezing to "command + c '' command + v '

Share this post


Link to post
Share on other sites
Advertisement

ماشى يا اهلاوى ومبروك التعادل مع انتاج ميونيخ :D

 

one question..should i install snow then 10.6.8 then upgrade to lion or lion directly??

Share this post


Link to post
Share on other sites

ماشى يا اهلاوى ومبروك التعادل مع انتاج ميونيخ :D

 

one question..should i install snow then 10.6.8 then upgrade to lion or lion directly??

 

I installed with direct lion. You need to prepare for the lion to run on a usb drive.

See: http://theappledaily.com/2011/07/20/how-to-install-os-x-lion-from-usb-pen-drive-clean-install/

You can also install chameleon or chimera directly to the USB drive.

 

حظا سعيدا

Share this post


Link to post
Share on other sites

ماشى يا اهلاوى ومبروك التعادل مع انتاج ميونيخ :D

 

one question..should i install snow then 10.6.8 then upgrade to lion or lion directly??

اهلاوى مين يا عم تصدق انا اتقفلت

انا زملكاوووووووووووووووووى

لا وانت من خلال snow leopard

هتعمل فلاشة تسطيب للنسخة

lion 10.7.0 gm

وهتلاقى شرح لطرق كتير ازاى تعمل الفلاشة

لو معرفتش قولى وانا هساعدك

Share this post


Link to post
Share on other sites

اهلاوى مين يا عم تصدق انا اتقفلت

انا زملكاوووووووووووووووووى

لا وانت من خلال snow leopard

هتعمل فلاشة تسطيب للنسخة

lion 10.7.0 gm

وهتلاقى شرح لطرق كتير ازاى تعمل الفلاشة

لو معرفتش قولى وانا هساعدك

 

Got your intel 3000 HD graphics working with QE/CI?

I am planning to get a double layered DVD and install a retail version of lion as I have always used distros especially iAtkos

maybe that would fix my graphics issues hanging especially on full screens

would also appreciate your own method which you used for your hackintosh from A to Z

 

مقلق أكتب عربى علشان حاسس إنه مش مسموح :angel_not:

Share this post


Link to post
Share on other sites

i used this guide for understanding making lion bootable for setup

http://www.insanelymac.com/forum/index.php?showtopic=260594

 

and modified it for me

just make restore to usb flash memory

 

copy mbr patched stuff to there places

install bootloader throw chamleon wizard

use extra folder

now you are ready to boot from usb flash memory to setup lion ;)

Share this post


Link to post
Share on other sites

run myfix then use this flag :)

DSDT fix or what? I have another model - Vostro 3350, sound works just great but can't load with UseKernelCache. Found this my fix utility. I'll try.

Share this post


Link to post
Share on other sites

23/jan/2012 - Do not Work.

 

I have not found a solution to the freeze(Intel HD 3000). Perhaps this can be a problem updating the BIOS. What bios version the lion is working without freezing?

 

I'm using the A09.

 

I will try to revert to my story, let me know the versions of the bios that the lions are running stably.

Share this post


Link to post
Share on other sites

I have not found a solution to the freeze(Intel HD 3000). Perhaps this can be a problem updating the BIOS. What bios version the lion is working without freezing?

 

I'm using the A09.

 

I will try to revert to my story, let me know the versions of the bios that the lions are running stably.

 

iam using a09

try this this

http://www.insanelymac.com/forum/index.php?showtopic=259705&view=findpost&p=1785172

 

myfix, kext utility, manual cache rebuilding... nothing helps, can't load AppleHDA.kext if I use UseKernelCache=Yes flag

try new install

Share this post


Link to post
Share on other sites

Hi Mohamed,

 

my n5110 is i7 with 8 gigs ram A9 bios

intel hd 3000 and gt525m

 

I got most hw working but I have problems with gt525 recognition. In System information i get the following for my 525m:

 

525m Video card is named Display without any DRAM

Display:

 

Type: GPU

Bus: PCIe

PCIe Lane Width: x16

Vendor: NVIDIA (0x10de)

Device ID: 0x0df5

Revision ID: 0x00a1

 

Even the latest release of chameleon did't recognize it properly so I compiled latest ErMac branch with additional patch to nvidia.c to calculate DRAM correctly. GraphicsEnabler=On causes system to stall after chameleon nvidia card detection because graphics enabler can't enable some nvidia cards.

 

Here are some lines from dmesg related to the nvidia card sorted by time with GraphicsEnabler=off:

 

 

NVClockX: [Warning] no nVidia graphics adapters found

NVClockX: [Warning]

NVClockX: NVClock Darwin port by alphamerik © 2010

NVClockX: usr-sse2 © 2010

NVClockX: Card: 0, Vendor ID: 10de, Device ID: df5, Architecture: 1000000, GF100 [GeForce GT 525M]

PXHCD 0xffffff80f1f2e000:UIMInitialize xHC addressing capability 64 bit register

PXHCD 0xffffff80f1f2e000:UIMInitialize HCSParams2 = 0xc0000f1

PXHCD 0xffffff80f1f2e000:UIMInitialize MAX SCRATCH PAD = 1

NVClockX: Error reading BIOS

 

No more NVClockX messages as memory mapping or so.. (no errors too)

Also used many different releases of nvclockx and fakesmc

 

 

I'm using custom dsdt with your patch which contains all sandy bridge patches (brightness keys don't work even with the patch for them) and 8.1 smbios

 

What is the device id of your 525m card ?

Any ideas for my problem?

Share this post


Link to post
Share on other sites

you are zamlkawy so you are habeb harty:D :D

I don't know why i always reply here when there is match for zamalek:D

i installed snow 10,6,8 on vmware temporarily in order to make the bootable flash..i was having eggzamz and finally finished so i will try make the bootable usb and install after the match:D

 

but i have a question.. i formated my HDD in GUID since the last time i installed the snow retail..after i installed chameleon it gave me boot0 boot 0 boot 0 but windows 7 64 bit was installed and boot eaisly although it's GUID not MBR..so can't i boot from the GUID on mac???..is it better to reformat the HDD to MBR and modified the files on lion to be installed on MBR?

واكيد اكيد هحتاج مساعدتك لان فى السنو الريتيل كانت مشكلتى فى التعريفااات والدى اس دى تى والابدينت

Share this post


Link to post
Share on other sites

Hello Mohamed.

I have a DELL N5110.

I'm not such a dummy, but i tried for 4 days all tutorials about instaling LION on my PC.

None of them worked.

Can you give me a hint, or a detailed tutorial?

Thanks a lot for your documentation :)

 

LE: My configuration is:

 

DELL INSPIRON N5110 (ACPI x64-based PC)

Motherboard: Unknown

BIOS: AMI A09 (updated)

CPU: Intel i7 - 2630QM

Memory: 8099MB

Video Adapter: Intel HD & NVIDIA GeForce 525M

IDE Controller: Intel 6series/C200 sata AHCI

USB1: Renesas Electronics USB 3.0 Host Controller

USB2: USB host

USB device: Dell Wireless 1702 Bluetooth

Network adapter: Realtek PCIe & Dell Wireless 1702

Share this post


Link to post
Share on other sites

I followed a tutorial with only one USB stick.

It boots, enters that ms-dos message mode.

It stucks by saying something about IOBluetooth not recognized and then "waiting for root device" and it freezes :)

Share this post


Link to post
Share on other sites

I followed a tutorial with only one USB stick.

It boots, enters that ms-dos message mode.

It stucks by saying something about IOBluetooth not recognized and then "waiting for root device" and it freezes :)

 

Try powering off wireless card/bluetooth and also make sure your sata configuration is set to AHCI.

Also I recommend you to use this manual: http://www.insanelymac.com/forum/index.php?showtopic=256729

 

My configuration is with i7 2670QM and centrino wireless-n 1030 card.

 

You must be able to boot without any problems with this installation guide (maybe you will need external keyboard and mouse).

After the installation you will need ONLY the files attached by Mohamed. Don't try patching the dsdt for the 525M because it's useless at this time.

Also be carefull with the VoodooHDA which can cause kernel panics.

Share this post


Link to post
Share on other sites

Hi Mohamed,

 

I tried to PM you, but maybe your pm box is full

 

can you follow this issue http://forge.voodoop...eon/issues/215/ and share your expirience too.

 

Thanks,

Alexander

 

see first for nvidia card we don't have working driver

i injected nvidia card throw dsdt and tried many setting but driver not assigned to work

 

as apple nvidia next don't have part for optimus

 

so injection not will help even from chamelon

 

so you don't need chameleon injection

 

as our intel card work vinalla with out any touch from us

 

so no need to add gfxenabler to boot.plist

 

 

cosmetic for the nvidia card on system profiler you can use injection throw dsdt as on dsdts on topic

 

 

 

---------------------------------------------------------------------------

 

if any one have torrent leech invitation please send me invitation throw PM :D

my account had disabled :P

 

cleaned my inbox :)

Share this post


Link to post
Share on other sites

In BIOS, the mode is set to AHCI ... and i have no posibility to disable the wireless / bluetooth card.

I used USB2.0 ...

Still nothing ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×