Jump to content
Mohamed Khairy

{Guide} DELL INSPIRON N5110

3,333 posts in this topic

Recommended Posts

Advertisement

Partitioned the hole hard drive with Master Boot Record at 1 partition only formatted with Mac OS X Journaled and installed to it.

 

After installation completed, booted into USB and choosed the drive I installed to with "-x -v" and the exact same problem happens!

Seems like I formatted it for nothing :wallbash: :wallbash:

Share this post


Link to post
Share on other sites

Partitioned the hole hard drive with Master Boot Record at 1 partition only formatted with Mac OS X Journaled and installed to it.

 

After installation completed, booted into USB and choosed the drive I installed to with "-x -v" and the exact same problem happens!

Seems like I formatted it for nothing :wallbash: :wallbash:

strange

is installation is competed successfully ?

 

the problem of still waiting for root

means that mac cant read the partion contain mac

means that the kext for sata controller not loaded or not compatible

but our sata controller works defaultly on achi mode on mac

means that sata kext not loaded or corruptted !!

------------------------------------------------------------

some tries to do !!

1- load all kexts using this flag

UseKernelCache=No -f -v

respect captial and small

 

2- open installer and open from it terminal and there is import option you can browse mac partion go to system / library / extensions

and check for appleahciport.kext ioahcifamily.kext

 

3- may be the lion you downloaded is corrupted !!

 

this is my thoughts now about your problem

 

do try if fail go for next try

Share this post


Link to post
Share on other sites

Tried "UseKernelCache=No -f -v" with same problem

Both kexts are there and installed

 

filename: h-ml1073.dmg

md5: 18542A8A1A16657257BA0B5263F5B044

sha-1: 8EF208772F878698E9DD92B3632E25B23FFC9CA7

Share this post


Link to post
Share on other sites

will check it

 

to me i downloaded it from torrentleech and after extract MD5 checker says

18542A8A1A16657257BA0B5263F5B044

 

as one you posted did you checked one you have or you copied md5 from download site ?

Share this post


Link to post
Share on other sites

I checked the one I downloaded with HashTab

 

edit: I will use a VMware image to prepare the USB again and will give it another try as I can't install iAtkos now on the laptop :(

Share this post


Link to post
Share on other sites

Leopard didn't work, chimera installer hanged while installing it to the USB flash and it seems because I must use Snow Leopard

Downloaded Snow Leopard 10.6.5 vmware image and will try tonight!

Share this post


Link to post
Share on other sites

Hi, I have successfully installed Lion on my Dell Inspiron N5110, and everything works great, except keyboard. No matter what i do, i can't get vertical line. I have added newest kext, and selected ISO European, but still not working. Can somebody help me with this problem? Thanks

Share this post


Link to post
Share on other sites

Prepared the usb from 10.6.5 vmware image and I got the same problem

Used "UseKernelCache=No -f -v" and got the same problem

The kexts you mentioned are in the mac partition as I checked with the import of terminal

And the md5 matches so I don't know what is the problem :(

 

So far I have formatted the whole hard disk and downloaded like 7 gegas for nothing, no result at all and as well as not being able to use iAtkos anymore as I can't revert to bios A07 and it doesn't work with A09

Share this post


Link to post
Share on other sites

Hi, I have successfully installed Lion on my Dell Inspiron N5110, and everything works great, except keyboard. No matter what i do, i can't get vertical line. I have added newest kext, and selected ISO European, but still not working. Can somebody help me with this problem? Thanks

 

dont understand you

is all keyboard dont work or one key doesnt work !!

 

Prepared the usb from 10.6.5 vmware image and I got the same problem

Used "UseKernelCache=No -f -v" and got the same problem

The kexts you mentioned are in the mac partition as I checked with the import of terminal

And the md5 matches so I don't know what is the problem :(

 

So far I have formatted the whole hard disk and downloaded like 7 gegas for nothing, no result at all and as well as not being able to use iAtkos anymore as I can't revert to bios A07 and it doesn't work with A09

 

see your PM

Share this post


Link to post
Share on other sites

Hello Mr Khairy, i thank you so much for your Guide, So all works for me except some stuffs like Wifi cuz

 

i have the heated BCM4313 with a strange PID & VID, something like 14e4-4727 and HDMI.

 

Anyway, i have some remarks :

 

1- About the backlight, the first thing it becomes much powerful after wake (same remark that Lucky

 

luck), the Pc believes it is on battery, the second thing, when you are on AC and u do nothing, the

 

screen darkens quickly after 1 or 2 minutes, but this option is only when Pc is on Battery.

 

2- Now my Pc is on AC adapter (i removed the battery), i want to update software & it displayed to me a

 

message like what my Pc isn't on AC !! (see the attachment)

 

Any :idea:

 

My English Sucks :wallbash:

post-822381-0-78298400-1335891815_thumb.jpg

Share this post


Link to post
Share on other sites

your notebook is not our notebook

so you didn't used used my dsdt

you need to patch your dsdt

anther thing why you remove your battery !!!

when opening mac from restart or shutdown the highest brightness is lower than must be

after sleep or screen sleep

this is corrected

this isn't a big problem to searh on it now

 

about photo you posted idont understand it :(

 

can you post your untouched dsdt table extract it from aida64

Share this post


Link to post
Share on other sites

the `~ is beside 1 and above tab, and \| is above enter on my keyboard

not use voodoops2keyboard from update use it from post install or preinstall folder

you will find it under voodoops2controller /contents /plugins

Share this post


Link to post
Share on other sites

your notebook is not our notebook

so you didn't used used my dsdt

you need to patch your dsdt

anther thing why you remove your battery !!!

when opening mac from restart or shutdown the highest brightness is lower than must be

after sleep or screen sleep

this is corrected

this isn't a big problem to searh on it now

 

about photo you posted idont understand it :(

 

can you post your untouched dsdt table extract it from aida64

 

No worry, i use my own DSDT, i got it from DSDTSE, i patch it using somes patches for Sandybridge (comes with DSDT Editor), but for the brightness i have the opposite thing, when a open the mac from restart, i have a level of brightness much higher than must be :S

 

in the attachment, the DSDT without patch and the DSDT patched that i use now.

 

And Yes our Notebook are different but are from the same family :D, your VoodooHDA, AppleIntelCPUPowermanagement, AppleIntelSNB, & more kexts work fin for me !!!

DSDTnative.dsl.zip

DSDT Patched.aml.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×