Jump to content
Mohamed Khairy

{Guide} DELL INSPIRON N5110

3,340 posts in this topic

Recommended Posts

ok, so regarding my "clover not booting to UEFI hands-free" problem referred to in the previous very long-winded post ...

 

after trying many things, i solved this problem by using efibootmgr in a usb linux distro, looking at the number for "Hard Drive" in the UEFI list (entry 0001, which was set up to be picked dead last for some odd reason), and then setting that entry as what i wanted the system to boot. boom. fixed the problem. system now boots to the UEFI Clover setup.

 

i can edit the previous post down if need-be, but i imagine someone else having this problem may benefit from having it cached in search engines.

 

meanwhile ...

 

i'm having some other interesting issues.

 

i got audio to function on this thing using AppleALC, per a previous post in this thread.

 

then i managed to get the HD3000 drivers installed and functional using the rehabman config.plist and DSDT patches for the HD3000 drivers ... but with the HD3000 stuff setup, audio stops functioning. 

 

if i switch back to the previous config.plist, i get audio back, of course...

 

i tried 'merging' all the bits of the functional audio config.plist with the functional hd3000 config.plist, but audio still will not werk. also tried the rehabman DSDT patch for "audio hdef layout 12" on top of the functional HD3000 setup, but still have no audio.

 

any ideas, anyone? 

Share this post


Link to post
Share on other sites
Advertisement

Hello rezsicc, please do not write requests in private. Make it visible to everyone, this way you can be better helped

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/10/2019 at 11:02 PM, dee-mon said:

the short version of that story, and i suppose a big part of necessary information there, is that i made a mojave installer stick with that-which-shall-not-be-named-on-this-forum and used that to install it onto the system. also, another small detail is that, like anyone else that tries to install macOS on these craptops, i had to install a version of the hacked UEFI A11 bios on the n5110.

 

the version of @Florin9doi's bios that i'm using has a modification date of April 6th 2018... so if there's anything newer/better that's been put together since then that may help solve my problem, may show more info or have some 'new' options to modify in the bios, i'm all ears...

 

https://www.dropbox.com/s/0wmx3ovht2lavws/N5110_bios_spec.zip?dl=0

Bios A11 is the most recent and the file placed by Florin9doi is the last one, use that one.

 

 

Edited by Kakaro

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/10/2019 at 11:02 PM, dee-mon said:

the-beast-with-one-back created an installer stick that had a semi-generic clover setup already on it (4920), which boots up on the n5110 just fine... and i could boot win7 from the usb stick as well, but any and all attempts to put Clover on the EFI partition were fruitless. nothing seemed to want to "bless" the EFI partition and make it bootable. i tried quite a few things...setting the partition as active using the Win7 usb stick i have to repair the efi partition (which would fix it but then you could only boot to win7 and putting Clover on the EFI partition afterward stuck like jello nailed to a wall), the Clover installer pkg, etc.

Use Clover Configurator to open EFI partition and install clover here. Put kext in kext/others


When you boot the computer with clover, select the clover boot options and select the first option for clover to boot the EFI partition. Remember to place the DSDT and the SSDT

 

Captura de Pantalla 2019-08-19 a la(s) 18.06.23.png

Edited by Kakaro

Share this post


Link to post
Share on other sites
On 8/10/2019 at 11:02 PM, dee-mon said:

when attempting to boot from the hard drive after this, using a straight-up, no-hands boot process (ie power button only), the version of clover that boots up is displaying in 1024x768, and appears to be the 'bios' version (the info page lists the AMI firmware and no mention of UEFI). win7 will boot from this side when pointed at the "Windows 7 from EFI" option but it's only partially functional -- some drivers under win7 absolutely DO NOT WERK when booting up like this, the audio chipset being the prime example. and mojave simply won't boot at all. i have verbose mode on, and it usually dies right after the little EFI "preamble" before the main boot process starts. 


Windows does not work well with uefi on these computers, since they were made to boot by bios. You will never have sound in windows. You must install Windows without the UEFI option

Share this post


Link to post
Share on other sites

hello to everyone friends dell inispiron n5110 notebook i use my computer mac os x high sierra kulu was running smoothly now i wanted to install mac os x mojave setup the computer seamlessly booted from the computer problem when I amma can not reach the table please help.

20190821_201545.jpg

Available Date / Date: 21 Aug 20 19 Carsamba, 16:01:13

Computer Name: DESKTOP-NN51GFS Windows 10 Pro 64bit (10.0, Build 10240) 1slebm

System Language: English (Boigesel Tuning System System System: Dell Inc.

System Model:  Inspiron N5110 BIOS: A11 Processor: Intel (R) Core9 5-2430M CPU 240GH 2Hz

Ram: 4096MB RAM Paging file 4718MB usable 2996MB DirectX Directly printing your digital signatures

Share this post


Link to post
Share on other sites
Posted (edited)


 

3 hours ago, Akosh114 said:

hello to everyone friends dell inispiron n5110 notebook i use my computer mac os x high sierra kulu was running smoothly now i wanted to install mac os x mojave setup the computer seamlessly booted from the computer problem when I amma can not reach the table please help.

 

Available Date / Date: 21 Aug 20 19 Carsamba, 16:01:13

Computer Name: DESKTOP-NN51GFS Windows 10 Pro 64bit (10.0, Build 10240) 1slebm

System Language: English (Boigesel Tuning System System System: Dell Inc.

System Model:  Inspiron N5110 BIOS: A11 Processor: Intel (R) Core9 5-2430M CPU 240GH 2Hz

Ram: 4096MB RAM Paging file 4718MB usable 2996MB DirectX Directly printing your digital signatures

Explain the method you are using to install Mojave. Clover version, what are the kext you are using

Edited by Kakaro

Share this post


Link to post
Share on other sites

thank you for the answer I used the raw file ready osxinfo10146.raw clover version 2.5k rev 5018  in the other folder just kext fakesmc no more

20190822_003348.jpg

Share this post


Link to post
Share on other sites
32 minutes ago, Akosh114 said:

thank you for the answer I used the raw file ready osxinfo10146.raw clover version 2.5k rev 5018  in the other folder just kext fakesmc no more

20190822_003348.jpg

N5110 HD3000 is not supported by Mojave. You should use the installation method suggested by nanotech

 

Share this post


Link to post
Share on other sites

hello everyone thanks Kakaro n5110 mac os x mojave successfully installed but can not identify the Intel hd 3000 graphics card please help please hd hd 3000 384 mb problem

20190824_222059.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, Akosh114 said:

hello everyone thanks Kakaro n5110 mac os x mojave successfully installed but can not identify the Intel hd 3000 graphics card please help please hd hd 3000 384 mb problem

20190824_222059.jpg


Did you use the dosdude1 tool when rebooting the system? You have to patch using macOS Mojave Patcher

 

Notice that you have installed the system as if it were an imac You must do it as MacBook pro 8.1

 

No problem you have only 384 MB of memory in HD3000, you only have 4GB of ram installed. To upload to 512 MB in HD3000, increase the RAM memory by at least 8GB

 

imageproxy.php?img=&key=c17464ef1b1b51c7imageproxy.php?img=&key=c17464ef1b1b51c7imageproxy.php?img=&key=c17464ef1b1b51c7

Captura de Pantalla 2019-08-24 a la(s) 17.07.45.png

Captura de Pantalla 2019-08-24 a la(s) 17.40.47.png

Captura de Pantalla 2019-08-24 a la(s) 17.42.12.png

Captura de Pantalla 2019-08-24 a la(s) 17.42.45.png

Edited by Kakaro

Share this post


Link to post
Share on other sites
On 8/20/2019 at 12:21 AM, Kakaro said:

Hello rezsicc, please do not write requests in private. Make it visible to everyone, this way you can be better helped

 

 

Hey,

 

I've seen that you would able to install the newest version of Mac OS and it works perfectly for you. I need your help!

I've tried to install El Capitan on my machine, but after the Post Install I had no success so I decided to roll back to Yosemite.

Unfortunately lots of apps are already deprecated or unsupported, so I can't install them on my system on 10.10.

Could you provide me proper kexts for the newest OS, please?! 

 

Mohamed Khairy's tutorial is very outdated and I can't find proper kexts...

Here is my entry, but nobody has reacted on my post.

https://www.insanelymac.com/forum/topic/271573-guide-dell-inspiron-n5110/?do=findComment&comment=2669065

I am waiting for your response!


Thanks in advance,

Tibor

Share this post


Link to post
Share on other sites

thank you imac the reason for the appearance of config pelis I have set yes mac os mojave phatc used 384 mb image card is normal why my computer is running delayed and color discoloration

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/25/2019 at 12:24 PM, rezsicc said:

Hey,

 

I've seen that you would able to install the newest version of Mac OS and it works perfectly for you. I need your help!

I've tried to install El Capitan on my machine, but after the Post Install I had no success so I decided to roll back to Yosemite.

Unfortunately lots of apps are already deprecated or unsupported, so I can't install them on my system on 10.10.

Could you provide me proper kexts for the newest OS, please?! 

 

Mohamed Khairy's tutorial is very outdated and I can't find proper kexts...

Here is my entry, but nobody has reacted on my post.

https://www.insanelymac.com/forum/topic/271573-guide-dell-inspiron-n5110/?do=findComment&comment=2669065

I am waiting for your response!


Thanks in advance,

Tibor



Hi, you need help installing El Capitan or Mojave. 


Please indicate the characteristics of your laptop

Edited by Kakaro

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/26/2019 at 6:48 PM, Kakaro said:



Hi, you need help installing El Capitan or Mojave. 


Please indicate the characteristics of your laptop

Dear Kakaro,

If Mojave works also smoothly, then it will be better! :)

Edited by rezsicc

Share this post


Link to post
Share on other sites
6 hours ago, rezsicc said:

If Mojave works also smoothly, then it will be better!

Work very well.

Your laptop is a inpiron N5110? What processor do you have?

Share this post


Link to post
Share on other sites

Hi Kakaro Would the VRAM enhancement benefit the computer to work faster? 384 mb is working very slowly thanks

Share this post


Link to post
Share on other sites
Posted (edited)

There is mixed feeling on this but I always found it beneficial on my E6220. Since upgrading RAM to 8GB and patching HD3000 VRAM to 2048MB, graphics have been working rather well. You can do no harm by patching to 512MB to begin with and compare performance. If required, you may then gradually increase that to, say, 1GB or 2GB.

 

This being said, I wouldn't say that increasing VRAM will dramatically increase overall computer performance. If your laptop feels slow, it's more probably due to its CPU. That or your CPU power management needs revisiting... And, of course, bear in mind that you're running with officially unsupported graphics!

 

Edited by Hervé

Share this post


Link to post
Share on other sites
5 hours ago, Akosh114 said:

Thanks for your reply intel hd 3000 How much gb support ? How much can I upgrade with 8gb ram

You can only patch HD3000 if you use MacOS High Sierra or earlier version. Mojave not since this card is not supported. It is being forced to be recognized

You need upgrade the ram to 8GB 

Share this post


Link to post
Share on other sites
Posted (edited)

@Kakaro, I don't see why the VRAM patch would not work in Mojave or later. After all, it consists of a simple binary patch of the SNB Framebuffer kext that modifies those default VRAM values that are set according to the amount of RAM. What is done to get non-Metal acceleration on Mojave and later if not installing and loading the High Sierra HD3000 graphics kexts which, obviously, include the SNB framebuffer? Of course the patch(es) will work.

 

It's been said before but, as detailed here, Apple allocate VRAM to HD3000 according to this:

  • 2GB RAM -> 256MB
  • 4GB RAM -> 384MB
  • 8GB RAM -> 512MB

 

@Akosh114, if you want to increase VRAM, you just need to apply the well-known High Sierra patches (assuming you're running with High Sierra's SNB graphics kexts in Mojave and later). If you currently get 384MB allocated then apply whatever patch (say 512MB or 1GB) to the default 384MB code. Details remain available in this old thread/post. If you upgrade RAM to 8GB (which I would recommend too), you'd have to apply the patch that applies to the default 512MB code and you can go straight to 2GB VRAM.

 

Edited by Hervé

Share this post


Link to post
Share on other sites
On 8/28/2019 at 11:53 PM, Kakaro said:

Work very well.

Your laptop is a inpiron N5110? What processor do you have?

Yes it is.

i5-2410m with 8GB ram memory

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×