Jump to content
Mohamed Khairy

{Guide} DELL INSPIRON N5110

3,294 posts in this topic

Recommended Posts

ok done i atlast solved the problem hurray !!!i had to install chameleon after that i guess that was the reason not sure must have been creating problem :D about webcam yes i have a different device id but anyways if u do find a solution for it please let me know or i ll have to use windows to run skype :( anyway thank you mohamud for your great support and patience without your help mac os x on my laptop would have been yet a mystery :)

Share this post


Link to post
Share on other sites
Advertisement

we are here to support us together :)

ok done i atlast solved the problem hurray !!!i had to install chameleon after that i guess that was the reason not sure must have been creating problem :D about webcam yes i have a different device id but anyways if u do find a solution for it please let me know or i ll have to use windows to run skype :( anyway thank you mohamud for your great support and patience without your help mac os x on my laptop would have been yet a mystery :)

Share this post


Link to post
Share on other sites

and thank you amiine for your dsdt and appleHDA and smbios it works ;) but seem to have a problem :( its with the usb 3 ports when i sometimes remove the mouse or flash drive i get instant kp i m not sure not all the time ...anybody facing such problem?

Share this post


Link to post
Share on other sites

and thank you amiine for your dsdt and appleHDA and smbios it works ;) but seem to have a problem :( its with the usb 3 ports when i sometimes remove the mouse or flash drive i get instant kp i m not sure not all the time ...anybody facing such problem?

 

look radiking..don't remove the mouse while you are still on the system..you will recieve KP..considering the flash drive you can unmount it first then remove it as well as in windows(EJECT)

Share this post


Link to post
Share on other sites

 

look radiking..don't remove the mouse while you are still on the system..you will recieve KP..considering the flash drive you can unmount it first then remove it as well as in windows(EJECT)

and thank you amiine for your dsdt and appleHDA and smbios it works ;) but seem to have a problem :( its with the usb 3 ports when i sometimes remove the mouse or flash drive i get instant kp i m not sure not all the time ...anybody facing such problem?

 

that's true don't remove mouse from usb 3.0 while system is starting this problem caused by the driver isn't 100% compatible but it's the best till now

Share this post


Link to post
Share on other sites

Good news for us

 

i found isight enabler with our id vendor / id product and it works for me i can now make some effect with photo booth and i can record movies via iMovie

 

and internal mic works with this kext :)

 

 

in the attached files the driver + kextutility new version

 

here is some snapshots

 

:D

isight.zip

post-232048-0-53108200-1334700260_thumb.png

post-232048-0-31623000-1334700309_thumb.png

Share this post


Link to post
Share on other sites
Good news for us i found isight enabler with our id vendor / id product and it works for me i can now make some effect with photo booth and i can record movies via iMovie and internal mic works with this kext :) in the attached files the driver + kextutility new version here is some snapshots :D

 

 

not all webcam with the same ven dev id

 

the old guide was having next for FaceTime like on macbookpro 8 the older macbookpro was having isight

 

i edited the isight next to FaceTime kext using ioreg of macbookpro 8

 

but i removed them since they need customization for ven dev id on next and not all have experience to do that

 

so will not post them on guide to make guide more simple

 

any way i will upload two next of card reader and FaceTime

and who know how to add his dev ven id can go for them :)

 

Archive.zip

facetime.png

Share this post


Link to post
Share on other sites

bluetooth is recognized after installing bluetooth kext :) but i keep getting annoying msg no keyboard found :( and i tried editing vendor id and product id my camera doesn t work :( here is my webcam ids :) if anybody can help me make it work i ll be grateful.artifacts have disappeared to an extent but do appear when a program is taking too long to repond or is not working as it has too :)

post-936303-0-29567900-1334832361_thumb.png

 

webcam is recognized as facetimeHD camera but this is what i get :(

webcamb.tiff

Share this post


Link to post
Share on other sites

open system pref --> bluetooth --> advanced --> unselect first two option

 

you didn't added dev id and vender id correct to all places

 

i think webcam won't work as problem nary webcam not compatible with mac driver

 

----------------

good news brightness keys works to me and the sun appear to me l like this

will add it next week as i will get respond for anther stuff about touchpad

Share this post


Link to post
Share on other sites

i donno where to add LOl i replaced all product ids and vendor id with mine i think that must be the problem :$ ok i m using windows at the moment .. will restart after some time and post the info.plist file please help me recitify mistakes if any :)

Share this post


Link to post
Share on other sites

Hello everyone

 

thanks to all of you brothers and a big thanks to Mohammed for his great efforts that made this pice of hardware get smoother with OSX

 

but there are some little problems most of us are struggling with

 

 

Right now I'm on 10.7.1 and I have the following issues

 

1- some little freezes especially when open apps in fullscreen.

2- artifacts are showing sometimes.

3- Webcam is not working I have the same problem that Radiking is having (the lED indicator near the webcam is on but webcam is not working).

 

I noticed that some of you

guys are on 10.7.3 and everything seems fine. this is strange because when I updated to 10.7.3 the system become unusable due to the constant freezes and artifacts

Share this post


Link to post
Share on other sites

bluetooth is recognized after installing bluetooth kext :) but i keep getting annoying msg no keyboard found :( and i tried editing vendor id and product id my camera doesn t work :( here is my webcam ids :) if anybody can help me make it work i ll be grateful.artifacts have disappeared to an extent but do appear when a program is taking too long to repond or is not working as it has too :)

post-936303-0-29567900-1334832361_thumb.png

 

webcam is recognized as facetimeHD camera but this is what i get :(

 

try this kext

FaceTime.kext.rar

Share this post


Link to post
Share on other sites

here is the Kext for brightness keys

VoodooPS2Keyboard.kext.zip

 

i will not post it on guide as code of it is too old from 2009 by ivik

 

i am trying to integrate it to new code from 2011 by slice and i am asking him for helping me on it

 

any way use it it works great

 

@ Alilajmi

did you tried method on tonymac to solve artifact

Share this post


Link to post
Share on other sites

i will trying now thankss

here is the Kext for brightness keys

VoodooPS2Keyboard.kext.zip

 

i will not post it on guide as code of it is too old from 2009 by ivik

 

i am trying to integrate it to new code from 2011 by slice and i am asking him for helping me on it

 

any way use it it works great

 

@ Alilajmi

did you tried method on tonymac to solve artifact

Share this post


Link to post
Share on other sites

here is the Kext for brightness keys

VoodooPS2Keyboard.kext.zip

 

i will not post it on guide as code of it is too old from 2009 by ivik

 

i am trying to integrate it to new code from 2011 by slice and i am asking him for helping me on it

 

any way use it it works great

 

@ Alilajmi

did you tried method on tonymac to solve artifact

 

 

I've tried it. no success :(

Share this post


Link to post
Share on other sites

Hello everyone

 

thanks to all of you brothers and a big thanks to Mohammed for his great efforts that made this pice of hardware get smoother with OSX

 

but there are some little problems most of us are struggling with

 

 

Right now I'm on 10.7.1 and I have the following issues

 

1- some little freezes especially when open apps in fullscreen.

2- artifacts are showing sometimes.

3- Webcam is not working I have the same problem that Radiking is having (the lED indicator near the webcam is on but webcam is not working).

 

I noticed that some of you

guys are on 10.7.3 and everything seems fine. this is strange because when I updated to 10.7.3 the system become unusable due to the constant freezes and artifacts

i had the same problem system was very much unstable..i deleted unwanted kexts from system/library/extensions like

delete all ATI,InteL GMA 950, X3100, HD ( Be careful dont delete 4 HD3000 kexts, AppleIntelIntegratedFramebuffer.kext, AppleIntelSNBGraphicsFB.kext and AppleIntelSNBVA.bundle, we only need these 7 Kexts ) and finally delete all NVIDIA Geforce Kexts and once again clear the caches using kext utility ( from mahesh kondrajus thread ) and restart comp u will no longer have freezes and artifacts

:) my system is very much stable now :).if ur dual booting u can delete from windows with the help of mac drive to see mac hdd then go to system/library/extensions and delete them then restart with these flags -v -f coz u might get kp use kext utility again to clear cache again and restart everything will work super smooth..i m using google chrome very stable that other browsers :)

Share this post


Link to post
Share on other sites

Dear mohammed after test your voodoops2keyboard.kext it works great thank you very much now my lappy is like real macbook pro :)

 

if we got full support for touchpad

our notebook will be Macbook Pro 8 tipcally :)

 

hope dev continue developing voodoops2 it is about more than one years the development of it had stopped :(

 

----------------------------------------

by the time

 

does any one have my work for applehda patching stuff

 

as ideleted it from my pc

 

 

please upload it here

Share this post


Link to post
Share on other sites

here is my geekbench score :)http://browse.geekbe...ekbench2/618962 well i m happy i am able to use mac os x i have been struggling from last 6 months to get it work on my hp laptop but was an utter failure :) one day nvidia 525 and optimus will also work :) lets hope for the best.webcam doesn t work even after installing those kexts :( sad but anyways no problem i have windows 7 for backup :) i can always u it when i need video calling

Share this post


Link to post
Share on other sites
i had the same problem system was very much unstable..i deleted unwanted kexts from system/library/extensions like

delete all ATI,InteL GMA 950, X3100, HD ( Be careful dont delete 4 HD3000 kexts, AppleIntelIntegratedFramebuffer.kext, AppleIntelSNBGraphicsFB.kext and AppleIntelSNBVA.bundle, we only need these 7 Kexts ) and finally delete all NVIDIA Geforce Kexts and once again clear the caches using kext utility ( from mahesh kondrajus thread ) and restart comp u will no longer have freezes and artifacts

:) my system is very much stable now :).if ur dual booting u can delete from windows with the help of mac drive to see mac hdd then go to system/library/extensions and delete them then restart with these flags -v -f coz u might get kp use kext utility again to clear cache again and restart everything will work super smooth..i m using google chrome very stable that other browsers :)

 

 

Hello radiking

 

thanks for your help

 

I applied your method I deleted all the mentioned kexts then I cleared caches many times but the problem still occur :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×