Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Marvell 88SX7042 4 Port SATA II support (Digitus 30104 PCI-E card)

4 posts in this topic

Recommended Posts

Hi all,


I' trying to get my Digitus 30104 4-Port SATA II PCI-E card running under Lion 10.7.2


First of all, here's some info on the card:



It uses a Marvell 88SX7042 chip. There is no OSX support.


The card appears to be identical to these cards according to specs and images:


I found two drivers for OSX that come with cards that use the same chip:

  • sonnet tempo sata e4i
    This card looks very similar (but misses the 2 eSATA ports and the jumpers to activate them). Furthermore, some review on Newegg mentions, that a Rosewill RC-218 (see above) is detected in Windows 7 as this card.
  • HighPoint RocketRaid
    They have some cards of the 23xx series, which use a 88SX7042 and have native support in Lion (HighPointRR.kext). However, none of them looks similar.


I followed this guide on kext editing:



I figured out the PNPID is 0x704211AB


First attempt: Modifying HighPointRR.kext

See attachment for resulting kext.

With the PNPID, the card is detected.

Unfortunately, connected SATA hard drives are not detected.

I didn't find any errors in the system log files.


Second attempt: Modifying SonnetSATA.kext

I extracted the SonnetSATA.kext from the driver packet that came from the official website.


Apart from injecting the PNPID, I removed the secondary device match stuff from the info.plist.

See attachment for resulting kext.

This version detects the card and connected hard drives.

The log says:

kernel: SonnetSATA::init 2.2.6, © 2004-2010 Sonnet Technologies, Inc.
kernel: SonnetSATA::detectDeviceType@0: Marvell 88SX7042 detected Disk Drive ST2000DL003-9VT166 CC32 6YD0GV3L

However, the problem is that the drives appear as "not initialized".

(I tested with a drive GUID and a single HFS+ partition with data and a drive with GUID and a single NTFS partition, which worked fine under Windows 7)

When I use DiskUtil, to initialize and partition the drive (GUID and single HFS+ partition), it gets stuck at "waiting for volumes to be displayed" (or similar - it's a rough translation from the German UI)

No errors are reported.


At this point I a stuck. I got the feeling, I am really close. It's probably only some minor tweak of the settings - but I have no idea where and what to change.


Any suggestions are welcome. Perhaps some of you owns one of these cards and could try him/herself.






Share this post

Link to post
Share on other sites

I just verified that the card is working fine under Windows 7 with the current driver provided by SonnetTech.

So where's the problem in Lion? I also tried earlier driver version (2.2.1 is the 1st that supports Lion) but all with the same result.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.