Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
E-Chris

Sil3114 (AppleVIAATA) in Lion?

2 posts in this topic

Recommended Posts

I want to use a Silicon Image 3114 SATA card in my Lion system. In the past (on earlier OS's), all I would do was add a line in the VIASATA.kext file.... but I don't see this file in Lion.

 

How do I add support for VIA SATA or more specifically the Silicon Image SATA chipsets in lion?

 

Appreciate any help,

Thanks

Share this post


Link to post
Share on other sites

You need AppleVIAATA.kext to boot into any OS X system using a Sis chipset. I have "Still waiting for root device" error otherwise. I needed to copy this kext into the setup first to boot the Lion installation. Then after installing Lion, I am in a process of installing windows on a second partition on the same drive and then copy the kext file into the mac partition on which I just installed Lion. It should then work. The kext files should be copied into S/L/E/

 

Basically you need AppleVIAATA.kext to boot into root device.

 

Anybody has any idea how to install a kext along with other system kext along with the installer?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • i think the "red light" you are referring to is that you have a optical SPDIF output (3.5 mm) combo jack. it most likely will be "red" when audio is active. 
    • Domanda , ma il tuo configplist lo ha settato cosi Gengik????
      Noto molte cose atipiche , tipo aperto con Clover configurator nella sezione ACPI il nome DSDT.aml NON è selezionato , quindi in teoria NON dovrebbe caricare il DSDT che hai in Clover ACPI Patch , se usi SSDT x la CPU NON dovrebbero servirti quelle personalizzazioni sempre in configplist sezione CPU ...
      Secondo me dovresti partire da un configplist pulito , xche sempre secondo me c'è rimasto delle schifezze di qualche tool x installare facile    EDIT
      Scaricando il configplist di jolly NOTO ha impostato +o- come intendevo fare io , sistemando quello  sopra elencato e bammmmm NON avvia , mi forniresti x favore Hack info che trovi nella mia firma ???
      Grazie
    •   Can you share the Clover folder that lets you boot?
    • yes it is. i can boot using a backup from a backup of my clover. i am just trying to fix the VGA /HDMI so i tried using the clover i got from Allan
    •     I mean't to fix that. The new attached EFI only contains new USB patch that will unlikely fix anything unless your hackintosh is installed on a USB drive. If it is installed on your hard drive, as I said, try playing with the patches I attached in the screenshot (i.e. disabling some of them).   Your SATA Mode is AHCI in the BIOS right?


×