Jump to content
InsanelyMac Forum
trookam

Instalacion Lion packard bell tj66

Recommended Posts

Hola a todos. Os cuento mi caso... a ver si alguien puede ayudarme. Tengo en mi portatil packard bell tj66 snow leopard 10.6.8 retail y funciona de lujo, todo. Las características drl pc son:

 

Intel core 2 duo T4200 2Ghz

4GB de ram

Gforce 105m

wifi atheros

etc. etc

 

Pues bueno, el problema lo tengo con lion. He intentado instalarlo mediante varios metodos y no he conseguido que funcione. He probado con xmove y multibest y con myhack installer... En ambos casos he tenido problemas para cargar desde el boot loader, en ocasiones he conseguido instalarlo, pero al reiniciar no puedo pasar de la configuración inicial.

 

Con iatkos L1 igual, he conseguido instalarlo pero no consigo pasar de la configuración inicial, cuando llega a este punto me detecta el raton tanto ps2 como usb pero no puedo seleccionar nada.

 

Lo curioso, es que el otro dia para hacer prueba hice una particion auxiliar e instale en ella iatkos L1 y funciono todo, me cogio hasta la wifi y bateria... Despues de comprobar que funcionaba formatee para instalarlo en la principal y ya no funcionaba.

 

Asi que me resulta raro, ya que lo he visto funcionar que no pueda ni siquiera completar la configuracion inicial.

 

a ver si podeis exarme una mano.

 

Gracias de antemano. Un saludo.

Share this post


Link to post
Share on other sites
Advertisement

Bueno despues de mucho topazos contra la pared os escribo desde mi lion 10.7.2 retail.

 

Al parecer era un problema con la partición ademas de que usaba como base iatkos con chameleon 2.0 y ahora lo he hecho con la retail y chimera.

 

No me reconocía la wifi ni la bateria. Ya he solucionado lo de la wifi y como la detecta como airport tengo icloud y app store funcionando. Falta la bateria

 

Gracias a todos por la ayuda.

Share this post


Link to post
Share on other sites

Bueno, pues ya esta en la 10.7.2 funcionando todo. Solo me falta una cosa, el audio, ya he probado con 2 kexts distintos y he tenido que estar reinstalando todo el sistema pq no puedo ni entrar en modo seguro para quitarlos.

 

 

el id es este

 

8086:293e es de la familia ICH9 8081I

 

 

En la 10.6.8 tenia funcionando ok el voodooHDA 2.7.2

 

Gracias. a ver si alguno puede ayudarme please

Share this post


Link to post
Share on other sites

Que raro, yo tengo funcionando el audio tanto en Snow como Lion con VoodooHDA 2.7.2. (sin nodestoPatch). Por cierto, si en la DSDT esta presente la device (HDEF) se necesita el AppleHDADisabler para evitar un KP seguro por conflicto con AppleHDA, la otra forma de evitarlo es borrando AppleHDA de /S/L/E, reparar permisos y reconstruir caché. Saludos.

Share this post


Link to post
Share on other sites

Pues probaré.... Juanerson tienes el mismo portatil???? Usas DSDT?? pq la placa base de mi portatil es basica basica. A versi me indicas como... pq yo lo tengo instalado sin DSDT.

 

Un saludo. Gracias a los 2... ya os informo de los avances.... jejeje.

Share this post


Link to post
Share on other sites

No, nada de eso. Sólo lo mencioné porque dices que te funcionaba bien con Snow, por lo tanto no veo por qué no funciona con Lion si a mí me sirve normal? En fin, te adjunto el Disabler y el VoodooHDA (sin NodesToPatch), tal como advierte Slice en su post de proyectosx, esa parte según él era sólo de ejemplo, yo la he quitado y de esa manera queda el driver estándar, para soportar una gran variedad de tarjetas de sonido. Entonces vas a instalar así:

 

1) Primero HDADisabler, reparas permisos y reconstruyes caché.

2) Luego VoodooHDA, reparas y reconstruyes nuevamente, y reinicia. Te recomiendo Kext Wizard 3.7.10 para la tarea.

 

NOTA: Si lo haces exactamente de esa manera NO tendrás problemas. Nos cuentas.

 

P.D. Reinstalar todo el sistema por culpa de unos kexts problemáticos? Por Dios, eso es prehistoria Hermano. Tema aparte.

P.D2. La device HDEF puede estar declarada en la BIOS, pero si no extraes tu dsdt y la miras un poco NI TE ENTERAS.

 

VoodooHDA + Device HDEF = Kernel Panic seguro! Por eso inventaron AppleHDADisabler.kext, para anular a AppleHDA.

Lion_Disabler_Voodoo_HDA.zip

Snow_Disabler_Voodoo_HDA.zip

Share this post


Link to post
Share on other sites

Cnd he tenido algun problema con algun kext siempre he usado el modo seguro para repararlo. Pero desde que actualice a la 10.7.2 no puedo entrar en ese modo, x eso he tenido q reinstalar.

 

Uso el kext wizard. Probaré el disabler aunq la ultima vez lo instalé borrando el appleHDA. La cosa es q m funciona. Pero despues de 2 reinicios... KP!!!

 

Ya os digo algo. Gracias a los 2

Share this post


Link to post
Share on other sites

Bueno pues os cuento... Ya en la 10.7.2. Para poder entrar uso el "UseKernelCache=Yes" porque si no, no puedo entrar. He instalado con kext wizard el disabler q m puso derty, reparo. Luego el voodooHDA de derty. Reparo yReinicio. Todo ok.

 

Ya he comprobado que el kp lo produce el voodooHDA/disabler cuando apago el pc.

 

Lo puedo reiniciar 10 veces q funciona. Ahora como apague, ya no va. Y lo peor es q no puedo entrar en modo seguro ni nada para repararlo.

 

Iluminadme porque yo toy atascado.

 

Edito: he intentado iniciarlo 20 veces y nada. Con todo. Lo he dejado 10 min apagado mientras salía un segundo y ahora lo he encendido y ha entrado y funciona todo.

 

Seguiré haciendo pruebas...

Share this post


Link to post
Share on other sites

si vuelves a entrar repara nuevamente los permisos con kext helper.

 

pero que no haga el extensiones.kext "reconstruir cache" de extra y si lo tienes el extensiones.kext borralo y prueba como va.

 

asegurate de tener el fakesmc en system/library/extensions

 

como explica juanerson en otros post, es mejor no tener ya carpeta extra/extensions solo extra/ dsdt, smbios y boot.plist

Share this post


Link to post
Share on other sites

Buenas a todos... sigo comentando fallos y demás. Os voy a comentar como hago toda la instalación, así me decis si hay algo mal... aunque me estoy volviendo cuidadoso, jejejeje. Estando en retail 10.6.8 he instalado lion 10.7 mediante xmove(borrando anteriormente el voodooHDA y voodooBattery que me daban problemas, reparo y reconstruyo).

 

Una vez entro en lion lo primero que hago es utilizar el kext wizard y mover los kexts de Extra a /S/L/E. Borro la carpeta extension y el .mkext de la carpeta Extra y reparo y reconstruyo la cache de /S/L/E. Hecho esto reinicio, todo ok. Instalo el combo update 10.7.2 y antes de reiniciar, vuelvo a pasar el kext wizard y reconstruyo y reparo. Reinicio y todo ok.

 

Ahora viene lo bueno. He probado ambos disabler que me pasasteis e incluso borrando el appleHDA. Lo instalo, reparo y reconstruyo, instalo el voodooHDA, reparo, reconstruyo y reinicio. Funciona. Cuando reinicio despues o apago el pc o hago un -f para iniciar o algo asi, es como si el disabler se desactivara... y produce KP el voodooHDA.

 

He dejado de intentarlo, pq no se pq motivo no puedo entrar en lion con el -x, se debería de seguir entrando en modo seguro asi??? es que las veces que lo he probado he tenido que reinstalar el sistema por este kext.

 

Podria crear una particion aparte como backup y luego restaurarla???? Para seguir haciendo pruebas es que es un verdadero calvario, ya le he pillado el punto y vuelvo a tenerlo instlado en 20 min, pero sigue siendo un coñazo.

 

Gracias de antemano a los dos.

 

Gracias.

Share this post


Link to post
Share on other sites

Bien compañero, ya tu problema parece venir por deficiencias en el bootloader (gestor de arranque), por cierto cuál tienes instalado en tu HDD? Es recomendable Chameleon 2.1svn r1650 (Buildbot) en adelante, y para instalarlo lo más sencillo es utilizar Chameleon Wizard (preferiblemente siempre la última versión disponible por el tema de corrección de fallos).

 

También me gustaría saber cuáles entradas tienes en el org.chameleon.Boot.plist? Súbelo por favor. Porque en Lion es recomendable fijar el flag para habilitar la prelinked kernel caché (UseKernelCache), ya que 10.7 posee una caché principal distinta a la que comúnmente se conoce como Extensions.mkext, usada en Snow e inferiores versiones de Mac OS X.

 

En conclusión, necesitas tener la versión del bootloader Chameleon estable y actualizada, y a su vez tiene que estar correctamente instalado (bien sea con CW o a través del .pkg de Fabio en su tópico oficial) en el disco duro - partición del sistema. Todos sabemos que eso es vital, así como fijar de forma adecuada los flags, los cuales controlan la configuración de las opciones de arranque. Esperamos tu reporte. Saludos.

Share this post


Link to post
Share on other sites

Hola Juanerson de nuevo, gracias por tu repuesta... De loader uso ahora mismo el chimera 1.6. El UseKernelCache=Yes lo tenía puesto, porque al actulizar a la 10.7.2 una vez me dió un error de "waiting for root device" y leí que así se solucionaba y así fue.

 

Opciones en el org.chameleon.Boot.plist tengo las tipicas:

 

arch=i386

USBBusFix¡Yes (necesario para que arranque mi laptop)

GraphicsEnabler=Yes ( para la nvidia g105m)

match kernel y ya ta.

 

Cuando llegue a mi casa buscaré lo del chameleon aunque con el chimera he podido cargar sin problemas.

 

Un saludo.

Share this post


Link to post
Share on other sites
Hola Juanerson de nuevo, gracias por tu repuesta... De loader uso ahora mismo el chimera 1.6. El UseKernelCache=Yes lo tenía puesto, porque al actulizar a la 10.7.2 una vez me dió un error de "waiting for root device" y leí que así se solucionaba y así fue.

Ok, no sé donde leíste eso, pero estas absolutamente equivocado! No existe relación del flag o la habilitación de la prelinked kernel caché con el problema del "Still waiting... blabla", eso no tiene lógica alguna. En fin, en Lion es recomendable utilizar dicho flag para optimizar la carga desde su particular caché principal (NO FUNCIONA CON .KEXTS EN /E/E, deben estar todas en /S/L/E). Y por favor instala Chameleon 2.1, que es la troncal (trunk) principal, porque chimera no es más que una de sus ramas (branch) secundarias, una variante o derivado de la troncal o tronco, pues.. con alguna que otra adición. Saludos

Share this post


Link to post
Share on other sites

ok, probaré, ya he instalado el chameleon... ya te cuento. Gracias por todo.

 

Edito: Acabo de instalarlo y después de varios reinicios y apagados, está todo funcionando....Hasta la batería!!!! cruzaré los dedos!! seguro que peta cuando ya le haya instalado todos los programas, jejeje.

 

Gracias por todo men! Si tengo algún problema ya vendré a darte el coñazo. Gracias de nuevo crack

Share this post


Link to post
Share on other sites

Que bueno, te felicito! Entonces esperemos una semana para que lo pruebes y le hagas de todo, así darlo por SOLUCIONADO. Saludos.

Share this post


Link to post
Share on other sites

Pues acabo de llegar a casa. Lo he dejado apagado y al volver a encenderlo han vuelto los KP

Creo q voy a desistir... Porque esto es inhumano. Jeje. Lo q mas me jode es q no puedo entrar de ninguna manera para borrar el voodooHDA q produce el kp.

Asi q nada a reinstalar snow leopard. Ya no se q hacerle

Share this post


Link to post
Share on other sites

Pues con tantos intentos fallidos y reinstalaciones NO me extrañaría que hayas jod... tu disco duro físicamente y/o al menos su esquema de particiones. En especial me refiero específicamente al sector de arranque (Zero) de la partición donde se aloja el corazón del bootloader cuando es instalado, eso podría explicar el comportamiento extraño con cualquier gestor de arranque que instales, no crees?. En ese sentido, te recomiendo que destruyas completamente el esquema actual (GUID o MBR), después le hagas un formateo a bajo nivel (tarda horas), y finalizar creando el esquema desde cero al instalar OS X, así tendrás una base limpia, sin sectores perdidos o inestables, etc. Ahora bien, sectores defectuosos son palabras mayores, por lo tanto tampoco sería mala idea hacerle, como esclavo o por USB conectado en otra máquina, un test intensivo completo en su superficie, para descartar daños en su estructura física, en el peor de los casos. FIN del off-topic. Saludos.

 

P.D. Tienes corregidas las IRQs (solicitudes de interrupción) en la DSDT? Eso es básico, en relación con dispositivos vitales durante la carga de OS X, como lo son HPET, RTC, TIMR Y IPIC... que pueden generar conflicto "aleatoriamente" con los puertos SATA y USB en la mayoría de los casos. Fin del off-topic... again, tema DSDT.

Share this post


Link to post
Share on other sites

Pregunto desde la ignorancia.... ¿Si fuera un problema del HDD y sus sectores corruptos/defectuosos, no debería de fallarme el bootloader tbn en snow leopard 10.6.8? Porque en esta versión no tengo ningun problema y lo ejecuto siempre sin problemas.

 

Por cierto Juanerson, como ya te dije no uso ningun DSDT, pues la placa base de mi portatil es lo más básico que he visto... Hay algun tutorial para extraer el dsdt y poder hacerlo???

 

Gracias

Share this post


Link to post
Share on other sites

Para asegurarme de todos modos voy a hacerlo. Lo tengo puesto con el borrado con 35 pasos y voy a hacer lo siguiente. Voy a volver a instalarlo Juanerson y le instalo todo excepto el audio... Y lo voy a probar un par de dias a ver si falla el bootloader.

Si fuera algun problema de este tipo, aunq no esté el audio debería de seguir provocando los kp... Lo q m extraña mucho es q siempre lo haga de la misma forma. Hay una cosa de la q no me he dado cuenta y no se si pudiera ser ese el motivo del kp del voodooHDA.

Yo uso el portatil como base en casa, con pantalla externa, altavoces y demas. Y no me he fijado si cuando me da el kp es cuando lo arranco con los altavoces enganchados al conector, es q es algo muy raro esto... Q funcione y lo apague y reinicie y funcione. Me lo llevo a la faculad y funciona... Veno lo conecto de nuevo y ya hay KP!

Bueno, como he dicho voy instalarlo todo menos el audio y veo si funciona correctamente, aunq el borrado va para largo... Jajaja. Bueno, asi m voy estudiando lo del dsdt a ver si aprendo como va....

Uun saludo, y gracias x todo.

Share this post


Link to post
Share on other sites

Hola Juanerson, por aqui ando de nuevo.... anoche instale de nuevo, despues de formatear el HDD.

 

Lo tengo funcionando correctamente... he hecho todo tipo de pruebas... reiniciar con y sin batería. Apagarlo, con y sin batería. He probado con la pantalla externa y los usbs conectados, sin ellos, y todo funciona, hasta el voodooBattery... Y no he tenido ni un fallo cargando el sistema.

 

Así que creo que podría descartar el problema del HDD o del bootloader. LLegado este punto creo que el fallo tiene que ser o bien con el voodooHDA o del disabler. Podría usar el dsdt para añadir mi audio para no tener que utilizar ese driver concretamente????

 

He estado mirando el tema del dsdt y tengo muchas dudas, pero bueno... voy mirando. He descargado el dsdtse y extraido el dsdt y he conseguido quitar los errores y compilar con exito. Me qedan algunos warnings por ahi, ya lo miraré.

 

A ver si podeis exarme una mano con el dsdt o con el driver mientras voy aprendiendo y probando por mi cuenta.

 

Gracias de antemano.

 

EDITO: Ya he metido en el dsdt los hack de HPET y RTC, y está compilado sin fallos, sigo avanzando, jejeje.

Share this post


Link to post
Share on other sites

Buenas, después de 3 dias funcionando sin problemas sin el voodooHDA instalado, procedí a instalarlo, y funcionó un día hasta que volvieron los kernel panics!

 

Es posible con mi hardware, usando el dsdt no tener que utilizar el voodooHDA??? Ya extraje el dsdt y lo compilé sin fallos y le puse algunos hacks!

 

Gracias de antemano.

Share this post


Link to post
Share on other sites

Bueno, me voy respondiendo yo mismo, así si alguien tiene este laptop pues le irá ayudando. Ya extraje el dsdt como dije, está compilado y con el HPET puesto. Lo he instalado y he borrado el disabler del power management y carga y puedo ver como pone que el applecpupowermanagement ha sido cargado con exito. Por lo que supongo que el dsdt funciona.

 

Mañana con mas tiempo probaré a injectar la nvidia gforce g105m. A ver si algun entendido, puede exarme una mano para ver si puedo hacer algo con el audio y quitarme el voodooHDA!!!

 

Thx

Share this post


Link to post
Share on other sites

yo de verdad que no lo entiendo, jejeje. Buenas de nuevo. He instalado iatkos l2 y despues de 3 dias usandolo, con algun fallo al iniciar y eso han vuelto los kernel panics con el voodooHDA!!!! es q es algo sin sentido... Ya no se que mas hacerle.... además que los dias q ha estado funcionando el voodoo en lion, el sonido es mas flojo que en snow leopard y se escuchan ruido de fondo en ocasiones chasquidos...

 

Seguiremos informando, aunque ya estoy llegando a mi limite de formateos y demás.

 

Un saludo... a ver si alguien me ilumina.

 

Juanerson, puede ser que el problema con el voodooHDA lo esté probocando el IOPCIFamily??? pq cada vez que me pasa lo del voodooHDA puedo leer que el problema es del IOPCIFamily junto al fallo del voodooHDA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×