Jump to content
About Just Joined group Read more... ×

Upgraded from SL --> Bootloader Question

2 posts in this topic

Recommended Posts

I have a GB GA-EX58-UD5 that has been running Snow Leopard flawlessly since 10.6.1... With the release of Lion and iOS5, I decided to follow the upgrade path found here. All went very well! I was psyched how easy it actually went down, and how everything continued to work.


Then I got brave (or stupid, not really sure which). I decided to download and install SleepEnabler.kext.10.7.X that has been released through this Google Code page. I installed it with KextHelper and after about three seconds, it KP'd and that was it for a few days.


I ended up restoring from a Time Machine backup (from an external drive) not realizing that it would mess up my bootloader (at the time Chameleon RC4). So after playing around for a few hours, I decided to try and save my Lion disk by installing Snow Leopard again on a separate, internal HD. That went well. Now I could boot from the SL disk and select either SL or Lion and it would boot into either. No problems...


But here's my problem: my Chameleon bootloader (Chameleon 2) is now my Snow Leopard drive (which I want to use for something else). I tried to install Chameleon 2 onto my Lion drive, copy over the entire Extra folder (Extensions.mkext, smbios.plist, org.chameleon.Boot.plist, Themes folder and modules folder), and then let the system boot from that drive directly.... Chameleon loads, and I can select either disk, but when Lion tried to load, the white and great Apple logo comes up, the spinner does it's thing, and then I get the "DO NOT" strikethrough-circle symbol...


So I don't get it. What's different between the two drives and installations of Chameleon?


Thanks for reading this, if you did. If not...


TL;DR I have a Chameleon 2 bootloader on two separate disk drives (one Snow Leopard [for recovery], One Lion [for my main system]), with identical /Extra folders on the root of both drives, and only one disk actually boots properly.


Could it be that Chameleon needs to be on the first disk in the system?

Share this post

Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.