Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
alianyn

[Asus U36SD] - a few dsdt questions

139 posts in this topic

Recommended Posts

Hi there, first of all I'd like to thank all of you for somehow developing OS X on our laptops. I'm not new to topic of OS X on PC cause I used it on my previous computer then I sold it and bought U36SD. I installed most of common features, but I've got a problem. I'm using DSDT by alianyn - great thanks for that piece of work but I've got a problem. Some of you wrote that after applying speedstep patch you were able to use AICPUPM, I tried many different patchers, patches for kext + SSDT + patched for DSDT and nothing worked I always get a KP from AICPUPM, once after applying patch + adding SSDT and adding modified section to DSDT i got KP but from AppleACPIPlatform.kext - "

Should have 4 Threads, but only found 5 for Die 0"

and also I was unable to do anything about it. My CPU is i5 2430M and ofc I used dedicated patches for this particular CPU. Do you hava any ideas of solving this issue? I use this notebook a lot and usually I cannot plug it so it's crucial to make Power Management work... I don't know if it mean anything but IntelCPUMonitor seems not to recognize my CPU: "CPU family 0x6, model 0x2a, stepping 0x7, cores 16, threads 0"

Thanks in advance.

Share this post


Link to post
Share on other sites

Hi there, I've been using Lion on my Asus u36sd for about four or five months. During this period I had only one major (until yesterday) issue which led me to reinstall everything basically the problem was that my partition got broken for an unknown reason, so... guess what? yesterday the same happened! My shiny hfs+ partition was totally broken AGAIN , I managed to recover some files using fsck, they appear on /lost+found...

 

So I'd like to ask you all, which partition table format are you using and how long are you using it, I was using (I'm still doing it) MBR with for partitions: win, linux, macos and the original for win recovery.

 

Any help will be really really welcome!

Thanks!

Share this post


Link to post
Share on other sites

My answer probably won't help you or sth but I'm using GUID for about 2 months now and everything works fine. Comparing to you issue this information is probably useless but just wanted to get you know ;D BTW Speed Step issue was solved by reinstalling everything from scratch but enabling speed step at the first place.

 

Cheers

Share this post


Link to post
Share on other sites

Hi there! Actually your answer is helpful, all my tries were using MBR... so maybe its related to the format of the partition table. It would nice to hear from someone using MBR without problems for a long period!

 

I'm glad that you could solve the issue with speedstep!!!

Share this post


Link to post
Share on other sites

someone of you updated to 10.7.3 ? my wlan is broken .. i got a atheros 9285 which should be supported.. :(

 

Edit:

worked now, just use the 10.7.2 IO80211Family.kext

 

to Claudio, I'm using also triple boot with GPT/MBR Hybrid disk .. first installed OS X, then Linux, synced the disk and at least win 7.. worked since december

Share this post


Link to post
Share on other sites

Hey Guys!

 

So, i had a working install of lion on my Asus u36s a few months ago, but i reformatted it shortly after to test other operating systems. I am now trying to install lion again, and i have done everything the exact same way. The only difference is i upgraded my bios from 203 to 206. Now, Lion installs without a hitch, and using the dsdt from this post, pretty much everything works when i boot to the installer. I don't need any boot arguments, it boots to the installer off the usb drive with out issue.

 

When i restart after a successfull install, it throws a kernel panic at "AppleIntelCPUPowerManagement.kext". I have tried multiple different fakesmc files and AppleIntelCPUNull kext files to no avail. I intend to triple boot with win 7 and Linux Mint using a hybrid GUID MBR partition table, But i need to get this working first! Do you guys have any ideas? What bioses are you using? Have you ever run into this issue? In addition, i am using the latest version of chamelion.

 

Any help will be greatly appreciated!

Share this post


Link to post
Share on other sites

i was success installing lion on my u36sd using Reixx guide. now, i want to ask about how to get lion recognize nvidia gt520m and able to use it. anyone?

Share this post


Link to post
Share on other sites

so does this mean that sleep etc. is working on this laptop? I would really like to install this soon. I want to try osx out over the summer.

Share this post


Link to post
Share on other sites

i was success installing lion on my u36sd using Reixx guide. now, i want to ask about how to get lion recognize nvidia gt520m and able to use it. anyone?

 

I can't using it, so I tried to disable it but thats also doesn't worked. :-(

 

so does this mean that sleep etc. is working on this laptop? I would really like to install this soon. I want to try osx out over the summer.

 

Yes for me everything worked except of battery state and the functions keys. (Even Bluetooth worked with the latest updates)

Share this post


Link to post
Share on other sites

Hi guys,

 

another question, in Snow Leopard the function keys for brigthness worked, but in Lion not. Where do I have to look at to fix? dsdt.aml?

 

Thanks.

 

anyone? or how to set the brightness?

Share this post


Link to post
Share on other sites

Hi everyone,

 

Thank you very much for the edited DSDT! Now I have sleep and shutdown working and on top of that less heat generation and fan noise. I originally installed dual boot with Win 7, but didn't use the mac side as much due to poor power management, lack of bluetooth and instabilities with VoodooHDA.

 

This thread however encouraged me to put more effort into solving the remaining problems. I tried just about all kexts (including AppleHDA with edited pin configurations) and combinations of them to get audio working, but nothing seemed to do the trick. I finally managed to get audio with edited AppleHDA, HDAEnabler and IOAudioFamily kexts I found on various forums. The KPs are now gone and everything seems to be working except the internal mic. Also the speakers don't work after sleep, but this is enough for me and may be for others too.

 

I am not sure if all kexts are needed and haven't had the time to experiment. I will upload them here in case its helpful for someone else. Unfortunately I don't remember exactly which one belongs to which forum/topic and can't credit the persons behind them. I hope I don't violate forum rules by uploading these.

 

Hi guys,

 

After 1 day fighting with the Bluetooth on our laptops I finally made it work on startup and after wake up from sleep. I'm attaching a file containing all you need and here is how to install it:

 

su -

or

sudo -i

 

cd /

tar xzvf /location/of/bluetooth.tar.gz

 

then execute:

 

launchctl load /System/Library/LaunchDaemons/org.ath.plist

launchctl load /System/Library/LaunchDaemons/org.sleepwatcher.plist

 

and you have fully functional bluetooth after you reboot or wake up :)

 

cheers

 

I tried your method but I still can't get BT working. Both files are found in S/L/LaunchDaemons but when I run "launchctl list" in terminal, the processes are not listed. Also, if I try to manually start the process "launchctl start ..." I get a message: "no such process". Does anyone know what I 'm doing wrong? (As a side note; programming is not my number 1 skill)

ALC269Kexts.zip

Share this post


Link to post
Share on other sites

I like to share my full AppleHDA for ALC 269 I edited to get sound on my G74SX I hope it works in your ASUS.

 

Speakers Ok

Headphones OK

Internal Mic OK

External Mic OK

 

Sound After sleep OK

 

Install this 2 next with kextwizard for correct permissions and don't forget to rebuild kext cache.

 

This needs DSDT HDEF definitions implemented.

 

Good Luck

AppleHDA ALC269 Full Working.zip

Share this post


Link to post
Share on other sites

I like to share my full AppleHDA for ALC 269 I edited to get sound on my G74SX I hope it works in your ASUS.

 

Speakers Ok

Headphones OK

Internal Mic OK

External Mic OK

 

Sound After sleep OK

 

Install this 2 next with kextwizard for correct permissions and don't forget to rebuild kext cache.

 

This needs DSDT HDEF definitions implemented.

 

Good Luck

@areos - thanks, this could really be helpful. some time has cleared up for me - so i'm doing a bit of work on the dsdt again, i was wandering where you got this kext? did you make it yourself? if so, can you tell me what you did? if it's pinout/mapping changes - perhaps it can be incorporated into the dsdt - which would make it even more valuable.

Share this post


Link to post
Share on other sites

@areos - thanks, this could really be helpful. some time has cleared up for me - so i'm doing a bit of work on the dsdt again, i was wandering where you got this kext? did you make it yourself? if so, can you tell me what you did? if it's pinout/mapping changes - perhaps it can be incorporated into the dsdt - which would make it even more valuable.

 

@alianyn! How are you doing, one little question, are you using 10.7.4? Did you made any changes to your (" a-w-e-s-o-m-e" ) DSDT?

@areos Thanks for sharing!!!!!!

Thanks!!!

Share this post


Link to post
Share on other sites

@alianyn! How are you doing, one little question, are you using 10.7.4? Did you made any changes to your (" a-w-e-s-o-m-e" ) DSDT?

@areos Thanks for sharing!!!!!!

Thanks!!!

Hi @Claudio - I'm pretty good, have a little spare time now - so yes, i upgraded to 10.7.4, and started working on closing some of the gaps in the dsdt, etc...

 

How have you been?

 

I already have battery working mostly correctly, and currently working on the 2410m ssdt's in order to get better power management (and more battery time...). when i finish with that i plan on taking a look at what areos provided for the audio (i've been having random kernel panics from voodoohda because of the hdmi cable being plugged in), and want to have as much in the dsdt as possible and the system to be as vanilla as possible.

I will then take a look at what can be done with the usb3, and the bluetooth (both will probably need kext changes/fixes and cannot be done in dsdt).

 

[Edit:] also forgot to mention - found a solution to the wifi not working after 10.7.3/10.7.4 upgrades (one line change to the plist.info in the kext - currently no way around it, though i'm trying with dsdt to mix it up).

Edited by alianyn

Share this post


Link to post
Share on other sites

@areos - thanks, this could really be helpful. some time has cleared up for me - so i'm doing a bit of work on the dsdt again, i was wandering where you got this kext? did you make it yourself? if so, can you tell me what you did? if it's pinout/mapping changes - perhaps it can be incorporated into the dsdt - which would make it even more valuable.

 

I did all the changes in AppleHDA, but the ALC 269 has a Problematic EAPD that needs to be initialized at boot or after sleep. I found a modded IOAudioFamily kext that takes care about that, it initialize the EAPD at every boot or after sleep.

 

My AppleHDA is a little old (10.6.3), I can create a new AppleHDA with the newer version available but we need to update the IOAudioFamily kext too. I attach the patch for the IOAudioFamily kext. I attach the patch I found in the dell mini osx site because I don´t have the programmer skills to apply it. If someone is interested in create a new IOAudioFamily kext let me know to create a new AppleHDA.

 

@alianyn this is the guide I use to learn more about AppleHDA kext http://www.projectosx.com/forum/index.php?showtopic=465&st=0

 

Good luck

IOAudioFamily-mute-v1.patch.zip

Share this post


Link to post
Share on other sites

@AREOS - Thanks, then perhaps you can help me. After studying all the changes necessary, i understand this cannot be done via dsdt - too many injections required and i'm not sure some of them will be valid for the kext.

The kext you posted in not compatible with our configuration.

The config data for out ALC269 is

<01471c40 01471d01 01471e13 01471f99 01871c20 01871d10 01871e81 01871f04 01971c10 01971d01 01971ea0 01971f99 02171c50 02171d10 02171e21 02171f04 01470c02>

I also had to add a layout269.xml to the kext with some changes, i didn't do the original kext change myself, i took a kext that partially worked for me and modified it from there (got the config data using the same thread you mentioned by "the king").

 

Editting a Lion kext seems to be a little different than previous versions, so if you know how to do it, i'd love some help.

Last problem though is sleep and mute, like you mentioned we need the IOAudioFamily modification for that. i tried to find any material on this, but could not - so thanks for the patch, i'll take a look. if you can point me to a thread on this - that would be really helpful...

 

 

@All - some updates:

1. I have a new dsdt and ssdt (both attached below) that should work fine for anyone wanting to upgrade to

10.7.4, they work with speedstep and give you a good range of frequencies. it's good for anyone who has

the i5-2410m of this laptop, if you have anything else, please don't use this!!!

dsdt & ssdt for lion 10.7.4.zip

2. I've also started using the IOath3kfrmwr - which should take care of all your bluetooth woes (works

perfectly with my iPhone, ear-piece for skyping, and microsoft notebook mouse 5000). -

http://www.tonymacx8...53556&start=106

3. I've also moved to using AppleHDA instead of VoodooHDA as it was giving me lots of kernel panics on

boot, only problem is no speakers after sleep. working on that...

AppleHDA.zip

4. I've had to edit the IO80211Family.kext and remove the "network-root" requirement, you CAN work

without it, but sometimes there is a kernel error because it loads too early and it may not load (that's since

10.7.3). IO80211Family.kext.zip

5. Switched to a new version of chameleon/chimera with a few modifications - i haven't had a single screen

corruption problem since this change + upgrade to 10.7.4.

Chameleon-2.1svn-r2000.zip

 

With these changes i now have an almost 100% working mac, missing still are sound after sleep and usb3 - working on both of those. but no more kp's no more screen corruption and better battery time on 10.7.4 (your milage may vary ofcourse).

Share this post


Link to post
Share on other sites

@AREOS - Thanks, then perhaps you can help me. After studying all the changes necessary, i understand this cannot be done via dsdt - too many injections required and i'm not sure some of them will be valid for the kext.

The kext you posted in not compatible with our configuration.

The config data for out ALC269 is

<01471c40 01471d01 01471e13 01471f99 01871c20 01871d10 01871e81 01871f04 01971c10 01971d01 01971ea0 01971f99 02171c50 02171d10 02171e21 02171f04 01470c02>

I also had to add a layout269.xml to the kext with some changes, i didn't do the original kext change myself, i took a kext that partially worked for me and modified it from there (got the config data using the same thread you mentioned by "the king").

 

Editting a Lion kext seems to be a little different than previous versions, so if you know how to do it, i'd love some help.

Last problem though is sleep and mute, like you mentioned we need the IOAudioFamily modification for that. i tried to find any material on this, but could not - so thanks for the patch, i'll take a look. if you can point me to a thread on this - that would be really helpful...

 

 

@All - some updates:

1. I have a new dsdt and ssdt (both attached below) that should work fine for anyone wanting to upgrade to

10.7.4, they work with speedstep and give you a good range of frequencies. it's good for anyone who has

the i5-2410m of this laptop, if you have anything else, please don't use this!!!

dsdt & ssdt for lion 10.7.4.zip

2. I've also started using the IOath3kfrmwr - which should take care of all your bluetooth woes (works

perfectly with my iPhone, ear-piece for skyping, and microsoft notebook mouse 5000). -

http://www.tonymacx8...53556&start=106

3. I've also moved to using AppleHDA instead of VoodooHDA as it was giving me lots of kernel panics on

boot, only problem is no speakers after sleep. working on that...

AppleHDA.zip

4. I've had to edit the IO80211Family.kext and remove the "network-root" requirement, you CAN work

without it, but sometimes there is a kernel error because it loads too early and it may not load (that's since

10.7.3). IO80211Family.kext.zip

5. Switched to a new version of chameleon/chimera with a few modifications - i haven't had a single screen

corruption problem since this change + upgrade to 10.7.4.

Chameleon-2.1svn-r2000.zip

 

With these changes i now have an almost 100% working mac, missing still are sound after sleep and usb3 - working on both of those. but no more kp's no more screen corruption and better battery time on 10.7.4 (your milage may vary ofcourse).

 

This is really nice! I think that I will have to put myself to work on a new installation :)

 

Thanks!!!

 

BTW, one thing that I was wondering is, how did you setup your hardrive? Are you using GPT, MBR? I'm thinking in starting from scratch this time. Last Time I use MBR with a some information from a Chinese Forum to bypass some MBR validation (OSInstall.mpkg)... and it did not work ok...

Share this post


Link to post
Share on other sites

This is really nice! I think that I will have to put myself to work on a new installation :)

 

Thanks!!!

 

BTW, one thing that I was wondering is, how did you setup your hardrive? Are you using GPT, MBR? I'm thinking in starting from scratch this time. Last Time I use MBR with a some information from a Chinese Forum to bypass some MBR validation (OSInstall.mpkg)... and it did not work ok...

 

Have at it :) i'm really enjoying lion, and i also installed office for mac 2011 (turns out, our company has a license), and now i also have normal mail... the only 3 reasons i currently sometimes switch to windows are SVN (couldn't find any mac app that even comes close to scratching tortoisesvn), visualstudio (i wish there was some way around a virtual machine - which i don't want to install), and having to write to NTFS partitions...

 

BTW - also if anybody's interested i found a great general purpose editor to replace notepad++ on mac (it's my main IDE on windows) called Editra ( http://editra.org/ ) it's free, actively developed and has lot's of great plugins. i was loosing my mind due to textwrangler and coderunner (in my opinion they are a far cry from notepad++ or editra).

 

I used an MBR partition scheme for my install as per this guide - http://myhack.sojugarden.com/2009/12/dual-booting-demystified/

I have used it already on 2 other friend's machines and it worked flawlessly on both - i don't remember having to change any of the instructions on it, but it was a long time ago (about a year) since i last used it.

Share this post


Link to post
Share on other sites

Have at it :) i'm really enjoying lion, and i also installed office for mac 2011 (turns out, our company has a license), and now i also have normal mail... the only 3 reasons i currently sometimes switch to windows are SVN (couldn't find any mac app that even comes close to scratching tortoisesvn), visualstudio (i wish there was some way around a virtual machine - which i don't want to install), and having to write to NTFS partitions...

 

Great! I'm glad you are enjoying it. Mm.. about the 3 reasons, about SVN (on the other two I don't really know) :

 

Maybe one of these may help: http://gigaom.com/apple/12-subversion-apps-for-os-x/

 

BTW - also if anybody's interested i found a great general purpose editor to replace notepad++ on mac (it's my main IDE on windows) called Editra ( http://editra.org/ ) it's free, actively developed and has lot's of great plugins. i was loosing my mind due to textwrangler and coderunner (in my opinion they are a far cry from notepad++ or editra).

 

Good to know :) Thanks for the info.

 

I used an MBR partition scheme for my install as per this guide - http://myhack.sojuga...ng-demystified/

I have used it already on 2 other friend's machines and it worked flawlessly on both - i don't remember having to change any of the instructions on it, but it was a long time ago (about a year) since i last used it.

 

Wow! I thought that you were using GPT or another one than MBR.. are you using Linux also? Do you have four (win7, recovery, macos and linux) partitions? (I use to have four and that may cause the problem...)

 

As always... thanks!

Share this post


Link to post
Share on other sites

wow i havent checked in this thread for a while. Ill try installing it soon. Just a quick question: are the mulit-touch trackpad gestures working within os x?

Share this post


Link to post
Share on other sites

Another question for you guys, did you manage to get brightness work with the Fn keys ? I'm on a different laptop (Asus g53jw) but if it is working for you i will pick your brighness methods ad put them on my dsdt.

Share this post


Link to post
Share on other sites

@AREOS - Thanks, then perhaps you can help me. After studying all the changes necessary, i understand this cannot be done via dsdt - too many injections required and i'm not sure some of them will be valid for the kext.

The kext you posted in not compatible with our configuration.

The config data for out ALC269 is

<01471c40 01471d01 01471e13 01471f99 01871c20 01871d10 01871e81 01871f04 01971c10 01971d01 01971ea0 01971f99 02171c50 02171d10 02171e21 02171f04 01470c02>

I also had to add a layout269.xml to the kext with some changes, i didn't do the original kext change myself, i took a kext that partially worked for me and modified it from there (got the config data using the same thread you mentioned by "the king").

 

Editting a Lion kext seems to be a little different than previous versions, so if you know how to do it, i'd love some help.

Last problem though is sleep and mute, like you mentioned we need the IOAudioFamily modification for that. i tried to find any material on this, but could not - so thanks for the patch, i'll take a look. if you can point me to a thread on this - that would be really helpful...

 

 

@All - some updates:

1. I have a new dsdt and ssdt (both attached below) that should work fine for anyone wanting to upgrade to

10.7.4, they work with speedstep and give you a good range of frequencies. it's good for anyone who has

the i5-2410m of this laptop, if you have anything else, please don't use this!!!

dsdt & ssdt for lion 10.7.4.zip

2. I've also started using the IOath3kfrmwr - which should take care of all your bluetooth woes (works

perfectly with my iPhone, ear-piece for skyping, and microsoft notebook mouse 5000). -

http://www.tonymacx8...53556&start=106

3. I've also moved to using AppleHDA instead of VoodooHDA as it was giving me lots of kernel panics on

boot, only problem is no speakers after sleep. working on that...

AppleHDA.zip

4. I've had to edit the IO80211Family.kext and remove the "network-root" requirement, you CAN work

without it, but sometimes there is a kernel error because it loads too early and it may not load (that's since

10.7.3). IO80211Family.kext.zip

5. Switched to a new version of chameleon/chimera with a few modifications - i haven't had a single screen

corruption problem since this change + upgrade to 10.7.4.

Chameleon-2.1svn-r2000.zip

 

With these changes i now have an almost 100% working mac, missing still are sound after sleep and usb3 - working on both of those. but no more kp's no more screen corruption and better battery time on 10.7.4 (your milage may vary ofcourse).

 

@alianyn, I'm starting to work on my new installation :)

 

On question about point number 4, removing the network-root requirement from the IO20211Famility.kext solves the problem definitely or after applying this change a kernel panic may happen...

 

Did you install 10.8?

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×