Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

[HOW TO] 10.6.8 on barebone Asus T3-P5G965

3 posts in this topic

Recommended Posts

Well, this old fart can do much more than running 10.5.8 LEO!


I've finally got it fully working in 64bit mode with official ASUS BIOS; retail 10.6 DVD; nVidia 8400GS; 10.6.8 Combo


Her is how I did it:




- Make sure you use latest stock bios 0903 and not the AHCI modified one

- Load BIOS defaults and make sure that:


-- sata configuration ENHANCED

-- USB legacy syppport ENABLED

-- Graphics Adapter PCI/PEG

-- Graphics Adapter Mode DISABLED

-- JMicron SATA/PATA controller DISABLED

-- Suspend Mode S3 ONLY

-- ACPI 2.0 Support ENABLED

-- 1st Boot Device DVD ROM

-- 2nd Boot Device HDD

-- 3rh Boot Device DISABLED

-- Full Screen Logo DISABLED


- if you want to take a walk on the wild side here is unsupported AHCI BIOS with settings for configuration as mentioned below




- Intel Core Quad Q6600 LGA 775 2.4 MHz

- 4x1 Gb DDR2 666 Mhz use at least 1 Gb but no more than 4Gb of single sided RAM modules during installation !

- SSD OCZ 120 Gb SATA II on 1st port SSD TRIM is not supported, take a walk on the wild side and use AHCI BIOS with TRIM EMABLER


- nVidia 210 1024 Mb PCIe 16x DON'T USE ONBOARD VGA

- DON'T USE 3rd SATA port !!!


Make sure all USBPWR jumpers are set to +5VSB




- NAWCOM OSx86 MOD boot CD

- Retail 10.6 DVD

- Xmove




- boot with nawcom, eject cd, insert DVD, wait few seconds and hit F5

- when icon changes to OSX installer hit ENTER

- format your HDD with HFP+/GUID and one partition not bigger than 500 Gb

- customize installation by UNCHECKING EVERYTHING except APPLE PS2 and INTElPIIX (this will speed up installation and prevent some KP issues)


installation will take about 30 min, so sit and wait until it reboots




1/2 hour later, with a little luck you just went thru initial screens ;)


- find 32/64-bit Kernel Startup Mode Selector and select 64-bit mode

- reboot

- install your VGA (don't forget to repair permissions)


nVidia uses:


- Add device ID in /system/library/extensions/NVDANV??Hal.kext/contents/info.plist


depending on VGA card u have ( not for GT 210 )


- Find an NVinject.kext, any one will do, they're basically the same

- Add your device ID in NVinject.kext/contents/info.plist

In the same plist, set the NVCAP string correctly THIS IS REALLY CRUCIAL, make sure you use correct nvcap string for your card!


ATI users:


- Add device ID in /system/library/extensions/ATIRadeonX????.kext

- Add device ID in /system/library/extensions/ATI????Controller.kext


n.b. it works with ATI 4650 HD and modded kexts but HD performance is poor with full HD content


Regardless VGA of your choice:


- reboot and make sure your VGA is fully operational

- If you have any problems with your VGA, pause here and find a solution. Updating to 10.6.8 without fully operational VGA will only make it worse.

- download an install 10.6.8 combo update !!! DON'T USE SOFTWARE UPDATE and DON'T REBOOT !!!

- edit ( by 10.6.8 combo freshly installed ) kexts same way you did before update

- download DSDT Patcher GUI, run and apply patch

- download, install and update Champlist

-- run Champlist and check:

Ethernet Built in

Graphics Enabler (nVidia users only)

Generate P-States

Generate C-States

USB Bus Fix


Restart Fix



SMBios path (generate one first with ChamPlist)

-- leave all other options unchecked!


- install latest VoodooHDA

- install sleepenabler.kext

- remove NullCPUPowerManagement.kext from /E/E

- repair permissions !


cross your fingers and reboot! If everything went as planed you have a fully operational iHack. You can even use Software Update! Optionally edit SMBios and generate "Genuine Serial" to make programs like TeamViewer work.


Some people report problems while sighing in AppStore: "Your device or computer could not be verified. Contact support for assistance ..."


If so, this is official Apple solution and it works!


- delete all interfaces in system preferences/network

- delete Library/Preferences/SystemConfiguration/Networkinterfaces.plist and com.apple.network.identification.plist

- reboot

- add ethernet interface in system preferences/network and configure it if necessary

- optionally add all other interfaces you might need, like firewire, com etc.

- wait a few seconds for Eth interface to initialize

- log in to your app store account and enjoy




if you use SSD, for optimal performance, take a walk on the wide side and flush with AHCI BIOS

System may be very slow on boot up to 180 sec with HDD or < 40 sec after a lot of tweaking and SSD upgrade!

Sleep is faster, use it with HDD never with SSD!

Or go all the way and upgrade to 10.7.5

And, please, don't be lazy. If it worked for You, confirm it by leaving a comment.


Thank You!




If you are lucky as I was, everything will work including sleep etc. I've tested this procedure on tree separate systems. One with ATI 4650HD other with nVidia 8400GS and third with GF 210 & SSD. What you have to do i to follow this how-to and not jump over some steps even you disagree and/or don't understand why.

Talking about sleep, this is something that confuses me. It works but not each and every time. Sometimes system doesn't shut down completely even when nothing was On the other hand I've read on manny forums that even owners of genuine Mac's experience same issues with 10.6.8

AppStore issue is a bug in 10.6.8 and Lion, it has nothing to do with your IHack. Even genuine Apple owners have the same issue.




I wish I had this much support when I attempted my first iHack back in 2006. Even it wasn't fully operational, we made a great stunt in our show room with 3 identical Creative Shuttle Intel based bare-bone x86 machines, one running MS XP {censored}, second running frustrating SUSE and third running OS X Tiger 10.4

Yes, it was by all means a total show-off. In that "golden PC age era" we simply could't build them fast enough. Until few months ago I've owned one, refurbished and donated it to a so called 3rd world country user.


* this HOW TO is subject to change without notice. If you need support send a PM and I'll do my best to help you.


Steve, R.I.P. I still don't want your hardware, just your software!

Share this post

Link to post
Share on other sites



I want to thank you for helping me with this build. I will confirm that these steps work, 100%. I would suggest (at my own experience) that you run and update champlist BEFORE running combo update. Don't check and apply any settings inchamplist, just open and update it. If you open it later, the combo update does something to video acceleration, and champlist wont display anything if you open it afterward.


I would do some research before buying a video card, Tepaks confirms it works it works with an 8400gs, and I can confirm that it works with an xfx 9600GSO 512mb. The problem with this card (and possibly any other actively cooled cards) is that the fan speed is constantly at 100%. The consequences of this is that the fan sounds like a vaccuum cleaner! I am purchasing aftermarket cooling for it, in an effort to reduce the noise. Also, when looking at video cards, look for something WITHOUT an external power requirement. If you're shopping for PSU's, you need a microatx power supply I believe. A Core2 Quad Q6600 is the fastest quad core supported by this machine.




If you run across this machine at a reasonable price, get it! It makes a FANTASTIC ihack! Form and function!

Share this post

Link to post
Share on other sites

I wanted to post an addendum to this whole experience. I just spent the last week reinstalling and going over all this again. There's a few tips that I'd like to add to this guide. Tepaks and I have talked a bit about it, so hopefully he agrees.


First of all, I'd highly suggest that if you are interested at all in using the modded bios, do it before going through the whole process because changing the bios may (it did for me, I think) cause MANY problems with an established install. If you use the modded bios, Tepaks has also provided a BIOS settings file so that you don't have to futz with the BIOS at all!


When changing the kernel boot mode, you'll get an error in chameleon that says to wait 5 seconds, to fix this type or copy & paste in terminal: sudo systemsetup -setkernelbootarchitecture i386


I used NVEnabler 64.kext. I tried NVinject and only experienced sadness and regret. Make sure you use NVEnabler 64.kext if you have an Nvidia card.


When editing your NVEnabler 64.kext, if you want both outputs to work on your graphics card, edit your NVCAP with these strings (use only as a guide). HDMI worked with the DVI/DVI option






When you get to the step with the combo update, make sure you run CHAMPLIST and DSDT PATCHER GUI FIRST!!!! You can't run them after the combo update installs, I don't know why.


Since we mentioned champlist, the more recent version (Since the guide was written) doesn't have the Restart Fix, DSDT Path, or SMBios Path option. I installed my DSDT Patcher to the root of the drive, and Chameleon appears to detect it automatically. I also don't have any restart problems, oh well! For SMBIOS, go to the SMBIOS tab, select MacPro 3,1 and SAVE AS to /extra. I also saved my Chameleon.plist to /extra. Just point them to the right spot. I left my DSDT in the root directory and I think that Chameleon auto detects it. Either way, im not sure, but it works perfectly.


For those of you using Dual Monitors, for some reason, with my 9600GSO 512MB (XFX) (HDMI/DVI) Dual monitors did NOT work in 10.6 even after the proper NVCAP string was injected (though the second monitor was detected) until I combo updated to 10.6.8 and then all of a sudden it worked after editing NVAND50HAL.KEXT and Reinstalling NVEnabler 64.kext. (The same procedure outlined in the guide)


I also have successfully installed 10.7.5 using Tepaks' guide,


If anyone else is interested, I can also write a guide on how to SUCCESSFULLY TRIPLE boot Win7,OSX Snow Leopard, and OSX Lion. all on the same drive!



Special thanks to the following posters!




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Yup that's fine! Oddly, when rebooting several times it is suddenly gone! Only thing I need to fix is getting 'Headphone' output to work, after sleep. Internal Speakers are working after sleep. I assume to fix this in CodecCommander.kext/ EAPDFix.kext? Anyway thanks for your help!   Yup I have a combo output, so there was something wrong I guess.
    • Nice @yapan4 then we can join forces to make this as good as possible.
    • I had a weird situation, after running great for a while: yesterday I did a reboot and got a KP. Turns out the AstekFusion2Adapter kexts were causing the KP, strange thing is I didn't recall applying any update or a like.  I had to boot with the USB installer, mount the EFI partition to delete the old AstekFusion2Adapter kexts and replaced with the patched version contributed by despeinao. I'm glad the system is working again, not having to reinstall OSX.
    • i think the "red light" you are referring to is that you have a optical SPDIF output (3.5 mm) combo jack. it most likely will be "red" when audio is active. 
    • Domanda , ma il tuo configplist lo ha settato cosi Gengik????
      Noto molte cose atipiche , tipo aperto con Clover configurator nella sezione ACPI il nome DSDT.aml NON è selezionato , quindi in teoria NON dovrebbe caricare il DSDT che hai in Clover ACPI Patch , se usi SSDT x la CPU NON dovrebbero servirti quelle personalizzazioni sempre in configplist sezione CPU ...
      Secondo me dovresti partire da un configplist pulito , xche sempre secondo me c'è rimasto delle schifezze di qualche tool x installare facile    EDIT
      Scaricando il configplist di jolly NOTO ha impostato +o- come intendevo fare io , sistemando quello  sopra elencato e bammmmm NON avvia , mi forniresti x favore Hack info che trovi nella mia firma ???
      Grazie   Ho creato un configplist , se vuoi provare , dovrebbe essere pulito da ogni impurità , se funziona dovrai adattarli tutte le tue personalizzazioni x il boot ..... config.plist.zip