Jump to content
geforcefan

[KEXT] CMI8738 Kext for 64bit OSX Lion

20 posts in this topic

Recommended Posts

Hello everybody,

after several tryings, I finally get ported the audio drive for OSX Lion 64bit, based on the original source codes from http://scifi.pages.at/ffm-2/ for OSX Tiger.

 

Use KextHelper to install the CMI8738 audio kext or just copy CMI8738AudioDevice.kext to /System/Library/Extensions and type following lines to the terminal:

 

sudo -i
cd /System/Library/Extensions/
chown -R root:wheel CMI8738AudioDevice.kext
chmod -R 755 CMI8738AudioDevice.kext

 

To test it on running system:

kextload CMI8738AudioDevice.kext

 

Maybe you have to clear your kextcache!

 

If there are problems to getting work the kext, just ask me ;)

 

PS: Its a native 64bit kext!

 

Have fun!

CMI8738AudioDevice.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

I just asked, because I'm using another cmi8738 kext on my lion 10.7.2(64bit) and input not working, but I will try this kext...

 

edit: I have only output, mic and input not working. Input device shows up in sound settings, but it's not working. Do you actually tested input?

Share this post


Link to post
Share on other sites

Thank you, geforcefan.

 

It works great! But, one problem exist...

 

After sleep & wake up, sound is gone. Volume control works, but no sound...

 

Maybe I can use script that unload and load 8738 kext after wake up... but it's annoying..

 

Can you fix it?

Share this post


Link to post
Share on other sites

It works for me except 5.1 doesn't work. I can get Left, Right, Back Left, Back Right and Sub to work but not center channel. Also it shows up as Stereo in when I got to configure speakers in the audio/midi setup . 5.1 is greyed out

Share this post


Link to post
Share on other sites

Any chance you could release the source?

 

Source code links are down for the main project

Share this post


Link to post
Share on other sites

Any chance you could release the source?

 

Source code links are down for the main project

 

I ask again, anyone have the source code?

 

This kext does not work with Mavericks. I would like to recompile it to work with such.

Share this post


Link to post
Share on other sites

I ask again, anyone have the source code?

 

This kext does not work with Mavericks. I would like to recompile it to work with such.

Just stumbled upon it when I tried to snoop around the Wayback Machine for a mirror, so here's a mirror to the source archive:

http://www.strawberryforum.org/gtastuff/CMI8738PCIAudioDriver-0.6.4-src.tar.gz

 

Same quirks as with the original, and I do hope someone would make the input parts work, or at least do something ala-VoodooHDA.

Share this post


Link to post
Share on other sites

I've given up on it for Mavericks

 

Get a card that works with kx (older sound blaster cards)

 

They are absolutely outstanding and the quality is spectacular.

 

The SNR is at a high level meaning you hear more.

Share this post


Link to post
Share on other sites

I gave up on my Xonar long ago and just went to onboard in both Windows and OS X. I also use optical out.

 

As it's digital it doesn't make any difference if it's onboard or a dedicated card as there's no digital-to-analog conversion going on.

Share this post


Link to post
Share on other sites

How would I recompile the source (above) to work for Input on Mavericks? I have output working... I think that the kext may be picking up the wrong input instead of the Mic. Just tell me what I would need to do in Xcode for the driver to have support for Mavericks? Is it as simple as opening the project and exporting it as a kext for Mavericks?

Share this post


Link to post
Share on other sites

Who has gotten this working in Mavericks and how did you do it? Did you take the source and port to Mavericks? Did you use the kext posted for Lion? I tried the Lion kext and I do not have any audio. I am on 10.9.2 using a cmi8738 card.  Thanks.

Share this post


Link to post
Share on other sites

Thank you, geforcefan.

 

It works great! But, one problem exist...

 

After sleep & wake up, sound is gone. Volume control works, but no sound...

 

Maybe I can use script that unload and load 8738 kext after wake up... but it's annoying..

 

Can you fix it?

I have the same problem. Is there a fix?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×