Jump to content
Donk

Workstation 8/9/10, Player 4/5/6 and Fusion 4/5/6 Mac OS X Unlocker

543 posts in this topic

Recommended Posts

Ah we have a common theme Comodo AV. I will install a copy and see if that breaks my test VM. 

 

Yep  Comodo is the problem. You will need to whitelist unlocker.exe in the Comodo Behaviour Blocker or add it to the trusted files list.

 

(Have to say I think it is a pretty obnoxious piece of software, it's installer will put crapware on if you don't read the instructions correctly)

Share this post


Link to post
Share on other sites
Advertisement

Yep  Comodo is the problem. You will need to whitelist unlocker.exe in the Comodo Behaviour Blocker or add it to the trusted files list.

 

(Have to say I think it is a pretty obnoxious piece of software, it's installer will put crapware on if you don't read the instructions correctly)

I uninstalled Comodo and the install.cmd worked, disabling the antivirus didnt work.

Share this post


Link to post
Share on other sites

I uninstalled Comodo and the install.cmd worked, disabling the antivirus didnt work.

 

Great. At least we know what the problem is and how to solve it.

Share this post


Link to post
Share on other sites

Man, thank you so much for figuring out our mishaps.. Iv'e been struggling with this for months now. I even messed with file permissions (and prob screwed them up)

I am now happily back in business with Kali and Mac OS 10.9.1

 

I disabled and killed EVERY Comando firewall service running. Ran the Unlock 1.3 without a problem.

I personally like Comando and avoided to bloatware during install. 

 

Just in case anyone else gets this;

"You have started vmware server with an out-of-date copy of the application" , but researching I found this and fixed it. (You have to add the line to every VM )

http://binyit.blogspot.com/2014/01/solving-you-have-started-vmware-server.html

 

 

Thank you!!!!

Share this post


Link to post
Share on other sites

Yep  Comodo is the problem. You will need to whitelist unlocker.exe in the Comodo Behaviour Blocker or add it to the trusted files list.

 

(Have to say I think it is a pretty obnoxious piece of software, it's installer will put crapware on if you don't read the instructions correctly)

 

I agree but its also free so you can't really blame them. Atleast the crapware / bloatware is just more stuff from them and "privdog" is the only third party utility. At least its not like most companies with the ask bar and {censored} bar and whatever else.

 

Surprising thing is, since I've used comodo for years, I know i've had to whitelist my own programs I've built and some patches, so I believe I whitelisted unlocked.exe already and that didn't work for me too. But ill try that again and report back..

 

Again thanks for the help and I'm glad I could help find the issue. Always forget about AV but thats because I'm mostly a linux / os x user and dislike windows for anything but gaming

Share this post


Link to post
Share on other sites

I agree but its also free so you can't really blame them. Atleast the crapware / bloatware is just more stuff from them and "privdog" is the only third party utility. At least its not like most companies with the ask bar and {censored} bar and whatever else.

 

Surprising thing is, since I've used comodo for years, I know i've had to whitelist my own programs I've built and some patches, so I believe I whitelisted unlocked.exe already and that didn't work for me too. But ill try that again and report back..

 

Again thanks for the help and I'm glad I could help find the issue. Always forget about AV but thats because I'm mostly a linux / os x user and dislike windows for anything but gaming

On the plus side it does have a very good hit rate on malware. Like you I am mainly OS X but job also involves coding on Windows and Linux.

 

Anyway glad we got it resolved. Thanks for bearing with me as we worked it out.

Share this post


Link to post
Share on other sites

On the plus side it does have a very good hit rate on malware. Like you I am mainly OS X but job also involves coding on Windows and Linux.

 

Anyway glad we got it resolved. Thanks for bearing with me as we worked it out.

 

So my problem WAS comodo. Even after checking my trusted files, adjusting my behavior exclusions etc nothing. So I stopped the service, restart, ran the patcher, it worked, set the service to start, restarted and bam fully functionally VMware Workstation.

 

Thanks for being here to debug. I respect developers that support all of their projects. Ive met / seen developers put out something like this and NOT support it by being available because "its so simple it should always work and if it doesnt its the user" and while thats true on windows half of the time, its sometime conflicting calls or old code that does it too.

 

Im glad theres another OS X user out there. Getting sick of people saying OS X is for "noobs and the rich". I love OS X for the GUI and Unix Core. Ill always have OS X as client / desktop and unix / linux as backend / servers.

Share this post


Link to post
Share on other sites

So my problem WAS comodo. Even after checking my trusted files, adjusting my behavior exclusions etc nothing. So I stopped the service, restart, ran the patcher, it worked, set the service to start, restarted and bam fully functionally VMware Workstation.

 

Thanks for being here to debug. I respect developers that support all of their projects. Ive met / seen developers put out something like this and NOT support it by being available because "its so simple it should always work and if it doesnt its the user" and while thats true on windows half of the time, its sometime conflicting calls or old code that does it too.

 

Im glad theres another OS X user out there. Getting sick of people saying OS X is for "noobs and the rich". I love OS X for the GUI and Unix Core. Ill always have OS X as client / desktop and unix / linux as backend / servers.

 

Excellent - pleased you have it working.

 

Appreciate the comments, and agree that support is important. I have been in commercial software development for 26 years, and research software development for five years before that, and unless you help people use what you create you may as well not bother releasing it in the first place.

Share this post


Link to post
Share on other sites

Hi,

 

New to Unlocker. Installed it onto VMware WS 10 and installed Mavericks. Afterwards installed the VMWare Tools package that was included and noticed that at boot up the spinning wheel at bottom of apple grey screen has a black bar over it. Its probably a graphical anomoly and no big deal but thought to inform anyone interested..

 

Thanks.

Share this post


Link to post
Share on other sites
Bad news! 
 
VMware have removed the mechanisms used in the patcher to override the SMC and OS X Server checks in new Tech Preview of Workstation 11 and Fusion 7. May have to go back to adding FakeSMC to installation images.
 
Will keep looking but in the meantime do not use the Tech Previews if you want to have OS X guest compatibility.
 
Sorry for posting twice but important news if you rely on the unlocker, Started a thread here.

 

http://www.insanelymac.com/forum/topic/298257-vmware-tech-preview-2014-and-unlocker/?p=2022388

Share this post


Link to post
Share on other sites

Oh my God, you are my hero!!!!!!!!!

 

Has been 2 weeks scratching my head, then the solution is rather simple   :drool:

Share this post


Link to post
Share on other sites

VMware workstation has been updated to 10.0.3. Can anyone confirm it work well with VMware Unlocker v1.3?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

VMware workstation has been updated to 10.0.3. Can anyone confirm it work well with VMware Unlocker v1.3?

 

Thanks in advance.

Yes, upgraded to Workstation 10.0.3 and all is well with OS X, since the install process un-installs the previous version as part of the "upgrade" process, the unlocker (1.3.0) needs to be re-installed once the "upgrade" to 10.0.3 has completed. I always do a cold re-boot after a workstation "upgrade" and applying the unlocker, and follow the unlocker install with another cold re-boot, just to make sure all the networking and services are running correctly.

 

This is a duplicate of my post in the following topic:

 

http://www.insanelymac.com/forum/topic/290949-how-to-install-os-x-10x-snow-leopard-lion-mountain-lion-and-mavericks-in-vmware-workstation-910-or-player-56/?p=1936143

Share this post


Link to post
Share on other sites

New unlocker Yosemite...

What does that mean? Are you stating or asking ?

Newer than Version 1.3.0 ?

Share this post


Link to post
Share on other sites

New unlocker Yosemite...

The current unlocker 1.3.0 works fine with Yosemite as a Virtual Machine under Workstation 10.0.3, Player 6.0.3 and Fusion 6.0.4, no unlocker support for Fusion 7.0.0.

Share this post


Link to post
Share on other sites

What about 10.0.4 and unlocker 1.3?

 

And what about 10.0.4 and Yosemite? Using the online update, I now get stuck in the new white Apple on black background screen (System Tools get loaded)...

Share this post


Link to post
Share on other sites

Unkocer 

 

What about 10.0.4 and unlocker 1.3?

 

And what about 10.0.4 and Yosemite? Using the online update, I now get stuck in the new white Apple on black background screen (System Tools get loaded)...

 

Unlocker works with 10.0.4. I have not tried Yosemite but everyone needs to know that VMware had to make low level changes in Fusion 7 to support it. My guess is you won't get great performance until Workstation 11 and ESXi 6 ships in the New Year, which will share code with Fusion 7. The current Tech Preview predates the changes to Fusion 7 so that is unlikely to be any better plus there is no unlocker for it.

Share this post


Link to post
Share on other sites

Unlocker works with 10.0.4. I have not tried Yosemite but everyone needs to know that VMware had to make low level changes in Fusion 7 to support it. My guess is you won't get great performance until Workstation 11 and ESXi 6 ships in the New Year, which will share code with Fusion 7. The current Tech Preview predates the changes to Fusion 7 so that is unlikely to be any better plus there is no unlocker for it.

Just to confirm Yosemite works OK under both Workstation 10.0.4 and Player 6.0.4, performance is better with the latest VMware Tools from Fusion 7.0.1, but still not as good as in Fusion 7, see my post in the "How to", link below:

 

http://www.insanelymac.com/forum/topic/290949-how-to-install-os-x-10x-snow-leopard-lion-mountain-lion-and-mavericks-in-vmware-workstation-910-or-player-56/?p=2080177

Share this post


Link to post
Share on other sites

Awesome! Do you have a guide for installing or making the iso/dmg of yosemite?

NSCXP,

 

You should only need the .dmg as Workstation 10.0.3 or 10.0.4 appear to support .dmg for Mavericks and Yosemite. Please find below a link to a post on my "How To" where shela has posted an updated version of the CMI script created by Donk for Mavericks to support Yosemite, let me know if it works for you.

 

http://www.insanelymac.com/forum/topic/290949-how-to-install-os-x-10x-snow-leopard-lion-mountain-lion-and-mavericks-in-vmware-workstation-910-or-player-56/?p=2074610

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×