Jump to content

Too High Resolution After Rebooting Macvidia Driver


3 posts in this topic

Recommended Posts

Like as Topic... this is my problem.


I have just installed MacVidia 1.0.8.

After Reboot, Mac Os works perfectly but my monitor (15" Crt) doesn't support very high resolution, so it's impossible for me to setting 1024x768 again.


Anyone know as can i resolve the problem without formatting and reinstalling?

It's possible a "Safe mode" in 640x480/800x600/1024x768?



Thanks in advance.



Link to comment
Share on other sites

You're saying what you want to do, but you're not saying what exactly is happening with your monitor right now.


So, I'm going to guess that somehow, your resolution got set higher than 1024x768 and your monitor is out of scale and maybe displaying a black screen or a very distorted screen.


Try deleting preference files containing your settings:


Boot into single user mode (boot option -s after hitting F8)

At the command prompt

Type: /sbin/mount -uw /


Type: /bin/rm /Library/Preferences/com.apple.windowserver.plist


Type: /bin/rm /Users/(your-user-name)/Library/Preferences/ByHost/com.apple.windowserver*


Type: /bin/rm /Users/(your-user-name)/Library/Preferences/ByHost/com.apple.preference.displays*


Link to comment
Share on other sites

Cross posting this from the macvidia forums which I wrote this for:


1. Download cscreen (or google for it) extract the files from the zip.

2. Move the cscreen executable to your home directory (the one that looks like a house)

3. Open a terminal window.

4. Type: cp ~/cscreen /usr/sbin ; cp ~/Library/Preferences/ByHost/com.apple.windowserver ~/ ; cp ~/Library/Preferences/ByHost/com.apple.preference.displays* ~/ ; cp /Library/Preferences/com.apple.windowserver.plist ~/ ; sudo -s


Enter your password when prompted.


5. Type: rm ~/Library/Preferences/ByHost/com.apple.windowserver*

6. Type: rm ~/Library/Preferences/ByHost/com.apple.preference.displays*

7. Type: rm /Library/Preferences/com.apple.windowserver.plist

8. Type: pico /etc/rc

9. Use the arrow keys or your 'End' key to navigate to the last line.

10. Move up 8 lines so the cursor is ABOVE the line reading "touch/var/run/.systemStarterRunning"

11. Type: /usr/sbin/cscreen -x 1024 -y 768 -r 60 -d 32


If 1024x768@60Hz isn't the mode you want, vary #11 to select the mode you want. -x is screen width, -y is height, -r is refresh rate, -d is color depth


12. Use Control+X to tell pico to exit. When it asks to save/overwrite, SAY YES.

13. Type: pico /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

14. Place your cursor on the line above "</dict>" Press enter to insert a new line.

15. Type: <key>Graphics Mode</key>

16. Press enter for a new line. Type: <string>1024x768@60</string>

Use the same numbers you used in #11, the format is 'Width'x'Height'@'Refresh Rate' without the '.

17. Write the Boot.plist file using Control+X, say yes to overwrite like before.

18. Type: shutdown -h now


The above will cause OS X to switch display modes for the boot screen, and again forcing the mode as soon as userspace has loaded.

If it doesn't work after that, use safe mode/single user mode, repeat the above steps varying the settings you specified in #11 to something you know the display will support. Once you've gotten it to work like you want, restart the machine BEFORE you open the display preferences app otherwise it will attempt to load its default which will likely send your display into a fit. Do this for every user account on the machine (that you added). If you screw something up, remember you backed up (I hope you did!) your .plist files in your home directory (~/)... Copy them back and you'll be at the beginning.


Enjoy all that fancy desktop acreage!



Link to comment
Share on other sites


  • Create New...