Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
amit_talkin

boot0: error with single MBR partition!

7 posts in this topic

Recommended Posts

I have just installed Lion on my Dell L502x laptop with most of devices working.

However I am not able to boot from HDD without bootdisk :(. I didn't create GUID Partition because my lappy doesnt support booting from GPT disk, so i used MBR patch and installed Lion on MBR disk.

 

What I did,

1. formatted whole HDD.

2. inserted windows 7 DVD and created 2 partitions without formatted, and 1 reserved partition which windows 7 creates.

3. rebooted and installed Lion on one of the partitioned.

4. installed kexts n so n so and at last chimera!

5. rebooted and got boot0: error!

 

Also tried,

1. deleted all partitions except the one where Lion is installed.

2. then installed chimera and set Lion partition active.

3. Did above many times with minor changes.

4. rebooted.

5. boot0: error!

 

weird, because I dont have any other formatted partitions on my system. I even deleted all partitions except the Lion's. Made it active and reinstalled chimera as well, I did this more than 10 times now! still same error! :(. Its the only available partition on HDD and still getting this error! any clue about this?

Share this post


Link to post
Share on other sites
Read this post

 

http://www.tonymacx86.com/viewtopic.php?p=202165#p202165

 

hope it will help ;) .

 

So youre saying that if the boot1h file isnt there and you boot into single

user mode and replace it it will fix your bootloader?

Well i go to the file location i find it there. Am i doing something wrong?

:/

Share this post


Link to post
Share on other sites

what i did is , I booted from backup mac os on other partition, then unmounted the Lion partition and performed above task on that unmounted partition. you dont need to login as single user..just do it normally.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Yup that's fine! Oddly, when rebooting several times it is suddenly gone! Only thing I need to fix is getting 'Headphone' output to work, after sleep. Internal Speakers are working after sleep. I assume to fix this in CodecCommander.kext/ EAPDFix.kext? Anyway thanks for your help!   Yup I have a combo output, so there was something wrong I guess.
    • Nice @yapan4 then we can join forces to make this as good as possible.
    • I had a weird situation, after running great for a while: yesterday I did a reboot and got a KP. Turns out the AstekFusion2Adapter kexts were causing the KP, strange thing is I didn't recall applying any update or a like.  I had to boot with the USB installer, mount the EFI partition to delete the old AstekFusion2Adapter kexts and replaced with the patched version contributed by despeinao. I'm glad the system is working again, not having to reinstall OSX.
    • i think the "red light" you are referring to is that you have a optical SPDIF output (3.5 mm) combo jack. it most likely will be "red" when audio is active. 
    • Domanda , ma il tuo configplist lo ha settato cosi Gengik????
      Noto molte cose atipiche , tipo aperto con Clover configurator nella sezione ACPI il nome DSDT.aml NON è selezionato , quindi in teoria NON dovrebbe caricare il DSDT che hai in Clover ACPI Patch , se usi SSDT x la CPU NON dovrebbero servirti quelle personalizzazioni sempre in configplist sezione CPU ...
      Secondo me dovresti partire da un configplist pulito , xche sempre secondo me c'è rimasto delle schifezze di qualche tool x installare facile    EDIT
      Scaricando il configplist di jolly NOTO ha impostato +o- come intendevo fare io , sistemando quello  sopra elencato e bammmmm NON avvia , mi forniresti x favore Hack info che trovi nella mia firma ???
      Grazie   Ho creato un configplist , se vuoi provare , dovrebbe essere pulito da ogni impurità , se funziona dovrai adattarli tutte le tue personalizzazioni x il boot ..... config.plist.zip


×