Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Zoostorm Freedom 10-270

1 post in this topic

Recommended Posts

Netbook in question : http://www.zoostorm.com/Products/92-zoosto...-hd-laptop.aspx


Technical Specs (as far as im aware)

Atom N270


Intel 954GSE & ICH-7M

Ralink Wireless RT2860?/RT3090?

Intel GMA950


After many trial and errors and many reinstalls, I managed to get 10.6.0 retail installed with the help of NetbookInstaller 0.8.5pre (only one that allowed it to boot) even though it said it was not supported. I had to have the battery out though otherwise it would result in a kernel panic. I then used NetbookInstaller 0.8.4RC once on the desktop because it seemed to work better than NetbookInstaller 0.8.5pre (usb worked / graphics worked).


To get 1024x600 resolution i installed an older version of ScreenResX (3.8.6) as a trial, added the custom resolution, rebooted and uninstalled ScreenResX to get rid of the annoying pop up! There maybe a better way, i don't know.


I then installed VoodooBattery (after removing AppleACPIBatteryMonitor from /Extra/GeneralExtensions. This allowed me to use the thing with the battery in (no more KP's).


I then installed VoodooHDA (newest version) and sound was working (look for the iGain fix to stop that awful sound when you first install it).


Wireless you can get working using a mac driver from Ralinks website.


The only things i can tell that do not work are Speedstep and Sleep.


Speedstep is more important to me so i am asking for some help. I have tried installing VoodooPowerMini.kext but it KP. Google tells me that its not needed if you are using NetbookInstaller anyway. Well my speedstep doesnt work (checked with CPU-i and MSR Tools).


Anyone got any tips?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.