Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Donk

ESXi 5 Mac OS X Unlocker

817 posts in this topic

Recommended Posts

Thank you kindly sir.... progress made with some kernel kexts, and more importantly a new vm set for a "bios" instead of efi in esx.... and pointing to one of the osx vmdk.

 

I would like to see if 1.3.1 does better with the efi and bootable iso's.

 

I uploaded all the versions to www.daveparsons.net/downloads, and 1.3.1 is here http://daveparsons.net/downloads/unlock-all-v131.zip. 

Share this post


Link to post
Share on other sites

Did anyone have a go with ESXi 6?

 

This unlocker is only for ESXi 5. There is no functioning unlocker for ESXi 6 at the moment.

Share this post


Link to post
Share on other sites

I got that, I basically ment doing what the tool does manually and trying to get that working with 6.

Share this post


Link to post
Share on other sites

Is it possible to use a Xeon 5080 CPU? I have a dell precision 690 with dual Xeon 5080s running ESXi 5.5 U2 and I installed the 1.3.0 unlocker but I can't seem to get past the apple logo. Tried the CPUID masks I've seen in this forum but one caused a kernal panic and the other caused boot loops. Is my CPU just too old?

Share this post


Link to post
Share on other sites

Hi

 

I'm running one host with esxi 5.5 with the 1.3 unlocker, and it works really fine. 

 

My scratch partition is located on a SSD drive that I need to replace because of SMART errors.

 

Do I need to re-run the unlocker if I change my scratch location to another datastore?

 

What will be the best approach.?

Share this post


Link to post
Share on other sites

Hi

 

I'm running one host with esxi 5.5 with the 1.3 unlocker, and it works really fine. 

 

My scratch partition is located on a SSD drive that I need to replace because of SMART errors.

 

Do I need to re-run the unlocker if I change my scratch location to another datastore?

 

What will be the best approach.?

The patcher is embedded in a shell script local.sh which is run at boot from /etc/rc.local.d. This should not be affected by the location of the scratch files, so you should not need to re install the unlocker. 

Share this post


Link to post
Share on other sites

The patcher is embedded in a shell script local.sh which is run at boot from /etc/rc.local.d. This should not be affected by the location of the scratch files, so you should not need to re install the unlocker. 

Ok, thanks for the quick reply.

 

I know that 5.5U3 er pretty new, but do any know if it breaks the unlocker?

Share this post


Link to post
Share on other sites

Just in case I don't upgrade to esxi6, I will ask the similar questions here. This is NOT intended as a cross post.

 

Does esxi5.5 with unlocker 1.30 support el Capitan?

 

Do I still need beamoff with el Capitan?

Is el Capitan now recommended by good judgement (i.e. fixes more than it breaks)?

 

Thanks

Keith

Share this post


Link to post
Share on other sites

El capitan dont need beamoff it works perfectly without it as long as you install darwin tools from vmware (drivers etc).
I only use mavericks and el capitan becuase they are in my opinion much better the yosemite and i feel it fixes a lot of the lag issues with yosemite.

Share this post


Link to post
Share on other sites

This unlocker is only for ESXi 5. There is no functioning unlocker for ESXi 6 at the moment.

 

Is there any information on what specifically isn't working in esxi 6.0?  If it helps any, I have a few dev machines i am happy to beta test on! 

Share this post


Link to post
Share on other sites

Is it possible to use a Xeon 5080 CPU? I have a dell precision 690 with dual Xeon 5080s running ESXi 5.5 U2 and I installed the 1.3.0 unlocker but I can't seem to get past the apple logo. Tried the CPUID masks I've seen in this forum but one caused a kernal panic and the other caused boot loops. Is my CPU just too old?

 Any one have experience with this CPU? still trying. I've experimented with 10.8 10.9 and 10.11

Share this post


Link to post
Share on other sites

 Any one have experience with this CPU? still trying. I've experimented with 10.8 10.9 and 10.11

In theory your CPU(s) meet the minimum requirement to run OS X, however, all the documents I have read regarding Xeon processors and OS X mention 5100's and above, so I am guessing your CPU's are just to old to be supported in OS X, especially as OS X is very fussy about supported CPU's hence the CPUID masks needed. However the CPUID masks in the link below are from Xeon 5500 Series so no good in your case, sorry! Unless someone know better?

 

http://www.insanelymac.com/forum/topic/290949-how-to-install-os-x-10x-snow-leopard-to-el-capitan-in-vmware-workstation-1011-workstation-proplayer-12-player-67-esxi-56/

Share this post


Link to post
Share on other sites

Guys, got a question. Now I'm running clean OS X and I wanna passthorough Videocard. In order to make it work I need to use Clover or something to inject kexts and so on.

How do Iinstall cusom bootloader to the system in ESXI?

 

I've already have tested this, and it works for windows (videocard passthrough).

Share this post


Link to post
Share on other sites

i only tested reefit and that works for me 9 out 10 times sometimes the allocation via boot.efi fails but the second try it works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×