Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
ErmaC

[GUIDE] Lion 10.7 on Asus X58 (LGA 1366) i7 9xx

870 posts in this topic

Recommended Posts

First of all, thank you for this guide and files.

I have an ASUS P6X58D-E and I did the whole process using a GeForce GTX 260 and everything worked (no special flags)

 

BUT, then I changed to my GeForce GTX 560Ti, and I cannot longer boot.

I tried flags such as: -npci=0x2000 , -PCIRootUID=1, -x, and nothing works.

My boot gets stuck at: [PCI configuration begin]

 

Please any help!

Thanks!

 

If you still have your USB Boot make with Lionize try a fresh install maybe add the 10.7.1 update.

 

Fabio

Share this post


Link to post
Share on other sites
I try this but error still appears.

this is my diskutil list, so please help step by step...

 

also, if it is possible, can I have only Lion and Windows7 partition in chameleon? is it possible to "hide" other partitions in chameleon ?

I would like to see only disk0s2 and disk1s2

 

 

thanks.

 

 

please help !

Share this post


Link to post
Share on other sites
First of all, thank you for this guide and files.

I have an ASUS P6X58D-E and I did the whole process using a GeForce GTX 260 and everything worked (no special flags)

 

BUT, then I changed to my GeForce GTX 560Ti, and I cannot longer boot.

I tried flags such as: -npci=0x2000 , -PCIRootUID=1, -x, and nothing works.

My boot gets stuck at: [PCI configuration begin]

 

Please any help!

Thanks!

 

You shouldn't add the "-" before npci or PciRootUID flags.

 

try this

-v npci=0x2000

 

Ciao .: ErmaC :.,

 

after the sucessful instalation on my machine to a external USB HDD for test, i recreated the usb stick with Lionize 1.04 and installed on my hdd over my SL installation.

 

On this second installation i noticed some issues that i didn't on the USB HDD installation.

 

1- All my internal drives are showing as External not Internal

2- The computer is much slower then it was with the external USB HDD and in SL :)

3- All my IDE componets disapeared (No hdd and no optical drive). I even installed JmicronATA (this kext solved the problem on SL, but not on Lion)

 

Thank you in advanced

 

1- Solved with AHCI_3rdParty_SATA.kext from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]

2- Solved with a clean install

3- Still with the save problem, no IDE drives. No DVD or HDD

 

Just noticed that when i'm finalizing the instalation (./finalize /Volumes/LionHdd) and the filnalize command is instaling JMicronATA.kext it shows this output:

JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

Share this post


Link to post
Share on other sites
I will try this.

 

Also, I forgot to add CUDA in Lionize. Can I install it now from 10.7.1 directly? Do I need to recreande.command?

 

No problem if you forgot to add CUDA, you can add it when you are in Lion...

Link --> http://www.nvidia.com/object/mac-driver-archive.html

 

Recreandae.command generally is useful for re-add losted patch after an Apple update..

 

@ DefKorns

For your problem number 3

Try run Reacreandae.command from LionizeV1.05 package

 

Fabio

Share this post


Link to post
Share on other sites
@ DefKorns

For your problem number 3

Try run Reacreandae.command from LionizeV1.05 package

 

Fabio

 

A patchear de ficheiro Info.plist do JMiconATA de...
 AppleRTC.kext Binpatche...
 A copiar custom power management profile
JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.
CMUSBPointer.kext - dependency for com.orderedbytes.driver.CMUSBDevices lacks valid OSBundleCompatibleVersion.
CMUSBPointer.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
CMUSBKeyboard.kext - dependency for com.orderedbytes.driver.CMUSBDevices lacks valid OSBundleCompatibleVersion.
CMUSBKeyboard.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
CMUSBPointer.kext - dependency for com.orderedbytes.driver.CMUSBDevices lacks valid OSBundleCompatibleVersion.
CMUSBPointer.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
CMUSBKeyboard.kext - dependency for com.orderedbytes.driver.CMUSBDevices lacks valid OSBundleCompatibleVersion.
CMUSBKeyboard.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)
Created mkext archive /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext.
logout

Still no DVD Drive or HDD

Share this post


Link to post
Share on other sites
this is what I got...cant install...cant download (but internet work fine) ???

 

what folder do I need to select from HD?

 

 

the website your using is down try again in a few hours / tomorrow

Share this post


Link to post
Share on other sites

Thanks DefKorns, npci=0x2000 (no dash :( ) allowed me to boot.

 

I have a couple of small issues:

 

1. The hard drive where I installed Lion has 2 more partitions (NTFS), but they are NOT for any other OS. When I went to Windows, I could not see these 2 partitions, then I made them Active and apply a Drive Letter to them. It solve the problem but it broke the Lion boot. I only get... "bootmgr is missing" even after reinstalling Lion for a second time, and doing the ./finalize .. and saying Y to Chamaleon... (I can boot from the USB though)

 

2. With Lion and a Geforce GTX 560, what is the best way to have full GPU acceleration? I am now in 1024x768.

 

Thanks!

 

 

You shouldn't add the "-" before npci or PciRootUID flags.

 

try this

-v npci=0x2000

Share this post


Link to post
Share on other sites
Thanks DefKorns, npci=0x2000 (no dash :unsure: ) allowed me to boot.

 

I have a couple of small issues:

 

1. The hard drive where I installed Lion has 2 more partitions (NTFS), but they are NOT for any other OS. When I went to Windows, I could not see these 2 partitions, then I made them Active and apply a Drive Letter to them. It solve the problem but it broke the Lion boot. I only get... "bootmgr is missing" even after reinstalling Lion for a second time, and doing the ./finalize .. and saying Y to Chamaleon... (I can boot from the USB though)

 

2. With Lion and a Geforce GTX 560, what is the best way to have full GPU acceleration? I am now in 1024x768.

 

Is present a important step when you run ./finalize

The "script" ask you if you won't install chameleon on that partition..

 

the problem is...

this install support only a boot0 method no boot0hfs or the new boot0md

 

So I suggest you when you install (reinstall) simply say no (in the finalize step),

and use other tool like Chameleon wizard for a better install option method for your boot...

You can do this from other partition or boot with the USB boot (created with Lionize)... there is a lot of possibility...

 

Fabio

Share this post


Link to post
Share on other sites
Thanks DefKorns, npci=0x2000 (no dash :unsure: ) allowed me to boot.

 

I have a couple of small issues:

 

1. The hard drive where I installed Lion has 2 more partitions (NTFS), but they are NOT for any other OS. When I went to Windows, I could not see these 2 partitions, then I made them Active and apply a Drive Letter to them. It solve the problem but it broke the Lion boot. I only get... "bootmgr is missing" even after reinstalling Lion for a second time, and doing the ./finalize .. and saying Y to Chamaleon... (I can boot from the USB though)

 

2. With Lion and a Geforce GTX 560, what is the best way to have full GPU acceleration? I am now in 1024x768.

 

Thanks!

 

 

1- Boot from your USB into lion and then install this version of Chameleon (this worked for me)

2- Try this Guide

 

PS: if you want to remove npci=0x2000 from your kernel flags try my solution on post 9

Share this post


Link to post
Share on other sites

Thanks Guys!!!

 

My Geforce 560 Ti is Solved! besides adding the ID, the key part was having this in the ...boot.plist

<key>GraphicsEnabler</key>
<string>Yes</string>	
<key>Graphics Mode</key>
<string></string>

 

As far as installing a new Chameleon, what options should I checkmark (i386, PrefPane, Modules,...)

 

Thank you very much for all your help!

Share this post


Link to post
Share on other sites
Thanks Guys!!!

 

My Geforce 560 Ti is Solved! besides adding the ID, the key part was having this in the ...boot.plist

<key>GraphicsEnabler</key>
<string>Yes</string>	
<key>Graphics Mode</key>
<string></string>

 

As far as installing a new Chameleon, what options should I checkmark (i386, PrefPane, Modules,...)

 

Thank you very much for all your help!

I just selected i386 and a theme (optional)

Share this post


Link to post
Share on other sites

Can anyone point me to a site/advice on how to either get OSX to support a second graphics card(both 460gtx) or at least ignore it if it is in? p6t deluxe using the Lion installer on here.

 

Thanks again to OP. This was the smoothest install I have ever had.

Share this post


Link to post
Share on other sites
Can anyone point me to a site/advice on how to either get OSX to support a second graphics card(both 460gtx) or at least ignore it if it is in? p6t deluxe using the Lion installer on here.

 

Thanks again to OP. This was the smoothest install I have ever had.

 

 

You should try netkas or Tonymac's

 

i know that with gtx 470 was +pssible on SL.

Share this post


Link to post
Share on other sites
Just curious, Can I recreate your Lion USB method within Lion? or it needs to be on Snow Leopard?

Thanks

 

Lionize can works with Leopard, Snow Leopard, and Lion from an Hack or a real Mac ;)

 

Can anyone point me to a site/advice on how to either get OSX to support a second graphics card(both 460gtx) or at least ignore it if it is in? p6t deluxe using the Lion installer on here.

 

Thanks again to OP. This was the smoothest install I have ever had.

 

@siefert

PLS add your spec in signature. (this help people and help yourself).

Is also possible add the second o third (or fourth I already do it..) from DSDT injection or "better" with an external SSDT

 

Fabio

Share this post


Link to post
Share on other sites
Fabio,

 

still no DVD drive. Should i try to change JM on bios from AHCI to ide?

 

JM363... take a look here...

http://www.insanelymac.com/forum/index.php?showtopic=209898

the patch is already "add" into the Info.plist of JmicronATA.kext in S/L/E

let me know

 

Try overwrite the Info.plist with this...JMicronATA.zip

/System/Library/Extensions/JMicronATA.kext/Contents/Info.plist

 

Other user with P6T SE have this problem?

 

Fabio

Share this post


Link to post
Share on other sites

MacPro4,1 vs. MacPro5,1

 

When Lionizing, I remember I could choose MacPro4,1 , MacPro5,1 , What do you recommend for the Asus P6X58D-E? I did it with MacPro4,1 , but is there any difference?

Thanks!

Share this post


Link to post
Share on other sites

Failed during install due to nstat error.. pictures attached

 

I searched around and it looks like the nstat error is also happening for regular Macs that already have Lion installed, and even they can't figure out how to fix it :)

 

So.. if nstat error has no fix, and nstat error is specific to Lion, maybe I can use the motherboard-related files created by Lionize to install Snow Leopard instead and then upgrade?

 

Some other notes..

 

I used a partioning program to create a Lion drive formatted as HFS+ but I guess this made no difference because the installer never got that far.

 

I have a P6T with the bios version updated to 1408 .. does bios version need to be something other?

post-584694-1316413402_thumb.jpg

post-584694-1316413433_thumb.jpg

Share this post


Link to post
Share on other sites
MacPro4,1 vs. MacPro5,1

 

When Lionizing, I remember I could choose MacPro4,1 , MacPro5,1 , What do you recommend for the Asus P6X58D-E? I did it with MacPro4,1 , but is there any difference?

Thanks!

 

MacPro4,1 is for quad core cpu like i7 920, 930, etc

MacPro5,1 Recommended for 6 core CPU like i7 970, 980x or 990x

 

JM363... take a look here...

http://www.insanelymac.com/forum/index.php?showtopic=209898

the patch is already "add" into the Info.plist of JmicronATA.kext in S/L/E

let me know

 

Try overwrite the Info.plist with this...JMicronATA.zip

/System/Library/Extensions/JMicronATA.kext/Contents/Info.plist

 

Other user with P6T SE have this problem?

 

Fabio

 

Edited both AHCIPortInjector.kext and JMicronATA.kext.

 

Still no changes. Perhaps it's time to buy a SATA DVD :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×