Jump to content
InsanelyMac Forum
Martuzki

ATI 4570 SpeedStep

Recommended Posts

Hello! ;)

 

My GraphicCard runs finally great with QE/CI support. But i think that the card runs verry hot in my lapptop so the fan runs all the time.

Is there a chance to enable speed step for it? Speedstep for CPU works great.

Share this post


Link to post
Share on other sites
Advertisement
Hello! :)

 

My GraphicCard runs finally great with QE/CI support. But i think that the card runs verry hot in my lapptop so the fan runs all the time.

Is there a chance to enable speed step for it? Speedstep for CPU works great.

Are you able to wake from sleep without the display becoming distorted(different colors, inverted colors etc)

Share this post


Link to post
Share on other sites
Are you able to wake from sleep without the display becoming distorted(different colors, inverted colors etc)

No, sleep wont work. When I'm trying to activate sleep the display goes off but the laptop wont turn off... fan runs...

 

@soulcopy

Can you read? Try reading my siganture :P

Share this post


Link to post
Share on other sites
No, sleep wont work. When I'm trying to activate sleep the display goes off but the laptop wont turn off... fan runs...

 

@soulcopy

Can you read? Try reading my siganture ;)

 

I had the same issue but after struggling and searching for a solution found out that by pmset our hibernate mode to 0 i was able to put my lappy to sleep. Try it out.

Share this post


Link to post
Share on other sites
And than sleep will work and the Fan runs silent?

 

It worked for me. Try it. Also keep in mind you should have proper dsdt as well with all the usb fixes and stuff.

Share this post


Link to post
Share on other sites

Hmm...okay. But when i run the command nohing happens...

DSDT with 3 Speedstep is in /E/

CPU min Freq.: 1,20ghz (600mhz in DSDT)

Share this post


Link to post
Share on other sites
Hmm...okay. But when i run the command nohing happens...

DSDT with 3 Speedstep is in /E/

CPU min Freq.: 1,20ghz (600mhz in DSDT)

 

 

what was said here will not help you with the gpu fan..

 

You need NO DSDt ( wont harm if you have one, but it is not needed for what you want )

 

Has ABSOLUTELY NOTHING TO DO WITH THE CPU , if Speedstep works or not, if you use vanilla or Nullcpu..

 

The solution is very simple.. ONE kext in Snow/lion controls the fan of the graphics-card :

 

AppleGraphicsPowermanagement.kext

this sits in /S/L/E and Info.plist inside has ALL Macintosh machines and their Graphics listed.. Also the various powersettings ( fan-speeds ) for the cards..

 

So OSX looks what Mac it runs on ( On a Hack = SMBIOS.plist in Extra identifies the Mac Model .. ) , and decides according to the SMBIOS which graphics-support it will turn on, i.e. how to handle the load for the graphics-card and how to control the fan in it..

 

 

So, solution is to use a SMBIOS of a Mac that really ships with such a , or a very close / similar gpu, or to use a modded AppleGraphicsPowermanagement.kext ( rename inside kexts info.plist the MacModel ID that has 4570like card to MacModel-ID your SMBIOS uses ).

 

Sounds complicated ? it is not. Start with the easy method, to use SMBIOS.plist of a compatible Mac.

 

I suggest to try SMBIOS.plist of iMac9,1 - iMac10,1 or iMac11,1 ( have Ati Mobility Radeon HD 4670 fanspeeds in ApplegraphicsPowermanagement.kext -- should match the 45xx gpu,too )

 

Have Fun ^_^

Share this post


Link to post
Share on other sites

Guys, I have a Dell Studio 1555 (With ATI Mobility Radeon HD 4570 Graphics Card, id:0x9553) laptop and trying to make my external monitor (HDMI) work. I tried some kext files but I always had a black screen with white lines at the end. Everything else works good except the HDMI port. Anyone has the right kext files for this card?

I have OSX 10.6.6 installed. Thanks

Share this post


Link to post
Share on other sites

I'm on Mountaion Lion and I can't get the AppleGraphicsPowermanagement.kext to load. I've tried iMac9,1, iMac10,1, iMac11,1, MacPro3,1. With MacPro5,1 the kext is loaded, but I get a kernel panic. I have ATI Radeon 4330 Mobility Hd.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×