Jump to content
InsanelyMac Forum
nozyczek

[GUIDE] OS X Lion on Intel D945GCLF2 Atom 330

Recommended Posts

Strike that. It really was the ethernet driver. Just download the latest one (linked previously in this thread) and install it after the installer script runs, before you reboot.

10.7.3 works great with this installer.

Share this post


Link to post
Share on other sites
Advertisement

I put together a system for less than $150 with this board and a mini-itx case from fleabay and a 2GB stick of RAM and a 60GB SSD from Newegg. Replaced the motherboard fan with a heatsink and the case has an AC power supply. This thing runs OS/X Lion 10.7.3 with no moving parts. Pretty cool.

 

Anyway, the sequence of event I followed looked like this:

 

 

 

 

1. Install Lion 10.7 from installer USB

2. run ./installer script

3. re-boot to 10.7

4. run 10.7.3 combo update dmg (DON'T REBOOT)

5. run ./installer script again

6. run Realtek kext pkg installer

7. re-boot

8. repair disk permissions

 

I have another similar system with the exact same board running Snow Leopard 10.6.7 also from an SSD which I use as my primary desktop. I have to say the Lion O/S runs significantly slower than SL with this board. Really not worth the upgrade from Snow Leopard if you want to maintain performance, IMO. Most people will find this much too sluggish, even running on an SSD. Fun to play with however.

 

This board running Snow Leopard (especially from an SSD) is a thing of beauty and makes for a great little computer.

Share this post


Link to post
Share on other sites

thank

nozyczek and all guys on this post , i followed your guide and updates and now i have on my D945GCLF2 server

"Lion Server 10.7.2" working good !!!

important things were:

- update bios version to 278

- install Eth Realink drivers after "installer" script and before reboot

Share this post


Link to post
Share on other sites

I have an Intel D945GCLF2D and successfully installed Snow Leopard using Nozyczek's Guide. Now I want to install Lion based on Install Disk downloaded from Apple store. I followed Nozyczek's Guide for Lion and made the USB install stick, but no joy, when I boot from install stick the boot stalls at "Still waiting for root device".

 

Initially the stall was directly preceded by "couldn't alloc class IOUSBMassStorageClass", and based on Googling that message I tried boot flags npci=0x2000 and USBFix=Yes, still no joy. Based on further ideas in this thread I then installed

Lnx2Mac's Realtek RTL81xx Driver on the boot stick, still shows

IOUSBMassStorageClass error, followed by messages about RTL81xx adapter, and then the "Still waiting ...." message. I've attached hereto the screen image at the stall.

 

 

 

I'd appreciate ideas on what's wrong and how to fix. Thx, Gus

post-862297-0-57478100-1342713339_thumb.jpg

Share this post


Link to post
Share on other sites

I later got this to work, using

Nozyczek's Guide, with the following changes:

 

-Revert to Lion 10.7.3 (I had downloaded latest Lion 10.7.4 from Apple site, which causes USB problems on some hackintoshs)

-Use RealtekRTL81xx-0_0_90 kexts (download on

Nozyczek is 0_0_67)

-Use

Chimera-1.11.0 (download on

Nozyczek is 1.7)

Share this post


Link to post
Share on other sites

My 10.7.3 system (Celeron 420, GMA950) runs pretty well with nawcom's 10.7.1 kernel.

However, this kernel no longer work with 10.7.4

 

I tried the following kernel but it didn't work

http://www.osx86.net...l_atom.zip.html

 

It kept looping with "Cannot mount root, errno=19"

 

Does anyone got 10.7.4 running properly?

 

 

Edit:

 

32 bit kernel didn't work

64 bit kernel work but there is no driver for GMA950

Share this post


Link to post
Share on other sites

My results:

 

Updating to the latest firmware must be done before you attempt installing lion. Follow the guide and it will install fine if this is done.

 

10.7 --> 10.7.1 update, ran ./installer then reboot : working system.

 

-->10.7.3 combo update, ran ./installer, run network driver pkg (as mentioned earlier in this thread), reboot : working ok apart from iCloud.

 

Fix permissions after reboot.

 

I spent some time finding a fix for iCould, including messing around with network settings, deleting plist files etc but nothing worked (as per suggestions on some other threads/forums like this one (post by jtholb)) **.

 

Found this thread where someone had uploaded a custom compiled chameleon r1496 boot file. Download the file and then move (mv) to root ('/') using sudo -s. You may be wise to backup your old boot file (mv /boot /boot-old) first.

 

I can confirm it works a treat - system seems stable and it sleeps fine.

 

** I left the suggested fix in place, so it may have made a difference, it may have not. If you have used the new boot file and you still can't get iCloud to work then it may be an important step.

 

Haven't attempted 10.7.4.

Share this post


Link to post
Share on other sites

Is nobody still playing with Lion on D945GCLF2? Anyone got 10.7.5 running reliably (how?) or not?  Just picked up this mobo again and wondering if to put Snow on it or Lion. ML out of question!

Share this post


Link to post
Share on other sites

need help want to install lion... but when i download lion now in app store its the build 10.7.5... i had years ago lion running on the board with 10.7.1... but when i prepare the stick ready to install it stucks on "waiting for root device" i read already that is a problem with the kernel.... can anybody help me how i get it to work with the actual lion build from the App Store

 

thanks so much...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×