Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Asus 1201N Installation and support

1,055 posts in this topic

Recommended Posts

Hello it has been a while since anyone has posted here and I wanted to ask if anyone has tried to install 10.10.3 from scratch.  I am attempting to do it following TimeWalker's guide but run into issues just booting to the installer.


After trying multiple times to boot, sometimes it will get to the language selection screen, but will grey screen as soon as I click down on the trackpad.


Does anyone have any advice for me?

Share this post

Link to post
Share on other sites

Just wanted to leave a quick thanks for everyone who contributed to this thread, especially theconnactic and TimeWalker75a.


Thanks to your work I was able to get Yosemite running on 3 different ION/ION LE based machines.


Using your tutorial I was able to get Yosemite 10.10 running perfect on my Asus 1201N, but I was also able to use some of the same files to get my Acer Aspire Revo AR1600/R1600 (ION LE) and AR3600/R3600 (ION) working too.


For many months I had no luck getting my ION-based Acer nettops to work properly (swap file errors, USB errors, QE/CI would initialize in the bootup but would produce a blank screen on VGA/HDMI, etc, very similar to the 1201N).


But then I came across the below link from theconnactic:




And the below link from TimeWalker75a:




And the combination of files from both links allowed me to boot BOTH my Acer Revo nettops successfully!


The minimum 'required' files/extensions/bootloader/config to boot Yosemite on the ION-based Acer Aspire Revo AR1600/R1600/AR3600/R3600/AR3610/R3610 are the following:


- Clover bootloader (any recent version, I used r2988)

- Inject - Nvidia set to 'true' in Clover (inject QE/CI, works for VGA and HDMI)

- KernelCpu set to 'true' in Clover (on-the-fly kernel patching to support Atom CPU)

- theconnactic's boot file for Clover (intended for Asus 1201n but also works perfect for R1600/R3600, extracted from theconnactic's Asus 1201N Clover boot/EFI package found here: http://www.insanelymac.com/forum/topic/264740-asus-1201n-installation-and-support/page-49#entry2033600 )

- TimeWalker75a's 'CustomPeripherals.kext' extension (intended for Asus 1201n but also works perfect for R1600/R3600, extracted from TimeWalker75a's Asus 1201N installer package found here: http://www.insanelymac.com/forum/topic/295079-asus-1201n-installation-and-support-mav/#entry2042094 )

- Apple RTC CMOS Reset patch (can be found here: http://www.insanelymac.com/forum/topic/298536-applertc-patch-cmos-reset/ )

- 'NullCPUPowerManagement.kext' (can be found anywhere online)

- VoodooHDA v2.8.6 (can be found anywhere online)


With the above files I can boot Mavericks and Yosemite on my ION-based Acer Aspire Revo R1600/R3600 (also works for AR1600/R1600/AR3600/R3600/AR3610/R3610) with full QE/CI, Sound, Sleep and Network.


It seems the ION and ION LE based netbooks/nettops do have really poor BIOSes (regardless of vendor it seems), and the default Clover/Chameleon/Chimera configs are not enough to boot correctly, so by adding the above boot file and extensions they are able to boot using Clover no problem.


I would expect that the above configuration would probably work well for other ION/ION LE based netbooks/nettops too, as their hardware is all very similar.

how exactly did you do this? what do you have in bios, in kexts, in drivers, in acpi? I am trying but all I get is a black screen after selecting usb boot from clover. And when are you supposed to apply the RTC patch?




I was able to get to installer and install mavericks but then can't boot from HDD (selected in clover booting by USB). It just hangs after a bit.


Edit 2:


I put fix ownership in clover and was able to complete the installation, however at first reboot usb keyboard and mouse are not working anymore. USBF error is shown at start.

Share this post

Link to post
Share on other sites

Thanks to TimeWalker75a & theconnatcic ! I can install Yosemite & Maverick in my Acer Revo R3600(4g ddr2) by using the packages made by Timewalker75a.I had modified SSDT-5.aml to make system loads SMBUS & LPC kext. Only 1 problem was found ,that is EHCI not working properly except disable USB legacy support in the bios.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.