Jump to content

OSx86 won't boot after install


dazzer
 Share

2 posts in this topic

Recommended Posts

Hi,

 

I have successfully install OSx86 using the intructions: [HowTo] XP + OSX 10.4.4-10.4.7 native dual boot, NO VMWare, no Linux, no Chain0 required. With pictures http://forum.insanelymac.com/index.php?showtopic=11339

 

I used the MacOSX_10.4.6DVDPATCHED_Myz ISO image.

 

My problem is after installing OSx86 reboots, but my active OSx86 partition won't boot - my laptop thinks there isn't a bootable OS on there.

 

My system: Toshiba Tecra M5. My disks has the following partititons:

0: Windows XP

1: MAC (MACOS extended Journaled)

2: Solaris

3: Logical partition containing a DOS FAT partition

 

Most of the time I use Solaris as my active partition using GRUB to load Solaris or Windows. However, in this test, my MAC OSx86 partition is ACTIVE.

 

The OSx86 installation went OK and I managed to load the installer from the DVD using these options:

 

platform=x86pc cpus=1 idlehalt=0 fn=3 -v

 

and the installation went well. However, a reboot at the end results in the TOSHIBA seeing no OS to load on the OSx86 active partition.

 

Booting from the OSx86 boot DVD again, I can actually use the DARWIN boot loader from the DVD and then load OSx86 from my hard disk partition using:

 

hd(0,a)mach_kernel platform=x86pc cpus=1 idlehalt=0 fn=3 -v

 

so I know that the OSx86 install went well as it all works - it's just booting the thing I can't fathom. I eventually want to use GRUB (but let's not go there yet, as I'm trying to walk before I can run).

 

Can anyone give me some clues as to why my TOSHIBA laptop isn't seeing a boot loader on the OSx86 active partition? How can I check that there is one there? I have tried booting from the OSx86 DVD and running the DISK UTILITY and REPAIRING my OSx86 hard disk partition - this said nothing needed repairing, but still can't boot OSx86 from the hard disk.

 

Any help please

Link to comment
Share on other sites

  • 2 years later...

Hope this helps for finding you hard drive mac boot.....

I need HELP on BIOS settings FOR RAMPAGE EXTREME II, I too have loaded ideneb 10.5.5 on my PC, (ASUS RAMPAGE EXTREME II AND i7920... i finally got it to find the harddrive where I loaded mac Ideneb on (HOW YOU ASK?= After mac install on a formated extended journed Separate hardrive, I immediately opened the terminal from the install menu before reboot! and typed "fdisk -e/dev/rdisk2s2".....the 2s2 was identified as the actual harddrive and partition on my computer....YOU ASK AGAIN....I found out which drive it was by typing in the termal program Immediately after insall of IDENEB "diskutil list"....which provided me the "2s2" as the mac hardrive in my computer.)

 

PROBLEM: It will not boot mac from the hardrive, It starts then goes to time out. :(

 

Also all the other programs: xxx10.5.6, IPC 10.5.6, TOHX86, KALYWAY 10.5.2, v.7, generic kernals/my retail copy of OSX, etc. :wacko:

 

I have tried everything in setting up the BIOS (note: I have to change the default settings to achieve the above result....I follow simular but not the same as mine and it sometimes allows IDENEB to load)

 

I have read gobs of forums, But I think I need the Bios settings for my board and processor (asus extreme II + Intel i7-920) for best opperation. Screen shots would be great!

 

Then a simple step by step process......remember I am a Mac person, not a geek for IBM. For getting my system up and running, I will deal with the sound, 4 cores and internet later.

ANY HELP WOULD BE APPRECIATED. thanks

Link to comment
Share on other sites

 Share

×
×
  • Create New...