Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Aju Deeju

[GUIDE] OSX Lion on non-GUID (works on final too)

130 posts in this topic

Recommended Posts

I don't know why the booting doesn't work when using my 8 gb pen drive. I was able to boot when I created the installation media on my external hard disk. However I am now stuck on "Still waiting for root device" error during installation.

 

I found out why my 8gb pen drive wasn't working. Its because it formatted as GUID partitioning scheme. I formatted it to MBR and now its working.

 

I am stuck at the "Still waiting for the root device" issue. I have set AHCI mode in my bios.

Share this post


Link to post
Share on other sites

hi Aju Deeju

thanks for the excellent guide.

i followed your guide, boot from the usb, but when i click on customize button, i get blank selection screen. anyway i install lion, it is working fine, but no graphics, keyboard, lan etc. even the search is not working.

 

my system is

Dell Studio 1558

core i7 Q720 @ 1.6ghz

ati radeon hd 5470

4 gb ram

Share this post


Link to post
Share on other sites

I can confirm Hackintosh2000's statement above - even though the paths are same, the file names from Nawcom's patch and actual Lion dmg are different. Trying to boot by replacing the files (after renaming the files which have different names to those of existing files) causes the boot process to crash halfway and the system resets with no warnings.

 

Even tried myHack; that too does not work.

Share this post


Link to post
Share on other sites

Hey guys,

 

I followed this guide and stuck at installation step 9.

 

Just simply stop at Still waiting for boot device.

 

I have tried to unplug every HDD (except the 1 i wish to install Lion), DVDrom, tried every sata port configured my bios setting accordingly but still no luck at all.

 

Also tried -v -s -f -x and whatever combination i can find for my motherboard everytime just stuck at the same place.

 

 

Processor - Intel® Core2 Duo CPU E7400 @ 2.80GHz, 2800 Mhz, 2 Core(s), 2 Logical Processor(s)

 

Motherboard - System Model G31M-ES2L

Graphic Card - NVIDIA GeForce GT 240

 

RAM - 2GB X 2 Kingston 800

 

Any suggestion

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  
    • MAld0n, I can't post a new topic on post installation forum. is it on maintenance?
      Notebook Asus X550VX i7 - 7700hq
      GTX950MX - UHD630
      A1718086 - 025510ec ALC255 that works only on VoodooHDA 
      RTL8111 LAN Hwinfo
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL   Not work:
      1. White Screen Wake up
      EDID not a asolution
      IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
      http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist Image
      https://ibb.co/faL5wx 2. Battery info status bar sometimes goes on / off like battery has off
      3. Crackle Sound using   earphone using VoodooHDA
             Still investigation using patched iomatch voodooha info.plist
             The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99
      I have your (Mald0n) DSDT   http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl   I have re-patched again for FnKeys and Brighness Key http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml

       
      codec dump linux
      https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
       
       
      latest debug
      http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
       
      clover and kext
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
       


×