Jump to content
demonfox13x

Lion GM Facetime error

84 posts in this topic

Recommended Posts

Advertisement
Edited my DSDT, added my ethernet in to it, so I don't need EthernetBuiltIn. I don't use Chameleon, I use XPC.

 

With that edit, Facetime works.

 

http://i.imgur.com/QuE5n.png

 

wow that seemed to have done it. I added ethernet to my dsdt and rebooted using r755 and it finally logged in!

Share this post


Link to post
Share on other sites

so, editing the dsdt and adding ethernet, can you show how you did that ?

 

once the dsdt is edited will it work with a later release of chameleon, say r1078 ?

Share this post


Link to post
Share on other sites

Used demonfox13x's link for adding ethernet controller to dsdt, but FT doesn't work. I have an Realtek nic (dev-id: 0x8168) and use RealtekR1000SL.kext for getting ethernet to work. Any suggestions?

Share this post


Link to post
Share on other sites

check ioregistry explorer to see if the dsdt addition was added correctly.

 

screenshot20110725at316.png

 

type in "ethernet" in the search and see if your controller is now under GIGE@0

 

if it is try deleting the network plist files and FaceTime plist files.

 

 

Edit***

 

Just to be clear FaceTime was activated with Chameleon rc5 755 + DSDT edit. After FaceTime is activated you can update chameleon to any version and it'll still work, but if you log off you won't be able to log back in. To log in for the first time 755 must be used.

Share this post


Link to post
Share on other sites
Just to be clear FaceTime was activated with Chameleon rc5 755 + DSDT edit. After FaceTime is activated you can update chameleon to any version and it'll still work, but if you log off you won't be able to log back in. To log in for the first time 755 must be used.

 

Have done exactly this in the meantime - downgraded to 755 - FaceTime works &lost Graphics enabler, restored chameleon to my previous version: graphics and FT working, but after adding my secondary mail address it also stopped working again. So i downgraded to 755 and inject graphics with EFI String. All working for now :)

Share this post


Link to post
Share on other sites
Just to be clear FaceTime was activated with Chameleon rc5 755 + DSDT edit. After FaceTime is activated you can update chameleon to any version and it'll still work, but if you log off you won't be able to log back in. To log in for the first time 755 must be used.

So the bottomline is that in order to get FaceTime to work, you need to have the ethernet fix in your DSDT (by checking mine, I saw that the fix was in there, so the EthernetBuiltIn fix was redundant and unnecessary) and to use Chameleon build 775 to activate it. But still, the problem remains that one must figure out why later builds conflict with FaceTime (it's rather silly to keep a copy of build 775 around just in case you turn FaceTime off by mistake...)

Share this post


Link to post
Share on other sites

agreed, I would like to know what makes 775 work and 1078 or higher for the matter not to work.

 

So the bottomline is that in order to get FaceTime to work, you need to have the ethernet fix in your DSDT (by checking mine, I saw that the fix was in there, so the EthernetBuiltIn fix was redundant and unnecessary) and to use Chameleon build 775 to activate it. But still, the problem remains that one must figure out why later builds conflict with FaceTime (it's rather silly to keep a copy of build 775 around just in case you turn FaceTime off by mistake...)

Share this post


Link to post
Share on other sites
agreed, I would like to know what makes 775 work and 1078 or higher for the matter not to work.

 

I just installed the boot file from 775 and rebooted and now FaceTime finally works. Awesome

Share this post


Link to post
Share on other sites

its is so confusing can anyone explain in easy language please lol :wacko:).When i open IOreg too much stuff inside

 

its is so confusing can anyone explain in easy language please lol ;)).When i open IOreg too much stuff inside

 

I just installed the boot file from 775 and rebooted and now FaceTime finally works. Awesome

 

can u please explain in detail how u install boot file. I had open Chameleon utility but can't see how to install and what.

Share this post


Link to post
Share on other sites
its is so confusing can anyone explain in easy language please lol :wacko:).When i open IOreg too much stuff inside

 

its is so confusing can anyone explain in easy language please lol ;)).When i open IOreg too much stuff inside

 

 

 

can u please explain in detail how u install boot file. I had open Chameleon utility but can't see how to install and what.

 

 

use chameleon wizard and choose from folder.

 

http://www.kexts.com/view/1273-chameleon_wizard_2.0.html

 

the projectosx website link i posted earlier is a tutorial on how to add the ethernet controller. Use IORegistry Explorer to find your ethernet, its easier to search through registry with that. i thought he did a pretty good job explaining things read though that carefully.

Share this post


Link to post
Share on other sites
use chameleon wizard and choose from folder.

 

http://www.kexts.com/view/1273-chameleon_wizard_2.0.html

 

the projectosx website link i posted earlier is a tutorial on how to add the ethernet controller. Use IORegistry Explorer to find your ethernet, its easier to search through registry with that. i thought he did a pretty good job explaining things read though that carefully.

 

Oh this one is different wizard compared to chameleon rc5 755.

Share this post


Link to post
Share on other sites

It worked for me but when I tried to do it on my brothers comp it won't work...I tried to duplicate everything I tried before but not to sure why its giving errors..

Share this post


Link to post
Share on other sites

It worked for me as well, after that I went back to my normal Chameleon boot loader.

 

Thanks!

 

Just found out if you turn facetime off and then back on, you get the same error (unless your running build 755). So if you fix it, don't turn it off otherwise you need to go through the Chameleon change to 755 again to re-activate it.

Share this post


Link to post
Share on other sites

Thanks guys using 755 also fixed it for me. Feel sorry for the guys with real macs who still can't get this working ... NOT

Share this post


Link to post
Share on other sites

Mine still has the problem logging. I tried both 755 and 760 but still the same problem. I guess I will have to wait for another fix.

Share this post


Link to post
Share on other sites
Mine still has the problem logging. I tried both 755 and 760 but still the same problem. I guess I will have to wait for another fix.

 

You must do the ethernet fix. That is the only fix.

Share this post


Link to post
Share on other sites

Many thanks folks, 755 fixed it for me too :(

 

I already have my Ethernet added to the DSDT.aml so could access the App Store just fine and nothing on apple.com was working!

Share this post


Link to post
Share on other sites
I just installed the boot file from 775 and rebooted and now FaceTime finally works. Awesome

 

I tried installing this boot file. it did not work at all.

Share this post


Link to post
Share on other sites
I tried installing this boot file. it did not work at all.

 

Can you access the App Store and download something on there for free?

Share this post


Link to post
Share on other sites
You must do the ethernet fix. That is the only fix.

 

I did that already but still the same. I'm on wireless connection by the way.

 

thks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×