Jump to content
demonfox13x

Lion GM Facetime error

84 posts in this topic

Recommended Posts

ok, knowing what I don't know about how FaceTime authenticates. I tried just going to this web page in a browser "https://registration.ess.apple.com/WebObjects/VCRegistrationService.woa/wa/register" it was listed earlier in the posts as the page that FT tries to authenticate against. what I received was a notice saying that my machines "client certificate" was invalid making me think that maybe there is a key missing from the FaceSMC or something else in Hackintoshes that is not allowing for us to generate a valid client Cert for FaceTime.

 

just my observations.

 

HBP

Share this post


Link to post
Share on other sites
Advertisement

Is that a clean installation of Lion over clean SL?

 

Or upgrade of an existing SL to Lion? Well it seems MBP users have this issue on an upgrade.

 

You can move "com.apple.FaceTime.plist" and "com.apple.FaceTime.plist.lockfile" from "~/Library/Preferences/" to desktop [For safer method] and reboot the system and restart FaceTime and see if that helps? Coz when you restart FT fresh these Preferences files are created automatically.

 

Hope this fixes the issue. I would wait for the final release which is hours ahead of official launch and hope that fixes all these issues. As GM for developers and I don't think end-users should expect everything to work.

 

Cross your fingers for the final release and then you can give it a try. Cheers. :)

 

EDIT: Other Mac users have problem with this issue too. http://tinyurl.com/6bb4e5m

Share this post


Link to post
Share on other sites

I'm actually thinking FaceTime may check your App Store purchases, and If it doesn't see Lion as a purchase, it disallows FaceTime?

 

I hope not, but it would make sense. :( But based on other reading, it looks for now to just be switched off until Lion is released.

Share this post


Link to post
Share on other sites

I tried deleting the Facetime app (you have to do it from Terminal because it's a protected app). Then I reinstalled the Essentials.pkg which includes Facetime. Still no luck.

Share this post


Link to post
Share on other sites

just for the record, if I boot up in 10.6.8 Facetime works, in Lion DP4 no facetime, it does work on my MB and MBP with Lion GM, like others have said, waiting on release version to address these issues.

 

enjoy the weekend

Share this post


Link to post
Share on other sites
I'm actually thinking FaceTime may check your App Store purchases, and If it doesn't see Lion as a purchase, it disallows FaceTime?

 

I hope not, but it would make sense. :) But based on other reading, it looks for now to just be switched off until Lion is released.

 

Nope. I installed the Retail Lion today and FaceTime still doesn't log in. It says...

 

The server encountered an error processing registration. Please try again later.

 

App Store currently works and logs in fine.

 

I previously purchased FaceTime and it worked on 10.6.8.

 

Plenty of people with genuine Macs are being frustrated with the same situation over at the Apple forum.

Share this post


Link to post
Share on other sites

Same problem with facetime on my Sandy bridge hack with retail Lion. :rolleyes:

I found that few people say that Facetime works for them. Is that true?

 

I did an update keeping my old settings, maybe that created the problem?

Share this post


Link to post
Share on other sites
Same problem with facetime on my Sandy bridge hack with retail Lion. :)

I found that few people say that Facetime works for them. Is that true?

 

I did an update keeping my old settings, maybe that created the problem?

 

I sort out the problem... The culprit is the hosts file which is inside /private/etc.

 

You need to remove all the unwanted blocking. Probably most of the guys block this address gs.apple.com. If you see a "#" before the apple ip address uncomment it and the best way is to just have the default value.

 

 

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##
127.0.0.1	localhost
255.255.255.255	broadcasthost
::1			 localhost 
fe80::1%lo0	localhost

 

Just make sure you have this and that should fix the signing problem.

 

Hope this helps folks who run into this problem. FT trying to connect to the server but you must be blocking in the hosts file.

 

rest is next.

All the best guys.

Share this post


Link to post
Share on other sites
I sort out the problem... The culprit is the hosts file which is inside /private/etc.

 

You need to remove all the unwanted blocking. Probably most of the guys block this address gs.apple.com. If you see a "#" before the apple ip address uncomment it and the best way is to just have the default value.

 

 

I never had an active entry in hosts for gs.apple.com, just some local entries for other hosts. Still tried clearing it all out and flushing cache (dscacheutil). Still doesn't work here. :D

Share this post


Link to post
Share on other sites
installing chameleon build 755 or 760 worked for me.

 

http://www.kexts.com/view/1177-chameleon_rc5_r760.html

 

Well, what do you know... Your solution works! But for me, with a difference, build 760 didn't work. However, in my case, FaceTime Works with Chameleon RC5 build 755. Which begs the question: what's the difference between these two builds? Do newer builds work or not? In any case, thank you to stellarola for clearing up this one, I had tried all the solutions out there and nothing had worked.

Share this post


Link to post
Share on other sites

For the record, I was previously using Chameleon RC5 build 759. That build doesn't play nice with FaceTime either.

Share this post


Link to post
Share on other sites
Are you sure you tried build 755? Build 760 that stellarola suggested didn't work for me either. But build 755 did: http://www.kexts.com/view/1154-chameleon_2...755_+_lion.html

Thanks!! build 755 did worked, now i've fully function on my lion hackintosh, only without airdrop( I won't use it anyway since i am using a LAN CABLE instead of wifi. Anyway, thanks again for that!

Share this post


Link to post
Share on other sites
what are your boot options for 755

If you mean the settings inside com.apple.boot, this is what I use:

 

<key>Boot Graphics</key>

<string>Yes</string>

<key>Kernel Flags</key>

<string></string>

<key>UseKernelCache</key>

<string>No</string>

<key>GraphicsEnabler</key>

<string>No</string>

<key>Graphics Mode</key>

<string>1920x1080x32</string>

<key>Theme</key>

<string>Bullet</string>

<key>GUI</key>

<string>Yes</string>

<key>Boot Banner</key>

<string>No</string>

<key>Legacy Logo</key>

<string>Yes</string>

<key>EthernetBuiltIn</key>

<string>Yes</string>

 

Do you use an ATI 6870? If so, why don't you specify in your DSDT which framebuffer to use and thus get rid of the GraphicsEnabler=Yes flag? I use Duckweed as framebuffer (for that, your monitor must have a DVI connection, or an active DVI to VGA adaptor). I'm not sure about the EthernetBuiltIn flag, I don't think it matters in this case, but will test without it and let you know.

Share this post


Link to post
Share on other sites
i tried it with GE disabled and after getting into the system I still can't get in.

Well, that's a bummer, I think it's best to wait for some users to maybe try this solution and see if they have any success.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×