Jump to content
nmano

intel hd graphics cards success 10.8

183 posts in this topic

Recommended Posts

KEXTS LOADED: Geforce; NVDAGF100Hal; NVDAResman

KEXTS NOT LOADED: AppleIntelHDGraphics; AppleIntelHDGraphicsFB; Natit (but if i boot OS X in verbose mode i see: Natit: found ID 0046)

dont worry about intel hd kexts but natit have to lodded.

what about screen resoution?

Share this post


Link to post
Share on other sites
Advertisement

dont worry about intel hd kexts but natit have to lodded.

what about screen resoution?

Only 1024x768. Tried to boot with flag: "Graphics Mode"="1366x768x32" and "Graphics Mode="1366x768x32@60" but doesn't work.

Share this post


Link to post
Share on other sites

Only 1024x768. Tried to boot with flag: "Graphics Mode"="1366x768x32" and "Graphics Mode="1366x768x32@60" but doesn't work.

I have HM55 SONY.I thing asus/sony they are blocked your resolution.

I was ERase sony windows 7 and install retail windows( only microsoft os ) so boot with usb harddrive fomats internal.this might be help u.

Share this post


Link to post
Share on other sites

So i have an HM55 from HP. And i haven't the original Windows 7 with HP. I installed, after Lion installation, Windows 7 Ultimate. With the Lion Installation, i formatted all the HDD and then, i created two partition: one for Lion and another for Windows 7 Ultimate. I don'tunderstand how HM55 blocks my resolution. :huh: :huh: :huh:

Share this post


Link to post
Share on other sites

maybe only works with MOUNTAIN lion???

if i understood it right, manor got the sucess with mountain lion, so maybe it only works with mountain lion.

Share this post


Link to post
Share on other sites

Manor got the succes with snw lion and mountain. He have a magic pc!! :sorcerer:

 

He had, where?? I have read the thread until manor posted it again and only found posts from him with 10.8

Share this post


Link to post
Share on other sites

since nobody else here has 10.8, maybe manor can try his kexts with 10.6/10.7, so we can see if its our computer´s fault or snow leopard´s/lion´s

Share this post


Link to post
Share on other sites

10.7 supported kexts

 

10.6 supported kexts

 

10.8 supported kexts

10.7.rar

10.6.rar

10.8.rar

Share this post


Link to post
Share on other sites

10.7 supported kexts

 

10.6 supported kexts

 

10.8 supported kexts

I`ll try these later`(its late in germany)...what have you changed/added to get this work under 10.6/10.7 manor?? Have you tested it??

Share this post


Link to post
Share on other sites

10.7 supported kexts

 

10.6 supported kexts

 

10.8 supported kexts

 

I tried 10.7 Kexts but not working: only a bit of acceleration. I noticed you have the resolution (1366x768x32) in chameleon boot loader. I have instead only the following resolutions: 1024x768x(32,16,8); 800x600x(32,16,8) and 640x480x(32,16,8). Maybe you used an EFI String or something that chameleon reads and then you have the resolution 1366x768x32!

Share this post


Link to post
Share on other sites

I tried 10.7 Kexts but not working: only a bit of acceleration. I noticed you have the resolution (1366x768x32) in chameleon boot loader. I have instead only the following resolutions: 1024x768x(32,16,8); 800x600x(32,16,8) and 640x480x(32,16,8). Maybe you used an EFI String or something that chameleon reads and then you have the resolution 1366x768x32!

i can´t test it since im not at home, but you have options for resolutions???

Thats a huge sucess!

You have to add it in the chameleon bootloader...here is for example an tutorial how to change resolutions

http://www.osx86.net...der-basics.html

look near here:

<key>Graphics Mode</key>

<string>1680x1050x32</string>

Share this post


Link to post
Share on other sites

If you go, in Chameleon Bootoloader, to "Video Info" you can see all the resolution supported by your graphic card. I have from 1024x768 to 800x600. Instead, manor, have also the resolution 1366x768. You can view it here: http://www.insanelym...attach_id=96915

It's from manor's topic "fixed no kext load issue".

Share this post


Link to post
Share on other sites

Manor has the 1366x768 in his video BIOS VESA table, thats why he get's native resolution. It doesn't involve any of the 10.6/7/8 kexts.

 

If you don't have the native resolution of your panel in your VESA table, there is currently no way to get native resolution. And there probably never will be...

Share this post


Link to post
Share on other sites

Manor has the 1366x768 in his video BIOS VESA table, thats why he get's native resolution. It doesn't involve any of the 10.6/7/8 kexts.

 

If you don't have the native resolution of your panel in your VESA table, there is currently no way to get native resolution. And there probably never will be...

Yes, but why has he got the native resolution in the VESA table and we no? Maybe an EFI String, a module, a patch for Chameleon because it detect the native resolution not the Mac.

However with the new kexts installation i have done a little update:

Now in "PCI Cards" tab i can see this:

 

Intel HD Graphics:

 

Name: NVDA,Display-B

Type: Display Controller

Driver Installed: Yes

MSI: No

Bus: PCI

Slot: Built In

Vendor ID: 0x8086

Device ID: 0x0046

Subsystem Vendor ID: 0x103c

Subsystem ID: 0x143a

ROM Revision: 0x00

Revision ID: 0x0002

 

Anyway only 1024x768... @Manor: Suggestions?

 

EDIT:

NEW UPDATE!

Chameleon build 1900 (not yet released):

Go HERE and see! Our Intel ID is now supported by Chameleon!

Share this post


Link to post
Share on other sites

EDIT:

NEW UPDATE!

Chameleon build 1900 (not yet released):

Go HERE and see! Our Intel ID is now supported by Chameleon!

 

i tried building chameleon from svn... GraphicsEnabler now seems to do something and with that i can load original 10.7.3 Intel HD kexts but the screen is completely messed up! 1366x768 graphics mode doesn't work at all, with 1280x800 i can see something but there is plenty of horizontal lines, with 1024x768 the screen is replicated 4 times and everything is scrambled.

Share this post


Link to post
Share on other sites

i tried building chameleon from svn... GraphicsEnabler now seems to do something and with that i can load original 10.7.3 Intel HD kexts but the screen is completely messed up! 1366x768 graphics mode doesn't work at all, with 1280x800 i can see something but there is plenty of horizontal lines, with 1024x768 the screen is replicated 4 times and everything is scrambled.

 

 

would you mind sharing your bootfile?

Share this post


Link to post
Share on other sites

 

From a quick inspection - the only difference from trunk version is that ID for IntelHDGraphics is added whose only benefit is to show right name of the card when bootloader is loaded. How did you draw any conclusion that something useful is done for intelhd?

 

oki

Share this post


Link to post
Share on other sites

From a quick inspection - the only difference from trunk version is that ID for IntelHDGraphics is added whose only benefit is to show right name of the card when bootloader is loaded. How did you draw any conclusion that something useful is done for intelhd?

 

oki

 

i never said that, i'm not a developer, i don't know what it's changed... but i can see that now intelgraphicshd.kext and intelgraphicshdfb.kext load without kp, so i think that something is happening.........

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×