Jump to content
nmano

intel hd graphics cards success 10.8

183 posts in this topic

Recommended Posts

just add your device ids

apple intel hd graphics

<string>0x03000000&amp;0xff000000 0x04000000&amp;0xff000000</string>

<key>IOPCIPrimaryMatch</key>

<string>0x00448086 0x00468086 0x3b448086 0x3b468086 0x2c628086 ox2d018086 0x2d108086 0x2d118086 0x2d128086 0x2d138086</string>

<key>IOProbeScore</key>

.....................

.AppleIntelHDGraphicsFB

<string>0x03000000&amp;0xff000000</string>

<key>IOPCIPrimaryMatch</key>

<string>0x3b468086 0x3b428086 0x468086 0x428086 0x3b448086 0x3b4c8086 0x24488086 0x3b098086 0x3b328086</string>

<key>IOProbeScore</key>

...........................

AppleIntelIntegratedFramebuffer

<key>IOPCIClassMatch</key>

<string>0x03000000&0xff000000</string>

<key>IOPCIPrimaryMatch</key>

<string>0x25828086 0x25928086 0x27728086 0x27A28086</string>

................

after add ids load your kext in Extensions

finally I make efi string with osx86 tool.

add your device pro your hex.

thats it.

thanks guys all your hard work enjoy.

 

my kexts file http://hotfile.com/dl/122338163/1240044/7final.rar.html

 

its work snowleopard with dp4 kexts.

 

....................................

 

------------------------------

if your system chameleon boot loder doesnot boot resolution 1366x768

 

you can enable this way

 

first boot with Iboot1.7 this can 1366x768 then restore another harddrive

I install snowleopard and lion restore meathed.use disk utillity restore your working system to other volume.

 

now you can use chameleon

 

then add uuid for current volume. .set extra folder .finally add efi string. 100%working

 

I use Applesmbiosefi.kext for system memory 4gb dedect but only 32bit working. I overwrite some mem info.

 

 

Any reason for you to use a gfx string based on an nvdia one on your com.apple.Boot.plist instead of a intel gma efi gfx string?

 

Thanks

Share this post


Link to post
Share on other sites
Advertisement

I man, i have try on snow (for now) i have this

 Modello Chipset:	IntelHDGraphics
  Tipo:	GPU
  Bus:	Integrato
  VRAM (totale):	768 MB
  Fornitore:	Intel (0x8086)
  ID dispositivo:	0x0046
  ID revisione:	0x0012
  Revisione ROM:	IntelHDGraphics OpenGL Engine [EFI]
  Monitor:
SwitchResX4 - Unknown Monitor:
  Risoluzione:	1024 x 768
  Profondità pixel:	Colore 32 bit (ARGB8888)
  Monitor principale:	Sì
  Mirror:	Spento
  Online:	Sì
Mostra connettore:

 

But no qe/ci and no correct resolution, When I get time I will try with lion

Share this post


Link to post
Share on other sites
I man, i have try on snow (for now) i have this

 Modello Chipset:	IntelHDGraphics
Tipo:	GPU
Bus:	Integrato
VRAM (totale):	768 MB
Fornitore:	Intel (0x8086)
ID dispositivo:	0x0046
ID revisione:	0x0012
Revisione ROM:	IntelHDGraphics OpenGL Engine [EFI]
Monitor:
 SwitchResX4 - Unknown Monitor:
Risoluzione:	1024 x 768
Profondità pixel:	Colore 32 bit (ARGB8888)
Monitor principale:	Sì
Mirror:	Spento
Online:	Sì
 Mostra connettore:

 

But no qe/ci and no correct resolution, When I get time I will try with lion

 

same result in LION DP4

have the kexts of intelHD been loaded?

Share this post


Link to post
Share on other sites

hi have to add com appleboot.plist

 

Graphics Mode 1366x768x32

 

 

replace ori Displayproudtid remove SwitchResX4 - Unknown Monitor

Share this post


Link to post
Share on other sites
same result in LION DP4

have the kexts of intelHD been loaded?

I looked in kextstat, but I have not found intelHD loaded

I can see in any other way?

 

p.s. i'm in snow, not in lion

Share this post


Link to post
Share on other sites
I looked in kextstat, but I have not found intelHD loaded

I can see in any other way?

 

p.s. i'm in snow, not in lion

 

you can enable add device ids but thats not impotant for efi string

Share this post


Link to post
Share on other sites

I want to ask a question

how can i edit the kext? bootthink or Chameleon?

Which OS should i choose to edit the kext? Windows or MAC?

Share this post


Link to post
Share on other sites
I want to ask a question

how can i edit the kext? bootthink or Chameleon?

Which OS should i choose to edit the kext? Windows or MAC?

 

you dont need bootthink only Chameleon load everything.

 

find ids.then edit mac osx.

Share this post


Link to post
Share on other sites
you dont need bootthink only Chameleon load everything.

 

find ids.then edit mac osx.

 

***。plist,is this the files i should edit,

Share this post


Link to post
Share on other sites

I just installed Lion GM and have all resolutions available that my monitor can handle :blink:

 

I did not edit any efi string! Just a clean install, removed the AppleIntelHDGraphics.kext and it worked.

 

I only had to remove the AppleIntelHDGraphics.kext, otherwise it would hang on the Apple logo

with the mouse enabled that i can move....Is there a way to see whats causing this 'freeze', I do boot with -v?

 

With kexstat i only see one kext loaded...AppleIntelSNBGraphicsFB.

 

If anyone need any files from me just ask.

 

Hardware:

P8H67-M Pro

Intel i3 HD2000

Share this post


Link to post
Share on other sites
I just installed Lion GM and have all resolutions available that my monitor can handle ;)

 

I did not edit any efi string! Just a clean install, removed the AppleIntelHDGraphics.kext and it worked.

 

I only had to remove the AppleIntelHDGraphics.kext, otherwise it would hang on the Apple logo

with the mouse enabled that i can move....Is there a way to see whats causing this 'freeze', I do boot with -v?

 

With kexstat i only see one kext loaded...AppleIntelSNBGraphicsFB.

 

If anyone need any files from me just ask.

 

Hardware:

P8H67-M Pro

Intel i3 HD2000

 

Hi,

it sounds almost to good, I have played with GM one day, with no result only 1024x768 on my intel HD 3000 IG, so I gave up.

I would really like to see screenshots from ATM.

Share this post


Link to post
Share on other sites
Here are some screenshots:

 

post-272713-1309909851_thumb.png

post-272713-1309909858_thumb.png

 

I just found out that it only works with the following smbios.plist

http://dl.dropbox.com/u/2640640/smbios.plist

 

I tried to install an iMac12.2 plist but then my resolutions were not correctly detected.

 

it really looks very interesting, but unfortunately I couldn't emulate it on my setup.

 

I think a lot of people would be very interested in full resolution on intel IG, so could you please give us more info.

Was it build 11A511? your install process, if you made something during installation what could be important for IG etc.

Because after I delete that kext I got only random reboot. After I switch to PCI GC I could boot without a problem, but not with IG.

Thank for any information on this.

Share this post


Link to post
Share on other sites
it really looks very interesting, but unfortunately I couldn't emulate it on my setup.

 

I think a lot of people would be very interested in full resolution on intel IG, so could you please give us more info.

Was it build 11A511? your install process, if you made something during installation what could be important for IG etc.

Because after I delete that kext I got only random reboot. After I switch to PCI GC I could boot without a problem, but not with IG.

Thank for any information on this.

 

I followed this tutorial for the Lion (11A511) install.

http://www.insanelymac.com/forum/index.php?showtopic=256729

 

Note: In the installation menu of Lion my TV resolution was already native (1920x1080) !

 

After the installation i could not boot to the desktop because it will hang on the apple logo with my mouse enabled.

So i restarted the computer and booted into the Lion installer again and opened the Terminal app.

Now i removed all the AppleIntelHDGraphics kexts except:

AppleIntelIntegratedFramebuffer.kext

AppleIntelSNBGraphicsFB.kext

AppleIntelSNBVA.bundle

 

Then i could boot into Lion with no problems and with the resolutions enabled.

 

Edit: Just found out that VGA is not working for me...it won't even boot into chameleon but just freezes...DVI/HDMI are working perfect.

 

 

Hi, Would this work on Emachine E732 i3 370 with Intel HD Graphics, thanks.

 

I don't know because that i3 has a different architecture and graphicscard, but you could give it a try.

Share this post


Link to post
Share on other sites
I followed this tutorial for the Lion (11A511) install.

http://www.insanelymac.com/forum/index.php?showtopic=256729

 

Note: In the installation menu of Lion my TV resolution was already native (1920x1080) !

 

After the installation i could not boot to the desktop because it will hang on the apple logo with my mouse enabled.

So i restarted the computer and booted into the Lion installer again and opened the Terminal app.

Now i removed all the AppleIntelHDGraphics kexts except:

AppleIntelIntegratedFramebuffer.kext

AppleIntelSNBGraphicsFB.kext

AppleIntelSNBVA.bundle

 

Then i could boot into Lion with no problems and with the resolutions enabled.

 

Edit: Just found out that VGA is not working for me...it won't even boot into chameleon but just freezes...DVI/HDMI are working perfect.

 

ok, thanks for the info, I will do it the same way,like you did

Share this post


Link to post
Share on other sites

Hello, I have a problem. I have been following this thread for some time. I Just cannot get this to work on my laptop. I have a Samsung NP-QX410-J01 laptop. It has an Intel Core i5-460M processor which so happens to have an Intel HD Graphics chip (5700 series I think) on it. The laptop also has an nVidia Geforce 310m GPU also. I tried the methods that are on this thread, but I cannot seem to get my system to load after I restart. It does not load in normal and safe boot.

 

I changed the device id's and added the efi to the boot.plist. nothing works. If anyone can help me out, that would be great. I am using a vanilla install of Snow Leopard 10.6.7 (installed using retail dvd 10.6.3 then ran combo update to 10.6.7) My device id's for the Intel HD GPU is 8086:0046 and the nVidia Geforce 310m GPU is 10de:0a70. If anyone can help me with step by step direction, I will love them forever. Thank you very much in advance.

Share this post


Link to post
Share on other sites
Hello, I have a problem. I have been following this thread for some time. I Just cannot get this to work on my laptop. I have a Samsung NP-QX410-J01 laptop. It has an Intel Core i5-460M processor which so happens to have an Intel HD Graphics chip (5700 series I think) on it. The laptop also has an nVidia Geforce 310m GPU also. I tried the methods that are on this thread, but I cannot seem to get my system to load after I restart. It does not load in normal and safe boot.

 

I changed the device id's and added the efi to the boot.plist. nothing works. If anyone can help me out, that would be great. I am using a vanilla install of Snow Leopard 10.6.7 (installed using retail dvd 10.6.3 then ran combo update to 10.6.7) My device id's for the Intel HD GPU is 8086:0046 and the nVidia Geforce 310m GPU is 10de:0a70. If anyone can help me with step by step direction, I will love them forever. Thank you very much in advance.

 

my cpu also 460m i thing 3400 series..

Share this post


Link to post
Share on other sites

I could install Lion with this guide: http://www.insanelymac.com/forum/index.php?showtopic=260594

for those without an external monitor.

(Delete all Graphics Kexts. Delete all Intel GMA 950 Kexts, Intel GMA X3100 kexts, Intel HD Graphics Kexts, ATI Graphics Kexts, NVidia Graphics Kexts, and GeForce Kexts.) :D BEFORE INSTALL LION, FOR NOT TO HAVE A BLACK SCREEN :D (IS ONLY FOR THOSE WHO DO NOT HAVE AN EXTERNAL MONITOR)

THIS IS ONLY IF YOU WANT TRY LION FOR INTEL GRAPHICS HD WHILE THERE A SOLUTION

 

sorry I'm not very good with English :)

 

 

My Notebook:

 

HP Pavilion dv4-2165dx

Intel i3 Arrandele

Intel HD Graphics / GMA 5700

4GB Ram

500 GB HD

Untitled_2.tiff

Untitled_3.tiff

Untitled_4.tiff

Untitled_5.tiff

Untitled_6.tiff

Untitled.tiff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×