Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
buoo

RevoBoot

284 posts in this topic

Recommended Posts

In /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist I had this:

			<key>Hibernate Mode</key>
		 <integer>1</integer>

also even before re-checking hibernatemode.

BTW, now also in /usr/bin/pmset -g log I've hibernatemode=1

 * Domain: hibernatestats
 - Message: Hibernate Statistics
 - Time: 14/06/11 13.59.12 GMT+02.00 
 - Signature: hibernatemode=1
 - UUID: D343A216-4A33-40E7-BD75-173B6C66251F

 * Domain: sleep
 - Message: Sleep: Platform Failure - AC
 - Time: 14/06/11 14.00.40 GMT+02.00 
 - Signature: Platform Failure
 - UUID: C78250ED-FA94-4D30-960D-AC62FE25A4FB
 - Result: Failure

but image-sleep is not picked up at boot.

 

Maybe some values in BIOS...

What's this?

110614121002.jpg

Share this post


Link to post
Share on other sites

I'd say it's a sleep issue you need to fix first (with regular soft sleep as well):

 

 * Domain: sleep
- Message: Sleep: Success - AC - Software Sleep
- Time: 30/04/2011 06:56:02 CEST 
- Signature: Success
- UUID: 299B8748-6E56-4BD8-B3E9-2B5AD208C0AB
- Result: Success
- Sleep count : 1

* Domain: wake
- Message: Wake: Success - AC
- Time: 30/04/2011 06:56:02 CEST 
- Signature: Success
- UUID: 299B8748-6E56-4BD8-B3E9-2B5AD208C0AB
- Result: Success

 

Got to go now, be back in the evening.

Share this post


Link to post
Share on other sites
Your PMLog shows "Platform Failure".

This only happen when hibernatemode is set to 1.

If is set to 0 this is what I get:

[color="#0000FF"]/usr/bin/pmset -g log[/color]:

 Descrizione:    Resoconti di gestione energia
 Dimensione:    2 KB
 Ultima modifica:    14/06/11 14.44
 Contenuto recente:    Power Management ASL logs.
-> All messages with "com.apple.message.domain" key set to "com.apple.powermanagement".)

* Domain: sleep
- Message: Sleep: Success - AC - Software Sleep
- Time: 14/06/11 14.42.41 GMT+02.00 
[b] - Signature: Success[/b]
- UUID: DC618EF6-624C-4407-A268-15394F03930C
- Result: Success
- Sleep count : 2

* Domain: wake
- Message: Wake: Success - AC - EHC1
- Time: 14/06/11 14.42.41 GMT+02.00 
[b] - Signature: Success[/b]
- UUID: DC618EF6-624C-4407-A268-15394F03930C
- Result: Success

* Domain: hibernatestats
- Message: Hibernate Statistics
- Time: 14/06/11 14.42.41 GMT+02.00 
[b] - Signature: hibernatemode=0[/b]
- UUID: DC618EF6-624C-4407-A268-15394F03930C

* Domain: sleep
- Message: Sleep: Success - AC - Software Sleep
- Time: 14/06/11 14.43.20 GMT+02.00 
[b] - Signature: Success[/b]
- UUID: 1D255B18-6C9C-4019-898C-4B70C820462C
- Result: Success
- Sleep count : 3

* Domain: wake
- Message: Wake: Success - AC - EHC1
- Time: 14/06/11 14.43.20 GMT+02.00 
[b] - Signature: Success[/b]
- UUID: 1D255B18-6C9C-4019-898C-4B70C820462C
- Result: Success

* Domain: hibernatestats
- Message: Hibernate Statistics
- Time: 14/06/11 14.43.20 GMT+02.00 
[b] - Signature: hibernatemode=0[/b]
- UUID: 1D255B18-6C9C-4019-898C-4B70C820462C

* Domain: sleep
- Message: Sleep: Success - AC - Software Sleep
- Time: 14/06/11 14.43.50 GMT+02.00 
[b] - Signature: Success[/b]
- UUID: 6409E721-12FB-4B83-9526-E9128AA6AD9A
- Result: Success
- Sleep count : 4

* Domain: wake
- Message: Wake: Success - AC - EHC1
- Time: 14/06/11 14.43.50 GMT+02.00 
[b] - Signature: Success[/b]
- UUID: FEA13F0B-B574-477B-AAFE-BB39C433F036
- Result: Success

* Domain: hibernatestats
- Message: Hibernate Statistics
- Time: 14/06/11 14.43.50 GMT+02.00 
[b] - Signature: hibernatemode=0[/b]
- UUID: FEA13F0B-B574-477B-AAFE-BB39C433F036

Share this post


Link to post
Share on other sites

How cute :)

 

Well, I'm a bit lost on this issue. The actual resume code seems to work fine here. Your issue lies in the generation of the sleepimage itself.

 

Does your PC shutdown automatically after the image is written to disk?

 

It's a blind shot, but have you tried booting in 64bit and then hibernate + wake?

Share this post


Link to post
Share on other sites

Yep, PC shutdown automatically.

I'll try to boot in 64-bit.

I'll be back in 2 minutes...

 

EDIT

Hibernation doesn't work also in 64-bit mode.

Get the same error regarding image-sleep.

Really don't know what to do...

Share this post


Link to post
Share on other sites
Anybody else testing hibernation?

I had a go earlier. Your version of RevoBoot failed to load the sleep image, though Chameleon booted it just fine.

The debug boot process reported bootFile empty!.

 

I don't have anything else to add at the moment as I have a problem which is for some reason after running a couple of tests I ended up with a damaged system disk (Haven't had one of those for a while). I see the messages:

Invalid leaf record count

Keys out of order

 

I've tried booting from the 10.6 retail DVD and running fsck but no joy. I'm currently backing up and going to rebuild my drive. oh what fun.. :D

Share this post


Link to post
Share on other sites
I had a go earlier. Your version of RevoBoot failed to load the sleep image, though Chameleon booted it just fine.

The debug boot process reported bootFile empty!.

Ouch, let's hope your HDD is not toast!

 

This error is not part of my patch, it's a fail-safe for when something really bad happend. From the RevoBoot sources:

 

The bootFile normally points to 'mach_kernel' but it will be empty when a

pre-linked kernel was processed, and that is why we check the length here.

...

_BOOT_DEBUG_ELSE_DUMP("bootFile empty!\n"); // Should not happen, but helped me once already.

Share this post


Link to post
Share on other sites
Interesting to see this posted here as a new topic… I agree with flAked that the text in the OP should be emphasised as being quoted from the RevoBoot wiki.

 

Excuse me blackosx

 

I thought it was enough to add the link where I took the Revoboot's news.

I'll explicitly write it.

Share this post


Link to post
Share on other sites

Oh man, I just implemented the graphical preview for hibernation wake and now I get the incorrect image header as well.

 

Don't ask me what I changed since yesterday... *g

 

Just tested it under Lion DP4 and it seems that SafeSleep (hibernatemode 1) isn't supported any more.

Share this post


Link to post
Share on other sites
Ouch, let's hope your HDD is not toast!

Thanks. No I didn't lose anything other than that particular OS X installation. Previous experiences have taught me the valuable lesson of regular backups. :rolleyes:

 

This error is not part of my patch, it's a fail-safe for when something really bad happend. From the RevoBoot sources:

Thanks for looking in to it for me. I guess something bad did happen though I don't know what but it doesn't matter now. :P

I didn't have enough time to get everything fully up and running as I like, but when I do I'll run some more hibernation tests for you.

 

Excuse me blackosx

 

I thought it was enough to add the link where I took the Revoboot's news.

I'll explicitly write it.

Hi buoo - It's no problem :)

I'd just imagined the text block wrapped in '

's. I see what you have done now and that's fine.

Thanks.

Share this post


Link to post
Share on other sites

:blink:

Hi Black osx..sorry again ...help me please for courtesy ...i ve a dual monitor...but one monitor not work ....i need a plist for my nvidia 9800gtx +...can you a generate for me..?

Thank 's and sorry for my bad english

Share this post


Link to post
Share on other sites

magnifico10 - are your dual monitors correctly configured when using Chameleon's graphics enabler?

If yes, then you can take the EFI info from ioreg when booted with Chameleon and use it as static EFI data for RevoBoot.

Share this post


Link to post
Share on other sites

There will be a new version of RevoBoot that supports full automatic injections for power management and sleep in the next week or so.

 

That means everybody can profit without ever touching DSDT/SSDT's!

Share this post


Link to post
Share on other sites
Sto per andare a cena (è il compleanno della mia ragazza) e sono già briaco.

Sabato in giornata torno alla base e ci sentiamo.

 

happy birthday !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×