Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Ed24135

DSDT for Dell Dimension 3000

14 posts in this topic

Recommended Posts

Hi all,

 

I'm having some small issues(sleep and volume control) with my Dell Dimension 3000 that i read could be fixed by DSDT patching. Anyone know the proper way to patch it for my system?

 

Thanks in Advance!

Share this post


Link to post
Share on other sites

dsdt_Ed24135.zip

use ForceHPET=Yes

 

remove EvOreboot and NullCPUPowerManagement

 

restart fix and NativePM use Chameleon RC5

http://www.insanelymac.com/forum/index.php...t&p=1526378

Add in boot.plist

<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

 

try it

 

P4 suport SpeedStep?

Share this post


Link to post
Share on other sites

Tried it and I got Unsupported CPU Kernel Panic.

Not sure if my P4 supports SpeedStep but i am using Chameleon RC5

Using ForceHPET=Yes as boot flag gets AppleHPET and AppleLPC loaded. Or was that in the DSDT you sent me?

Share this post


Link to post
Share on other sites

Use NUll and SleepEnabler

 

remove EvOreboot

 

test restart and shutdown

Share this post


Link to post
Share on other sites

select "Start up automatically after a power failure" in "Energy Saver"

 

if it doesn't work

I do not know a solution to this

I hope someone can help you

01a.png

Share this post


Link to post
Share on other sites
Tried it and again, Nothing. Oh well, maybe a solution will come up soon.

send me a kextstat

run on terminal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×