Jump to content
janek202

Chameleon Wizard - Utility for Chameleon.

691 posts in this topic

Recommended Posts

Advertisement

Compile/Export tab:

Compile/Decompile: It compiles (DSL => AML), and decompiles (AML => DSL) DSDT. AML is compiled version that Chameleon uses. DSL is decompiled version for edition.

 

Export: Exports DSDT from your BIOS/UEFI, so you can edit it.

 

Patch tab:

Apply patch: It allows to patch original, unmodified DSDT with patch file. The patch file contains all modifications that are useful. It must be generated with the same motherboard model and bios version. It uses standard patch command.

 

Create patch: It helps to generate patch file. You need two DSDT files. The first one, that is unmodified, original, and one that has all the modifications.

It will calculate all the differences between them and save it to patch file. It uses standard diff command.

 

IASL tab:

You can update IASL to the latest version. (That's the tool that compiles and decompiles DSDT).

Also there are some advanced options, that you don't have to worry about.

 

Quick Patch tab:

It will extract DSDT from your motherboard, patch it using DSDT patch file, compile it and put the DSDT.AML file in /Extra directory.

 

 

Why not simply put somebody else's DSDT?

Because there are many things that might affect DSDT tables like: number of RAM modules, BIOS settings, BIOS version, CPU type, and more.

The best way is to save your dsdt and modify it.

I will never recommend using somebody's DSDT. It might affect system performance and stability.

Share this post


Link to post
Share on other sites

Um, how do I remove file associations? So that the .plist files won't have a Chameleon Wizard icon?

 

1. Manually edit/remove the com.apple.LaunchServices.plist in the ~/Library/Preferences directory.

2. Select the Open With context menu by right clicking on the file, point to Other in the following subcontext menu, then choose an application to open the file ensuring to tick the Always Open With option at the bottom of the dialog window.

Share this post


Link to post
Share on other sites

Okay, after MUCH Googling and try and error, this is what I've come up with for smbios and SMC Version. I hate to say it but the smbios data I got from using Champlist and some Google searches. This is what I am using (minus serial number):

 

<!--?xml version="1.0" encoding="UTF-8"?-->

 

<plist version="1.0">

<dict>

<key>SMbiosvendor</key>

<string>Apple Inc.</string>

<key>SMbiosversion</key>

<string>MBA31.88Z.0061.B01.1011181342</string>

<key>SMboardmanufacter</key>

<string>Apple Inc.</string>

<key>SMboardproduct</key>

<string>Mac-942452F5819B1C1B</string>

<key>SMfamily</key>

<string>MacBookAir</string>

<key>SMmanufacter</key>

<string>Apple Inc.</string>

<key>SMproductname</key>

<string>MacBookAir3,1</string>

<key>SMserial</key>

<string>Search for Serial</string>

<key>SMsystemversion</key>

<string>1.0</string>

</dict>

</plist>

 

The harder one was the correct SMC Version key for FakeSMC. All this base64 and hex stuff made me crazy. Using online tools, I never got the correct code but after studying Prasys "Editing FakeSMC" I just winged it and following his instructions and came up with the following:

 

<!--?xml version="1.0" encoding="UTF-8"?-->

 

<plist version="1.0">

<dict>

<key>CFBundleDevelopmentRegion</key>

<string>English</string>

<key>CFBundleExecutable</key>

<string>fakesmc</string>

<key>CFBundleIdentifier</key>

<string>org.netkas.fakesmc</string>

<key>CFBundleInfoDictionaryVersion</key>

<string>6.0</string>

<key>CFBundleName</key>

<string>fakesmc</string>

<key>CFBundlePackageType</key>

<string>KEXT</string>

<key>CFBundleShortVersionString</key>

<string>2.5</string>

<key>CFBundleSignature</key>

<string>????</string>

<key>CFBundleVersion</key>

<string>2</string>

<key>IOKitPersonalities</key>

<dict>

<key>FakeSMC</key>

<dict>

<key>CFBundleIdentifier</key>

<string>org.netkas.fakesmc</string>

<key>IOClass</key>

<string>FakeSMC</string>

<key>IOMatchCategory</key>

<string>IOACPIPlatformDevice</string>

<key>IOProviderClass</key>

<string>AppleACPIPlatformExpert</string>

<key>IOResourceMatch</key>

<string>ACPI</string>

<key>SMCKeys</key>

<dict>

<key>MSDS</key>

<data></data>

<key>BEMB</key>

<data></data>

<key>$Num</key>

<data>AQ==</data>

<key>ACID</key>

<data>AAAAAAAA</data>

<key>BALG</key>

<data>AAAAAAAA</data>

<key>LSOF</key>

<data>AQ==</data>

<key>LSSB</key>

<data>AQE=</data>

<key>MSSD</key>

<data>AA==</data>

<key>MSSP</key>

<data>AA==</data>

<key>NATJ</key>

<data>AA==</data>

<key>NVPR</key>

<data>AAAAAAAA</data>

<key>OSK0</key>

<string>ourhardworkbythesewordsguardedpl</string>

<key>OSK1</key>

<string>easedontsteal©AppleComputerInc</string>

<key>REV </key>

<data>AWcPAAAE</data>

</dict>

<key>debug</key>

<false>

<key>smc-compatible</key>

<string>smc-mpc</string>

<key>tjmax</key>

<integer>100</integer>

</false></dict>

</dict>

<key>OSBundleLibraries</key>

<dict>

<key>com.apple.iokit.IOACPIFamily</key>

<string>1.0.0d1</string>

<key>com.apple.kpi.iokit</key>

<string>7.0</string>

<key>com.apple.kpi.libkern</key>

<string>8.0.0d0</string>

<key>com.apple.kpi.unsupported</key>

<string>8.0.0b1</string>

</dict>

<key>OSBundleRequired</key>

<string>Root</string>

</dict>

</plist>

 

The important thing to look for here is the <REV > key which turns out to be <AWcPAAAE> which corresponds to 1.67f4 which is what I consistently found in Google searches for a MacBookAir3,1. The RAW key when using Property List Editor is <01670f00 0004>. Also be sure to change the <smc-compatible> key to <smc-mpc>.

 

Hope that helps someone else.

Share this post


Link to post
Share on other sites

1. Manually edit/remove the com.apple.LaunchServices.plist in the ~/Library/Preferences directory.

2. Select the Open With context menu by right clicking on the file, point to Other in the following subcontext menu, then choose an application to open the file ensuring to tick the Always Open With option at the bottom of the dialog window.

 

Yes, but by default it shouldn't change file associations without asking first. :)

Share this post


Link to post
Share on other sites

Application doesn't change it.

To make opening files possible by dragging files on icon I had to declare what types It can open, by editing info.plist file, to tell OS X how It should react.

Your system changed file associations itself. My application doesn't have any code that changes file associations.

 

 

Also If you created *.patch files please share it with others. That's the only way to make most of DSDT features useful.

Share this post


Link to post
Share on other sites

@janek202

 

great work with all your softs,just a request-please mention the version numbers for successive builds or mention the version of the latest build in the first post.

 

keep up the good work.

Thanks

Share this post


Link to post
Share on other sites

hello janek

 

some problems with the portuguese translation pt_pt i dont know why ?

 

some screenshots

 

Captura de ecrã 2012-02-27, às 21.31.30.png

 

Captura de ecrã 2012-02-27, às 21.32.01.png

 

Captura de ecrã 2012-02-27, às 21.32.28.png

 

u see some things is translated and other no

 

i translated every thing

 

thanks

Share this post


Link to post
Share on other sites

Hi.

Everytime i save the settings in org.chameleon.boot.plist, the file is deleted!

Any trick? Or it is a bug? Chameleon wizard 4.01.

Share this post


Link to post
Share on other sites

RIght now i've Chameleon 2.1 r1819, when i start Chameleon Wizard it shows Dropbox version r1820 (builbot is down ATM)i select Install from Dropbox and it says that it's successful but the version showed at bottom remains the same. I've restarted the system, restarted Chameleon Wizard but it shows the same. ¿What i'm doing wrong? I'm Using Chameleon Wizard 4.0.1

Share this post


Link to post
Share on other sites

Hi Janek,

 

I have seen quite a few people complaining about "boot0: error" when installing Chameleon to HDDs with 4 K sectors

 

http://forge.voodooprojects.org/p/chameleon/issues/129/

 

Looks like dd can't write boot1h to a mounted partition, but it will work if you unmount the partition before running dd and use /dev/diskXsY instead of /dev/rdiskXsY

 

http://forge.voodooprojects.org/p/chameleon/issues/129/#ic1657

 

What about including an option in Chameleon Wizard which unmounts the target partition (if it's not the current root partition, of course) before running dd command?

 

diskutil unmount diskXsY
dd if=boot1h of=/dev/diskXsY
diskutil mount diskXsY

 

Regards.

Share this post


Link to post
Share on other sites

Hi, I posted this in another forum also, but I think it's worth to post here also.

 

I've been struggling lately to configure my Chameleon, to be honest it looks like it's not listening to me at all, I tried to change boot.plist file in my Extra folder and also in

/Library/Preferences/SystemConfiguration/

folder, still nothing, tried to use Chameleon Wizard to reinstall it, nothing, I would like to hide some partitions, install a theme and do some other tweaks, I can't even figure out how to boot in 32bit mode, adding -arch=i386 at the prompt doesn't help, thus can't really figure out why I get really choppy flash videos (except Youtube in Chrome, which works very well)

 

Have been browsing the forum many times for an answer, no luck, and I'm not quite the biggest noob in looking for something and/or configuring my OSx86 machine.

 

Thanks in advance for answers and help.

Share this post


Link to post
Share on other sites

As of 03/03/12, every time Chameleon Wizard connects to the buildbot, the app crashes:

 

 

Process: Chameleon Wizard [741]

Path: /Applications/Chameleon Wizard.app/Contents/MacOS/Chameleon Wizard

Identifier: janek202.Chameleon-Wizard

Version: ??? (4.0.1)

Code Type: X86-64 (Native)

Parent Process: launchd [112]

 

Date/Time: 2012-03-04 13:26:43.893 -0700

OS Version: Mac OS X 10.7.3 (11D50)

Report Version: 9

 

Interval Since Last Report: 138380 sec

Crashes Since Last Report: 7

Per-App Interval Since Last Report: 215 sec

Per-App Crashes Since Last Report: 7

Anonymous UUID: 022FE66C-30F4-4CF0-9BAA-53F780318B4C

 

Crashed Thread: 4 Dispatch queue: com.apple.root.default-priority

 

Exception Type: EXC_CRASH (SIGABRT)

Exception Codes: 0x0000000000000000, 0x0000000000000000

 

Application Specific Information:

objc[741]: garbage collection is OFF

*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[__NSCFDictionary setObject:forKey:]: attempt to insert nil value (key: Full Name)'

 

I have done absolutely nothing in regards to my system at the time of my 1st attempt, one minute Chameleon Wizard worked, then after the latest build was posted for the Buildbot, crash, every time, and is persistent on my test system as well. The problem seems to be the build bot server.

Share this post


Link to post
Share on other sites

hey mate, I love your tool and I use it regularly to keep chameleon updated!

 

 

One Option that might be great for future releases is the debug=0x100 option.

It gives you details in case your mac crashes what the cause of the issue is!

 

Keep up the good work!

Share this post


Link to post
Share on other sites

Janek, thank you all for your great job!

I can't read all thread, and I can't find search or printable view for this new forum-engine.

I'm sorry if somebody asked this question already.

 

I use EFI partition to store the Chameleon Loader there, and EFI support is enabled.

But Chameleon Wizard can't install themes to EFI, because it detects only one empty EFI partition on the second disk (with Time Machine backups).

Could you fix it?

 

Regards,

Anton.

Share this post


Link to post
Share on other sites

For whatever reason, I cannot boot my octo-core hack pro using any Lion-compatible bootloader options, including this one - every time i try it gives me just a split second of the apple logo and immediately reboots. Any suggestions? i've tried everything, even replacing the motherboard.

 

specs:

Mobo: Asus Z8NA - D6

CPUs: 2 x Intel Xeon 5530

RAM: 24 Gb Hynix DDR3 1333

Sys Disk: Corsair Force GT 120gb SSD

Several other internal and iSCSI disks

 

If anyone has any suggestions i would be forever in your debt!

 

BTW: I use the chameleon wizard on my other HackPro - its an amazing tool

 

Thank you in advance

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      This is a brief guide on how to create a vanilla El Capitan (also same process for Sierra) OS X Installer USB with an updated prelinked kernel containing FakeSMC.

      It is tailored for those users who want to understand the “nuts and bolts” of how to create an installer and also to help brush up on their terminal skills (rather than have one made for them with the numerous automated “tools” available or even Apple’s createinstallmedia) :
       
       
      Specifically, it is also a “Proof of Concept” which shows that installation is possible without even having to rely on boot loader kext injection.

      Prerequisites
      Existing Yosemite installation (or Mavericks - see post#4 for steps 7,8) “Install OS X El Capitan.app" downloaded to the Applications folder Pacifist FakeSMC.kext - Slice or Kozlek branch Bootloader - Clover or Chameleon 8GB or larger USB drive (16GB recommended), formatted HFS+ (MBR or GUID) named “Installer”  
      Procedure
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Open OS X terminal and type the following lines, followed by <Enter> after each line.
          The image restore and file copying may take a while to complete, and at the end of the process, the Installer volume is renamed to “OS X Base System"....
       
      sudo -s hdiutil attach /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/SharedSupport/InstallESD.dmg asr restore -source /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg  -target /Volumes/Installer -erase -format HFS+ -noprompt -noverify rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages cp -av /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/OS\ X\ Base\ System/System/Installation cp -av /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg /Volumes/OS\ X\ Install\ ESD/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System diskutil unmount /Volumes/OS\ X\ Install\ ESD exit 3.  Right click on the “OS X Base System” Volume and click “Get Info”
       

      4.  Click on the lock icon and untick “Ignore ownership on this volume”
       

      5.  Extract/Copy the El Capitan Kernels folder into /System/Library/ of the USB with Pacifist.  NB It is found in the "Essentials.pkg" in /System/Installation/Packages
       

      6.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel —> OG.prelinkedkernel
       

      7.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of the installer USB using Finder.
       

      8.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel…..
       
      sudo -s chmod -R 755 /Volumes/OS\ X\ Base\ System/Library/Extensions chown -R 0:0 /Volumes/OS\ X\ Base\ System/Library/Extensions touch /Volumes/OS\ X\ Base\ System/System/Library/Extensions kextcache -u /Volumes/OS\ X\ Base\ System exit Any errors should be noted but the output below is normal e.g.


      9. Install your Bootloader targeting the OS X Base System volume
       
       
       
       
      10.  Boot your system with the USB without injected kexts into the OS X Installer GUI....
       
       
       
       
       
      Post Install
      The original prelinked kernel in a fresh install of El Capitan will also lack FakeSMC ie it will only be linked to Apple signed kexts.  In order to boot into El Capitan the first time around without boot loader kext injection, the PLK needs to be rebuilt for the El Capitan volume like we did for the installer:
       
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel for the El Capitan volume —> OG.prelinkedkernel
      3.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of El Capitan using Finder
      4.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel.  In this example, the El Capitan volume is named "El_Capitan" - change if you have named it something else...
      sudo -s chmod -R 755 /Volumes/El_Capitan/Library/Extensions chown -R 0:0 /Volumes/El_Capitan/Library/Extensions touch /Volumes/El_Capitan/System/Library/Extensions kextcache -u /Volumes/El_Capitan exit 5. Install your Bootloader targeting the El Capitan volume.  This step is only necessary if you are installing El Capitan on a new drive without existing boot loader (not required if installing on a disk with existing boot loader beside Yosemite).
      6. Reboot your system without injected kexts into El Capitan!
       
       
      Other links
      The All-In-One Guide to Vanilla OS X for beginners
       
      Updates for Sierra and High Sierra   Custom Prelinkedkernel Generator Tool I have made a custom prelinkedkernel generator "PLK.tool" for Sierra + El Capitan.  Instructions:   1.  Download and extract the attached BaseSystem_PLK.tool.zip into your ~/Downloads folder.   2.  Copy any extra kexts necessary for booting your hack to ~/Downloads/BaseSystem/ExtraKexts (e.g. FakeSMC, VoodooPS2Controller), making sure SIP is disabled. 3.  Copy BaseSystem.dmg to ~/Downloads/BaseSystem  4.  Open terminal and run the following commands... cd ~/Downloads/BaseSystem chmod +x PLK.tool ./PLK.tool ---> supply your admin password ---> will place your new custom prelinkedkernel on the desktop.       macOS High Sierra bypass Firmware and MBR checks in post#13.
      BaseSystem_PLK.tool_ElCap.zip
      BaseSystem_PLK.tool_Sierra.zip
      BaseSystem_PLK.tool_Mojave.zip (need to run in Mojave to avoid dependency errors)
       
    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create Mac OS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the Mac OS installer apps, it is capable to create a Mac OS installer on a drive completely vanilla like what you do using the command line method, and also this method is recommended by apple itself. In addition to this, this app provvides also to you some customization features and a better management of the hall macOS isntall media creation process
       
      Allows you to create easily a macOS install media without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is you want to use it on a Mac.
       
      Features:
        - Simple to use UI that allows you to easily start the macOS install media creation process
        - It can work with every Mac OS installer app that has the createinstallmedia executable inside of it's resources folder (including also beta and newly released installers)
        - You can use any drive or partition you want that can be erased and is at least 7 GB of size
        - Works on Mac OS recovery, so you can create a macOS install media from a bootable macOS installer or from the macOs recovery, and you can use TINU to install macOS too.
        - All vanilla, the macOS install medias created with this tool are 100% vanilla, just like you created them using the command line "createinstallmedia" method in the terminal, with also some extra optiona features
        - Open source, you will know what this program does on your computer and also you can create your own version by downloading and playing with the source code
        - Does not requires to do anything of special first, just open the program
        - No need to go in disk utility first, TINU can format your drive for you
        - Uses recent and more modern APIs and SDKs and Swift 3 language
        - Transparent graphics style available (use alt + s on the keyboard or View->Use transparent style)
        - Works using the latest versions of macOS and will also support newer Mac installers out of the box without needing for an update
        - Advanced section, to customize your macOS install media
        - Installer customization: Kernelcache/prelinkedknerel and boot files replacement (a feature that can be handy while dealing with old Macs or with beta installers when you need to mod or change the boot files some times)
        - Clover EFI folder installer
       
        Features that are planned for some future versions:
        - Integrated EFI partition mounter tool (TINU can already mount EFI partitions from version 2.0, but a dedicated section which allows to mount every EFI partition in the system will be added)
        - Install clover and configure clover
        - Install kexts inside the kexts folder of clover
        - Clover drivers customization
        - Use custom dsdt in clover
        - integrated pre-made clover config templates database from a remote and open repository
        - Support for other languages, at least Italian   Rquirements:  - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer)  - A drive or a free partition of at least 7 GB that you want to turn into a macOS/Mac OS X installer  - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage device in your machine (excepted the drive or volume you want to turn into your macOS install media)   Note that this app is under the GNU GPL v3 license so any reuse of the source code must follow the license's terms   Latest stable TINU release:   Download the app:                                https://github.com/ITzTravelInTime/TINU/releases   View the source code:                            https://github.com/ITzTravelInTime/TINU/       Frequently asked questions about TINU:  https://github.com/ITzTravelInTime/TINU/wiki/FAQs     NOTE: if you have problems with your USB installer of 10.13.4 or newer version not being detected by clover you have to use the latest clover and if it still does not detectets your usb installer you have to remove the invivible file called .IAPhysicalMedia located into the root of the usb installer. This issue is caused by a changement in the apple's createinstallmedia, don't blame TINU for that, TINU does only uses the installer creation method from apple, which has been changed by appleitself, causing this problem for hackintosh users some times, this issue should be resolved in the latest versions of clover which will no longer require that you do changements to let your usb dive to be detected, a setting to do this fix automatically in tinu is also present TINU in the adavnced settings, starting from the version 2.0 of the app. I leave also some screenshots as well
       
       
       
       
       
       
       
       

    • By tlefko
      macOS-Mojave-XPS13-9350
      Hello, this is a simple guide to get OS X 10.14 working on any XPS 13 9350 model
      This guide uses files from (@syscl) (albeit edited) and full credit to him for the Deploy.sh and DSDT patches. However, his Clover folder is unbootable with Mojave and thus has been redone.
      However, his Deploy is still retained but edited to remove some DSDT patches that break things on Mojave
      I did my best to keep the guide simple and for the most part it is, it's inteded for the 6200U non iris but should work with others. (credit @syscl)
      Issues
      Wake up via lid is hit or miss (sometimes needs key press) SD Card slot Restarts don't work (endless black screen while turning off but still on) Usage Notes
      USB Devices eject upon sleep (USB Patches via Deploy were major issue) Changing board number via Clover Config doesn't work always unless serial is changed (No idea..) Audio is controlled via VoodooHDA however prefpane is not nessacary. Never tested USB C anything. Charging should be fine however I'm not sure about others, don't personally use it) What Works
      Everything else! Setup Notes
      The new AFPS file system must be used, there is no way to avoid it. Has no noticeable adverse effects except slower boot time It is difficult to repartition AFPS drives and resize them, recommend clean install or you could have one partition smaller than your hard drive that can't be increased unless reformatted Although Volumes will be converted, keep drive as GUID BIOS Settings
      Set all SATA operation as AHCI Disable Secure Boot, Fast Boot For Coil Whine improvement disable C-States Enable UEFI Booting (Disable Legacy if easily confused) Recommended: Clean Install (Preinstall steps)
      Download latest Mojave version from Mac App store (Register AppleID as developer, enroll your mac, download the preview from the link onsite or google for detailed instructions. Make Bootable media (google how or download app to do it, it's just a terminal command) Download the Latest Clover revision (currently using r4568) and install it to your USB as UEFI and ESP (no need for drivers) Copy The contents of this Github repository into your EFI folder on the USB (Mount the EFI Partition via clover config, efi mounter, etc.) (No Boot Folder in EFI) If you have the same XPS Model as me you can use stock ACPI patched files (6200u, hd 520, 3200x1800,) if not delete contents of both folders (origin, patched) and will fix later via @syscls modified deploy) Installing Mojave (Clean Install)
      Boot PC off the USB, select your Installer as your Boot drive from clover menu config is currently set to FAKESERIAL and -v. I believe (@syscl's) deploy generates serial # information Once installer is loaded, go to disk utility and format as a GUID Partition Table with whatever partitions you want (Don't format whole drive to afps make sure it's GUID) Run the Mojave installer to the drive wait for it to finish, then turn off) From Clover, select the name of the Mojave Partition (not preboot, recovery, etc.) and not your USB stick either From here the installation will continue. DO NOT CLICK ON MOUSE OR KEYBOARD (crashes installer shortly after at least for me) Post Install (Clean Install)
      Reboot off your USB once again, load up your Mojave drive. First Boot will take long, if your using my ACPI files (from @sysl's deploy, edited) and have same model you should have everything out of box (except wifi) Regardless, run through the installer and set it all up. (without acpi) At this point screen should be fine, mouse, keyboard, no wifi should be present or bluetooth. No brightness control as well. go to terminal to mount EFI or via clover Config, EFI Mounter, etc, of both USB and the internal disk Copy and REPLACE the EFI folder from the USB into your hard drive. Unplug your USB and reboot and you should be able to boot without the USB now Turn off PC, boot into clover. Don't select a drive and press F4 and Fn+F4 a few times, wait a few seconds, then boot back to the drive Plug back in the USB, mount it's EFI, and run the modified Deploy Script on your Hard Drive EFI partition After deploy is finished, there will be VoodooI2C error as I deleted it from Kexts, for me it breaks Trackpad and Keyboard. For now will be using VoodooPS2. After Modded Deploy
      You should have no Internet at this point, the following next steps should resolve that. However, your Brightness, lidsleep, USB, bluetooth should be working Using your favourite Kext Installer (Put it on a USB or something to get it on the PC), install (credit @Rehabman's) FAKEPCIID and FAKEPCIID_Broadcomm texts that are included in the ManualKexts Folder Then run "Sudo kextcache -i /" from terminal, reboot, then run it again. By this point your wifi should be fixed, and everything should be done Post Install Notes
      Your welcome to transfer whatever other kexts you want to S/L/E, personally I leave them in the CLOVER Folder injected. Doing upgrade via mac app store is similar, just partitioning hard drive is harder. Apart from that same process essentially, not recommended Credits
      Credit Hackintosher.com for basic patches (although @syscl) covered some Credit to @syscl (clearly...) Credit to @Rehabman Credit to @syscl Kexts, and his contributers. ex. Lidwake.kext (although not fully compatible) Support
      Your welcome to open any issues on this thread, I personally have little DSDT knowledge so I will do my best to help! Thanks for Reading!
      - This is a clone from my GitHub, the link to the repository is below with all files
       
      https://github.com/tlefko/macOS-Mojave-XPS13-9350
       
      - I would really like to hear everyone's experience trying this guide so please let me know in the comments how it worked for you, if you plan to try it, etc.
    • By Tom Snow
      Hello everyone, it sure has been a while since I last posted here. I'm trying to upgrade my Hackintosh to High Sierra, and right now it's running Sierra which I installed last year. My hardware is a Gigabyte Z68MA-D2H-B3 mobo with Intel Core i5-2500K. Unfortunately, I can't even run the installer. I have an installer USB stick with Clover 4558 on it, and whenever I try to run the installer from it, I get a KP after an extremely long boot process. There are so many panic messages that flash by so fast, but I think I got everything relevant in these pics.
       
       


    • By ITzTravelInTime
      Questo è il thread in italiano dedicato alla mia app TINU, l'app open source che ho creato per creare chiavetta di installazione di mac utilizzando il metodo "createinstallmedia".
      Il nome è l'acronimo di TINU Is Not U (Per le regole del forum devo censurare, ma la U si riferisce ad un programma che piu o meno svolge lo stesso scopo che per buoni motivi è bandita su questo sito, il punto del metterlo nel nome sta nel sottolineare che la mia app è totalmente diversa)
      L'app è pensata per essere molto semplice ed immediata da usare (con un interfaccia grafica progettata con criteri e metodi usati in ambito professionale per lo sviluppo di applicazioni utente) e per essere molto solida e stabile che funziona sempre al primo colpo (a differenza di altri tool che conosciamo ...)
       
      A livello funzionale quest'app non è altro che un interfaccia grafica per il metodo da terminale "createinstallmedia" che viene sfrutatto dalla stessa per creare la chiavetta, quindi le chiavette create con TINU sono chiavette al 100% vanilla come se le aveste create dal terminale, l' applicazione, rispatto al metodo da terminale, aggiunge però funzioni utili come il controllo ed il riconoscimento di errori nel processo, la formattazione automatica della chiavetta USB che si sceglie di usare in formato Mac OS Extended (journaled) (detto anche HFS+) con mapatura di partizione GUID, ed anche altre opzioni personalizzabili o disattivabili come l'applicare un icona alla chiavetta di instalalzione.
      Tra gli altri vantaggi troviamo il fatto che permette di creare chiavette utilizzando qualunque applicazione di mac che contiene l'eseguibile "createinstallmedia" inclusi installer delle beta ed installer appena rilasciati, e non richiede di fare cose particolari prima come formattare la chiavetta e cambiare lingua al sistema e puo utilizzare applicazioni di mac che si trovano in varie directory nel sistema e non solo quelle che stanno nella cartella delle applicazioni ed hanno un nome specifico (nota che l'applicazione di installazione di mac deve essere quella interacche pesa diversi gb e non quella da pochi mb che l'app store puo scaricare alcune volte e che non contiene tutto quello che serve per permettere a createinstallmedia di funzionare)
       
      Tra l;e altre cose quest'app è l'unica app di questo genere sviluppata e che continua ad essere sviluppata in Italia ed è anche l'unica completamente open source.
       
      Trovate qui alcuni link utili:
       - Scarica l'app:                                                  https://github.com/ITzTravelInTime/TINU/releases
       - Codice sorgente dell'app:                                 https://github.com/ITzTravelInTime/TINU
       
       - FAQs (Domande fatte di frequente, in inglese):   https://github.com/ITzTravelInTime/TINU/wiki/FAQs
       
       - Thread in inglese su tinu (English thread about TINU): http://www.insanelymac.com/forum/topic/326959-tinu-the-macos-install-media-creation-tool-mac-app/
       
      Qui invece ci sono un paio di guide (Anche se l'app è molto facile da usare):
       - Piccola guida su come usare TINU per un hackintosh:                                   https://www.youtube.com/watch?v=Ug1yBZybpD4
       - Piccola guida su come usare TINU per creare cheiavette per Mac "originali":    https://www.youtube.com/watch?v=fZOZOUt2ErM
       
       
      Pianifico molte altre nuove funzioni per future versioni dell'app (vedi il thread in inglese per saperne di più)
       
       
      Il supporto a clover in TINU è pianificato per una versione futura, anche se dei protipi a livvello codice per renderlo possibile, sono gia stati sperimentati con successo.
       
      Spero che anche voi del forum italiano aprezzerete questa app come gli utenti del forum inglese, per idee e suggerimenti, siete liberi di esprimervi :-)
       

×