Jump to content
janek202

Chameleon Wizard - Utility for Chameleon.

681 posts in this topic

Recommended Posts

So, forgive me for my ignorance, but UseKernelCache renders /E/E and /S/L/E useless?

The system won't use them at all?

 

It won't load kexts in /Extra at all. You have to move them to /S/L/E if you want to use that feature. It makes system boot a little bit faster.

 

BTW. builds.voodooprojects.org is dead and that's why Chameleon Wizard can't see anything to download.

Share this post


Link to post
Share on other sites
Advertisement
My org.chameleon.Boot.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1280x800x32</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Theme</key>
<string>LoginToLion</string>
<key>Timeout</key>
<string>15</string>
<key>UseKernelCache</key>
<string>Yes</string>
</dict>
</plist>

 

My theme is in /Extra/themes/LoginToLion.

 

 

So maybe get rid of Boot Banner and put in Legacy Logo instead? Do you think this is why the boot theme shows for 1 sec that boots to a black screen and eventually to the desktop? Capital T matters in theme? I have lower case t.

 

So, forgive me for my ignorance, but UseKernelCache renders /E/E and /S/L/E useless?

The system won't use them at all?

 

 

From what I gather if you "useKernelCache" "Yes" It ignores any extnesions.mkext which is in your /Extra therefore it will not load your kexts from /e/e. /s/l/e no longer has an exntensions.mkext. So you have two choices. Move the kexts from /e/e to /s/l/e or leave them in e/e and follow this guide below. Remember to remove your extensions.mkext from /e if you follow the method below which will load your /e/e without the extnesions.mkext.

 

There is a work around for this so you can keep your kexts in /e/e.

 

http://www.insanelymac.com/forum/index.php...t&p=1700092

 

 

This is what I am using and I wonder if this is what may be causing the problem with the Boot Theme?

Share this post


Link to post
Share on other sites

@janek202,

 

I figured it out. Looks like GUI =yes must be depreciated.

 

Changed it for Graphics Mode. What resolution should this normally be?

 

What is LEgacy Logo?

 

I have another issue. I had the Chameleon on EFI and removed and formated EFI with this command:

 

newfs_hfs -v EFI /dev/disk0s1

 

Now I try to install onto Root of drive and Wizard sais Chemelon Version unknown. I cannot update anything?

 

I tried to install Chameleon with the package installer last one I found is r1083. After that tried Wizard and I still have the problem with Wizard?

Thanks

Share this post


Link to post
Share on other sites
Changed it for Graphics Mode. What resolution should this normally be?

Native for your screen.

 

What is LEgacy Logo?

That's original grey Apple logo during boot.

 

Now I try to install onto Root of drive and Wizard sais Chemelon Version unknown. I cannot update anything?

 

Chameleon wizard is using VoodooProjects' BuildBot. ( http://builds.voodooprojects.org ).

Currently it's not working, I don't know why, but that's the reason why CW can't download anything.

Share this post


Link to post
Share on other sites
Hi all. I made a new utility for Chameleon. It helps to install, update and download latests revs of this bootloader.

 

Features:

Installing Chameleon with boot0, boot0hfs and boot0md install methods.

Updating Chameleon only by replacing boot file.

Downloading latests revs from server.

EFI Partitions are supported!

org.chameleon.Boot.plist editor.

SMBios.plist editor.

Themes downloader.

bdmesg diagnostic messages reader.

 

Works on Snow Leopard and Lion.

Universal binary: x86_64 and i386.

 

Download links:

http://dl.dropbox.com/u/7085278/Chameleon_...r/download.html

Kexts.com mirror: http://www.kexts.com/view/1713-chameleon_wizard_3.1.html

 

Please report me any bugs or ideas for new features.

I would never make this application without support and ideas by osx86.org.pl team. Thank you, guys!

Thanks a lot to the whole Chameleon team for the awesome work.

 

btn_donate_LG.gif updates_by_sparkle.png

 

If you want me to add your theme into the Chameleon Wizard's theme downloader, just write me an email with zip package, thumbnail, description, and your nick to janek202.osx86 (a) gmail [dot] com

 

Translations:

Chinese with both TW+CN by crazybirdy

German by !Xabbu

Italian by iFabio

Indonesian by Wayang-NT

Korean by MacGuyber

English by janek202

Polish by janek202

French by fantomas1

Portuguese Brazilian by slipttees

Portuguese Portugal by artur_pt

Russian by Awesome

Spanish by juanerson

Swedish by Greggen

 

Thanks to all, who translated this application.

All outdated translations removed. You can find them here: http://dl.dropbox.com/u/7085278/Chameleon_...ranslations.zip

 

If you want to translate, here's required files:

http://dl.dropbox.com/u/7085278/Chameleon_...er/en.lproj.zip

 

THIS SOFTWARE IS PROVIDED BY All-Seeing Interactive ''AS IS'' AND ANY
 EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
 WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
 DISCLAIMED. IN NO EVENT SHALL All-Seeing Interactive BE LIABLE FOR ANY
 DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
 (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
 LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
 ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
 (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
 SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

ss_cw_en.PNG

ss_cw_org_en.PNG

ss_cw_smb_en.PNG

hi, janek

 

nice work with new chameleon wizard

 

here is translation for pt Portugal

 

en.lproj.zip

 

thanks for your good work

Share this post


Link to post
Share on other sites

Maybe you can add MacMini4,1 and 5,1 model numbers for us itx users?

MacMini 4,1 server seems to have DD6K, DD6L and DD6N.

So far had no luck yet with the 5,1 serial as the premium reseller doesn't have it on display.

Shouldn't be to hard to add more model numbers :rolleyes:

Share this post


Link to post
Share on other sites

Very nice app.

Unfortunately, I can't install chameleon with it on a USB key on my desktop which is on an AppleRaid volume : the combo box containing all the rev available did not appear.

 

post-548931-1314132495_thumb.png

Share this post


Link to post
Share on other sites
Very nice app.

Unfortunately, I can't install chameleon with it on a USB key on my desktop which is on an AppleRaid volume : the combo box containing all the rev available did not appear.

 

post-548931-1314132495_thumb.png

 

And I've this log in the Console:

Chameleon Wizard[421] *** -[NSCFString substringWithRange:]: Range or index out of bounds

Share this post


Link to post
Share on other sites

Try this (in terminal):

sudo chown 0:0 /boot
sudo chmod 755 /boot

 

Or

 

Edit Application's Info.plist file.

Change

	<key>Auto Buildbot detection</key>
<true/>

to

	<key>Auto Buildbot detection</key>
<false/>

 

Maybe it will help...

Share this post


Link to post
Share on other sites

For us itx users I got this:

 

MacMini 5,1: (i5 with Intel onboard gfx)

SMBbiosVersion; "MM51.88Z.0075.B00.1106271442"

SMBbiosDate; "06/27/2011"

SMBboardProduct; "Mac-8ED6AF5B48C039E1"

SMBsystemVersion; "1.0"

Serial; "~DJD0"

 

Now you should be able to add full premade smbios for mac mini 5,1 <_<

Still trying to get the serial for the 5,3 to have my hack mini appear as server, got all info except the serial which should end with DJXX with the XX unknown, only the board has an other version number;

SMBboardProduct; "Mac-7BA5B2794B2CDB12"

 

 

MacMini 4,1 (Server):

SMBbiosVersion; "MM41.88Z.0042.B00.1004221740"

SMBbiosDate; "04/22/10"

SMBboardProduct; "Mac-F2208EC8"

SMBsystemVersion; "1.0"

Serial; "~DD6K"

 

MacMini 4,1 (Regular):

SMBbiosVersion; "MM41.88Z.0042.B00.1004221740"

SMBbiosDate; "04/22/10"

SMBboardProduct; "Mac-F2208EC8"

SMBsystemVersion; "1.0"

Serial; "~DD6H"

 

 

Seems there's no 4,2 model, both regular and server version use 4,1 while the 5,1 is the regular model and the 5,3 is the server model. Even the motherboard seems to be the same while the 5,X versions has different model numbers. To bad they still don't have a server model on display here.

Share this post


Link to post
Share on other sites
Try this (in terminal):

sudo chown 0:0 /boot
sudo chmod 755 /boot

 

Or

 

Edit Application's Info.plist file.

Change

	<key>Auto Buildbot detection</key>
<true/>

to

	<key>Auto Buildbot detection</key>
<false/>

 

Maybe it will help...

 

No, it does not.

I think you have a substring exception because my system is on disk2 and not on disk0s2 for example because it is a Raid volume.

 

If you can send me the code, I can solve that problem easily.

Share this post


Link to post
Share on other sites

Any change to add support for boot helper partition, same set up like EFI partition for software raid install, which is locate mostly at diskXs3. :wacko:

 

thanks for this great tools anyway!

Share this post


Link to post
Share on other sites

@janek202

 

A small aesthetic issue. In EFI mode, when I select 'Target partition' = EFI, the description displays wrongly: 'No chameleon installed on selected partition'.

 

PS. The bdmesg window shows the correct Chameleon version of EFI.

Share this post


Link to post
Share on other sites

Found more:

 

MacMini 3,1 (Server):

SMBbiosVersion; "MM31.00AD.B00"

SMBboardProduct; "Mac-F2208EC8"

Serial; "~B9X" (11 characters)

 

MacMini 3,1 (Regular):

SMBbiosVersion; "MM31.0081.B06"

SMBboardProduct; "Mac-F2208EC8"

Serial; "~19X" (11 characters)

 

MacMini 2,1 (Regular as there is no server version):

SMBbiosVersion; "MM21.009A.B00"

SMBboardProduct; "Mac-F4208EAA"

Serial; "~YL2" (11 characters)

 

iMac 10,1 (21,5"):

SMBbiosVersion; "IM101.88Z.00CC.B00.0909031926"

SMBoardProduct; "Mac-F2268CC8"

Serial; "~B9S" (11 characters)

 

I found these by accident searching for a MacMini5,1 server serial, want me to continue for more? :D

Share this post


Link to post
Share on other sites
Are MacMini's smbioses useful for hackintoshes in any way? Because I have never heard of anyone using them.

 

It doesn't hurt ?

It could be more useful to add MacBookAir ones.

 

Here is the French translation.

Share this post


Link to post
Share on other sites

I use them as my itx build is spec wise identical to a mac mini 5,1 and my old one was an almost copy of the 3,1 one.

The 3,1 one has worked for almost 3 years now without issues!

For me it would be no problem getting all the different values for the MacBook air.

One final thing about mac mini 5,x, since the HD3000 can be made to work now using a macmini5,1 smbios does make a lot of sense. Just to bad I have HD2000 on my cpu now and that can't be made to work yet.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fighttoby
      I have tried to install clover via no UEFI legacy mode (and with UEFI method) using the method here (http://www.tonymacx86.com/yosemite-desktop-guides/144426-how-install-os-x-yosemite-using-clover.html)
      both times I can get to just past the clover boot screen and it freezes after that.
      I have verbose (-v) selected in boot options: On the non-UEFI install then it hangs on:
      "Waiting on <dict ID="0"><key>IOProviderClass</key>...."
       
      I have had a lot of issues with trying to get the installer working and many different things that had to be disabled but now it just gets to here and stops. Some times it will glitch out on this screen and give me a the circle with the line through it and text garbage around it where the text in the pictures are.
       
      Need help please.
       
      This is the laptop im using the specs are the same nothing has changed.
      https://www.asus.com/Laptops/ASUS_VivoBook_X202E/


      config.plist
    • By ciriousjoker
      TLDR:
      I'm trying to boot MacOS on a Chromebook without UEFI. I'm stuck at getting the bootloader (Chameleon/Clover) to work.  
      My setup / context:
      I have an Acer Chromebook Spin 13.
      Available ports:
      2 x USB-C 1 x USB-A 3.0 MicroSD Slot No USB A 2.0 (I've read that Clover has problems with USB 3.0) Firmware:
      There's no UEFI firmware available and by default, it doesn't even allow booting anything other than ChromeOS. Thanks to MrChromebox (big shoutouts!), I flashed a custom legacy bios that allows me to boot anything linux related. This bios is flashed into the RW_LEGACY section of the existing bootloader (coreboot afaik) and doesn't have any configuration options. If I have to change a setting, I could try compiling his bios payload myself with the specific setting enabled.  
      What I've tried so far:
      Chameleon attempts:
      Only selected setting was "Install chameleon on the chosen path", rest was unselected.
       
      1 - Install chameleon first without restoring the basesystem:
      Output:
      > boot0: GPT
      > boot0: done
      (hangs; pressing power button once shuts down
      Chameleon installation log is attached as "Chameleon_Installer_Log_BEFORE".
       
      2 - Install Chameleon after restoring the base system:
      Output:
      > boot0: GPT
      > boot0: GPT
      > boot0: doneboot1: /boot       <- Exactly like that, no line break in between
      (hangs; pressing power button once shuts down)
       
      I haven't been able to reproduce #2 after wiping the drive and doing the same thing again. Subsequent attempts have resulted in either #1 of either Chameleon or Clover.
      Chameleon installation log is attached as "Chameleon_Installer_Log_AFTER".
       
      Clover attempts:
      I tried multiple settings and configurations, but all of them boiled down to either one of these.
       
      1 - Doesn't do anything, just hangs at "Booting from usb..."
      2 - Boots into the blue/grey mode as shown in the attached images.
      According to MrChromebox, this could be an old Tianocore DUET It doesn't detect anything (cpu frequency, ram, partitions or disks)  
      I've read pretty much every article, github readme and other types of documentation for coreboot, tianocore, clover, chameleon and MrChromebox' rw_legacy payloads and right now, I'm totally clueless as to what to try next...
       
      A few questions that came up:
      Why does chameleon hang? What is it looking for, /boot was clearly written to the disk by the Chameleon installer? What exactly is the blue/grey image? According to MrChromebox, it could be Tianocore DUET Where does it come from? Clover? The mainboard itself? Why does the blue/grey thing not detect my processor frequency or any partitions/drives? Can I use some sort of DUET bootloader to chainload Clover?  
      If you guys could answer any of them or if you have any other guesses or information as to what's happening, I'd be really happy!
      Chameleon_Installer_Log_BEFORE.txt
      Chameleon_Installer_Log_AFTER.txt





    • By grisno
      Hi people,
       
      This is a preliminary installer to activate the Combo Mini PCIe Atheros QCWB335 in MacOS.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      AIRPORT : OK Atheros QCWB335 (AR9565) (168c:0036) Mini PCIe * BLUETOOTH : OK Atheros AR3012 (0cf3:3121) USB 2.0 ** AIRDROP : Not Tested HANDOFF : Not Tested CONTINUITY : Not Tested WOL : Not Tested IMESSAGE : OK FACETIME : OK ICLOUD : OK APPSTORE : OK   Known Issues:
       
      - Partial support with a maximum speed of 10Mbits (10.11.0+) *
      - Don't support Bluetooth Power Off/On by Software (10.10.0+) **
      - Sometimes Lost Bluetooth After Sleep WakeUp (10.10.0+) **
       
      Sources:
       
      Insanelymac
    • By grisno
      Installer to activate the Combo Mini PCIe AZUREWAVE AW-CE123H in macOS (10.8.5+)
       
      Status:
      AIRPORT : OK AzureWave AW-CE123H (14e4:43b1) [Broadcom BCM94352 HMB] Mini PCIe BLUETOOTH : OK AzureWave AW-CE123H (17cf:0b05) [Broadcom BCM20702A1] USB 2.0 AIRDROP : OK HANDOFF : OK CONTINUITY : OK WOL : Not Tested IMESSAGE : OK FACETIME : OK ICLOUD : OK APPSTORE : OK SIRI : OK   I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
    • By grisno
      macOS driver installer for laptop HP Pavilion G6-2209SS with support for dual boot Bootloader. Maybe it can be installed on other HP Pavillion G6 series laptops, but in some cases additional fixes will have to be made.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      CPU : OK Intel Core i3-2370M AUDIO : OK IDT 92HD87B2/4 (111d:76d9) Layer 3 & 12 (Speakers+Hearphones+LineIn+MicInt w/NoiseFilter+MicExt+HDMI) VIDEO : OK Intel HD Graphics 3000 (8086:0116) (LVDS + HDMI A/V + VGA) (VGA MacOS < 10.8.2) MEMORY : OK Intel 2nd Generation Core Proccesor DRAM Controller (8086:0104) (Dual Channel DDR3 Up To 16GB) SATA : OK Intel 7 Series Chipset Family SATA Controller (8086:1e03) (ACHI Mode) DVD : OK (Read & Write) USB 2.0 : OK Intel 7/C216 Chipset Family USB Enhaced Host Controller (8086:1e26 & 8086:1e2d) USB 3.0 : OK Intel 7/C216 Chipset Family USB xHCI Host Controller (08086:1e31) WEBCAM : OK HP TrueVision HD (SuYin) (064e:e263) [USB 2.0] KEYBOARD : OK PS/2 TRACKPAD : OK PS/2 Synaptics LAN : OK Realtek RTL8501E Fast/Gigabyte Ethernet Controller PCI Express (10ec:103c) * AIRPORT : KO MediaTek RT3290 PCI Express (1814:3290) (Not Supported) BLUETOOTH : KO MediaTek RT3290 PCI Express (1814:3298) (Not Supported) CREADER : OK Realtek RTS5229 PCI Express (10ec:5229) (10.12.5+) *** ACPI BAT : OK (Chameleon & Clover) ACPI PWR : OK (Chameleon & Clover) ACPI RST : OK (Chameleon & Clover) ACPI SLP : OK (Chameleon & Clover) ** ACPI WAK : OK (Chameleon & Clover) ** HIBERNATE : OK (Only Clover Bootloader w/Hibernatemode: 0, 21 & 29) IMESSAGE : OK (Chameleon & Clover) FACETIME : OK (Chameleon & Clover) ICLOUD : OK (Chameleon & Clover) APPSTORE : OK (Chameleon & Clover) ITUNES : OK (A/V DRM Content & Sync iPod/iPhone) SIRI : OK CMOS : OK RTC : OK LPC : OK Intel HM76 Express LPC Controller (8086:1e44) SMBUS : OK Intel 7/C216 Chipset Family SMBus Controller (8086:1e22) IMEI : OK Intel 7/C216 Chipset Family MEI Controller (8086:131a) GPT PART. : OK (Chameleon & Clover) (10.13+ APFS Not Tested) MBR PART. : Not Tested   Known Issues:
       
      - AppleRTL8169Ethernet: phyWaitForAutoNegotiation TIMEOUT. *
      - AppleRTL8169Ethernet: only work to 10Mbits. *
      - You can't wake up the system when the laptop uses the battery and the system disk is a USB hard drive. **
      - You can't wake up the system from PS/2 Keyboard/Trackpad. **
      - The Wifi MediaTek RT3290 (1814:3290) device are not supported.
      - The Bluetooth MediaTek RT3290 (1814:3298) device are not supported.
      - The PCIe CardReader Realtek RTS5229 (10ec:5229) device are not supported. *** (10.12.5-)
      - Stop working when sleep with inserted card. *** (10.12.5+)
      - Chameleon Bootloader Not Work Properly With macOS Mojave
       
      Coming soon:
       
      - Installer: Create unified installer for all Mac OS versions
      - Manual: How To Install Wifi Card Blacklisted In HP UEFI BIOS
      - Manual: How To Install OSX Without Destroying Windows 8.x Partition
      - Driver: VirtualSMC Support
×