Jump to content

GMA950 on iAtkos S3 v2 SL

3 posts in this topic

Recommended Posts

Hi there,


I have installed an iAtkos S3 v2 Snow Leopard on my ThinkPad Z61t succesfully. First i was not able to get over non-ending loading, so I plugged external monitor , and it works !


Screen resolution was not native ( 1280 x 1024 ) , but 1024x768, but also QE / CI was enabled, and everything runs smoothly and nicely.


I wanted to have it on my ThinkPad LCD, so I installed AppleGMA950 and AplleIntegratedFramebuffer kexts, and it work, resolution was native on my notebook LCD, but QE / CI was disabled. I tried many kexts, but nothing works. So i tried it again, but the kexts broke my system, and i was not able to get across the loading of SL.


So i want to ask for any ideas how to fix it.


my device id is 27A2, ThinkPad Z61t Intel Core 2 Duo, 2 GB RAM, Intel 945 chipset.


Please help !!!!!!!!

Link to comment
Share on other sites

  • 3 years later...

I wish I could help but I'm having a similar issue. I have the GM945 and 10.6.8 sees it as a GMA950. I have the 10.6.6 kexts in the EXT. folder but the OS doesn't see them apparently. It took a few weeks to get this far. I took out all of the GMA kexts and finally got it to boot without having to connect an external monitor. This is a Dell D820Currently it shows GPU  Dvice ID: 0x27a2 I have installed half a dozen different kexts and still haven't got higher than 1024x768. The bios reads 1280x800 native res. 

VooDoo gave me sound, keyboard and touch pad, but they don't show in preferences but work just the same.  

Link to comment
Share on other sites

  • 3 months later...


i have a HP Compaq nc6320 with a 27a2 GMA950 and has the same problem with no QE/CI .

The only working solution for me was to made a patched DSDT with DSDT Editor.


@VooDooMan63 - GM945 is the chipset , GMA950 the graphics accelerator ;)

Link to comment
Share on other sites


  • Create New...