Jump to content
MaLd0n

Lion installation via USB stick using Chameleon

1,467 posts in this topic

Recommended Posts

can anyone help me with my problem? It's post nr 196

try with USBBusFix=Yes

Share this post


Link to post
Share on other sites
Advertisement
Guess what? I get the "still waiting for root device" error again!

Apple loves AHCI

Share this post


Link to post
Share on other sites
Apple loves AHCI

 

 

I swear i've been searching all around the internet for almost a year, but I found nothing, why my SATA Mode option is greyed out on RAID and I can't change it? Why? Damn PC, i've tryed to flash the bios but with no result, any suggestions?

 

The pc is Acer Aspire M3640, and the bios is an AMI R01-C1

Share this post


Link to post
Share on other sites

Hi there,

 

Ok used this excellent tuturial and got almost everything working accept for sleepmode (it works kind of)

 

the first problem is when i use apple>sleepmode it will go straight to sleep and and goes back up when i click the mouse but after i have used this method and i reboot my biossettings are reset so i have to make all the bios changes again!

 

the second problem is when i leave the pc to go in sleep mode by itself it will turn of the screen but the systemfans are still working and every now and then i hear the hdd and the dvdrw spinning. so this is not working

 

for sleep i have enabled:

 

Made a userDSDT in /extra

 

Chameleon:

restartfix + powermanagement + force HPET

 

in boot.plist in extra folder these strings are there:

<key>GeneratePStates</key>

<string>Yes</string>

<key>GenerateCStates</key>

<string>Yes</string>

 

removed from S/L/E

NullCPUPowerManagement

 

 

my system components are:

ga-p35-ds3p (rev.1 + f12)

6gb mem

E6750 proc

1x sata 2TB 2x sata 1TB 1x sata 500 gb

1x sata rw

1x BT dongle sitecom

GTX260 core 216

 

i hope someone can help me with this?

 

thanks in advance.

 

 

PS

also got a videocard sound problem maybe someone here can check this out

 

GTX260 Core216 sound problems

Share this post


Link to post
Share on other sites
Just to put in here for nForce users, nForce boards do not support AHCI (with the exception of nForce boards that include onboard graphic cards), and also don't send the TRIM command for SSDs. It can do NCQ through its controller though. The JMicron SATA ports do support AHCI, but you'd get worse performance running a HDD through these, than on the normal SATA ports.

 

You can uninstall the Nvidia controller though in Device Manager and install Microsoft's IDE Controller, which can send TRIM commands for SSDs.

 

Head to Device Manager (Open Start menu, type Device Manager), and click "IDE ATA/ATAPI Controllers", and you will see 3 Nvidia Serial ATA Controllers. Right click one of them and click "Properties" and go to the "Driver" tab. Click "Update Driver". Click "Browse my Computer", and then "Let me pick". You will see the option to choose "Standard Dual Channel PCI IDE Controller". Click this and click "Next" and let it install.

 

Do the same for the other two Nvidia Controllers in Device Manager and restart your system. After the controllers have installed, you will be asked to reboot again.

 

Are they serious? My nforce 630i mobo chipset doesn't support ahci????? Will the method above help me?

Share this post


Link to post
Share on other sites

hi,

 

thx for this tutorial. but it doesnt really work for me with dp3.

 

 

 

i made everything like its wrote in the first post. but if i want to start from the usb, i get "Cant find mach kernel"

 

 

 

what can i do?

Share this post


Link to post
Share on other sites

First, sorry for my bad english! :D

 

I just successfully installed Lion! But i got user permission problems! :(

After installation, I had a problem on the Welcome Wizard... after the user creation it crashed and get looped... i fixed it creating a file named ".AppleSetupDone" in /var/db!

Now lion starts successfully! But the user made by the welcome wizard isn't a sudoer! ( I'm not administrator ) :(

I tried to use "dscl" to make another user or giving administration privileges to the existing one without success ( in both cases i get error in Single user mode )!

I've tried to enable root account changing his passowrd, but i get error here too ( Unable to change the password for record root. eDSRecordNotFound ).

I've tried to enable the user to be a sudoer editing the sudo file using visudo... but I failed in it too!

I have made all the attempts in Single User mode, becouse i can't do anything without sudo permission after booting into lion

I'm using the DP3, How can i fix this it ? :(

Share this post


Link to post
Share on other sites
I swear i've been searching all around the internet for almost a year, but I found nothing, why my SATA Mode option is greyed out on RAID and I can't change it? Why? Damn PC, i've tryed to flash the bios but with no result, any suggestions?

 

The pc is Acer Aspire M3640, and the bios is an AMI R01-C1

you need the driver SATA/PATA to the Lion

 

ga-p35-ds3p (rev.1 + f12)

6gb mem

E6750 proc

1x sata 2TB 2x sata 1TB 1x sata 500 gb

1x sata rw

1x BT dongle sitecom

GTX260 core 216

 

send me your files

http://www.insanelymac.com/forum/index.php...st&id=81816

Share this post


Link to post
Share on other sites
hi,

 

thx for this tutorial. but it doesnt really work for me with dp3.

 

 

 

i made everything like its wrote in the first post. but if i want to start from the usb, i get "Cant find mach kernel"

 

 

 

what can i do?

 

juste past the existing mach_kernel from the DVD to / from your USB

Share this post


Link to post
Share on other sites

I'm having a few problems here.

I've tried restoring lion to both a mbr and guid usb stick.

When booting from the USB stick, I can't type anything in, like -v etc as it gets stuck after the 1st letter.

Also when booting with no variables it gets stuck saying that it cant find /var/db/BootCache.playlist

I have an E6600 and with a foxconn board. It runs 10.6.7 ok.

Share this post


Link to post
Share on other sites
Stuck on "Systemuptime in nanoseconds is 37909(Somenumber)" :)

Despite I installed Chameleon to the Pendrive it changed my Snow's Bootloader and windows no longer boots ( I use modcd to boot into windows )

 

Hi MaLd0n

Used the method.

Got same problem.

Tried the installation twice with no results.

Any idea ? :)

Share this post


Link to post
Share on other sites
First, sorry for my bad english! :D

 

I just successfully installed Lion! But i got user permission problems! :)

After installation, I had a problem on the Welcome Wizard... after the user creation it crashed and get looped... i fixed it creating a file named ".AppleSetupDone" in /var/db!

Now lion starts successfully! But the user made by the welcome wizard isn't a sudoer! ( I'm not administrator ) :)

I tried to use "dscl" to make another user or giving administration privileges to the existing one without success ( in both cases i get error in Single user mode )!

I've tried to enable root account changing his passowrd, but i get error here too ( Unable to change the password for record root. eDSRecordNotFound ).

I've tried to enable the user to be a sudoer editing the sudo file using visudo... but I failed in it too!

I have made all the attempts in Single User mode, becouse i can't do anything without sudo permission after booting into lion

I'm using the DP3, How can i fix this it ? :(

 

I've edited the sudoers file from another snow installation!

problem solved

Share this post


Link to post
Share on other sites

Tried putting AHCIPortInjector, ATAPortInjectior and IOAHCIBlockStorageInjector from my Snow Leopar Install into the /e/e folder, but now when I boot I get the spinning beach ball and no installation window. Any Ideas?

Share this post


Link to post
Share on other sites

Could maybe some one help me ;D

plz.. rly :L

i tried a alot of times to intal Snow Leopard.. and well every time it didn't work.. my question would be.. if some one could to a disk for me because i don't have no friends with macs or a mac :L or i can run idk how Snow Leopard in my PC...

 

I have an Original Snow Leopard disk and a original Leon disk ;D

Share this post


Link to post
Share on other sites

Ok, when i try the step "Now click on the Restore tab, drag Mac OS X Base System to Source and the USB drive partition to Destination, then click on the Restore button. This operation takes several minutes.", I get the following error "Restore failed, Unable to perform the restoration, resource busy"

 

Any idea? :(

Share this post


Link to post
Share on other sites
Could maybe some one help me ;D

plz.. rly :L

i tried a alot of times to intal Snow Leopard.. and well every time it didn't work.. my question would be.. if some one could to a disk for me because i don't have no friends with macs or a mac :L or i can run idk how Snow Leopard in my PC...

 

I have an Original Snow Leopard disk and a original Leon disk ;D

 

How can you have an original lion disk when its download only?

Share this post


Link to post
Share on other sites

 

 

Thanks Mald0n

 

it goes to sleep when i select apple>sleep it wakes up perfectly by clicking the mouse and the bios stays no reset anymore.

 

but autosleep function does not work properly screen goes of but fans are still rotating and there is hdd activity could this be dropbox autosync and/or plexserver? im gonna try stop all those background syncing apps maybe this helps.

Share this post


Link to post
Share on other sites
but autosleep function does not work properly screen goes of but fans are still rotating and there is hdd activity could this be dropbox autosync and/or plexserver? im gonna try stop all those background syncing apps maybe this helps.

 

old problem

http://www.insanelymac.com/forum/index.php?showtopic=182535

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×