Jump to content
MaLd0n

Lion installation via USB stick using Chameleon

1,467 posts in this topic

Recommended Posts

for keyboard: voodoops2 kext (attached) but youll have to get in SLE of the installation HDD somehow. and then redo the kernelcache. just did this for my install :) format a flashdrive to fat32/hfs/ntfs and put the kext on there and then you can use the install dvd to move it to the installed lion. or if you still have windows on the pc, then you can read the kext from there at do it that way.

 

thats strange for the mouse though, usb keyboard or mouse almost always work. try w/o the keyboard (you dont really need a keyboard until the user setup)

 

kext is for lion for sure and 64/32bit

VoodooHDA.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

download the binarys of cham here. download and extract the zip and then use terminal to cd into the extracted folder like "cd " and then drop in the folder extracted.

 

use these commands:

 

Find what hdd osx is on and what partition:

diskutil list

 

Install boot0 to the MBR:

./fdisk440 -f boot0md -u -y /dev/rdisk0

 

Install boot1h to the bootsector of the EFI partition:

dd if=boot1h of=/dev/rdisk0s1

 

rdisk0s3 is the partition osx is on(the s3).

rdisk0 is the hdd osx is on

Share this post


Link to post
Share on other sites

No w8,my hdd is right there : System reserved- windows 7 - datas - osx , so i need to install to s4?

 

 

 

Btw when from prompt i use the first command it say "permission denied" and i can't log on "su" cause when i hint the psw it show me "Sorry" ... hell!

Share this post


Link to post
Share on other sites

I do Step by Step

 

and seems working well but in last step (boot from USB)

laptop frezzed on DSMOS has arived (pic attached)

 

My laptop spec:

Acer 5750G

core i3 2350M (sandy brig)

4G Kingston RAM 1333

NVDIA 610M (in Bios I changeedd Switchable to Integrated)

Intel 3000HD is second VGA (active VGA)

 

Please help me/

THANKS/

post-1069148-0-49794700-1346244962_thumb.jpg

Share this post


Link to post
Share on other sites

use this flag: -f -v GraphicsEnabler=Yes npci=0x2000 PCIRootUID=1

 

Not helped :(

same

 

+ I have this command when i boot from USB but after press enter it's gone and chameleon boot working in command line mod:

 

/extra/com.apple.boot.plist is depreciated.

Please use the file /Extra/org.chameleon.Boot.plist instead.

Press any key to continue.

 

---------------------------------EDIT--------------------------------

---- FIXED -> rename com.apple.boot.plist to org.chameleon.Boot.plist in /Extra fixed chameleon prompt.

---- FIXED -> use Extra_MacBookPro8_1.zip and NullCPUPowerManagement n' LegacyAHCI attached in first post saved my **s :D

 

Thanks to all opensourceMind ppl for sharing.

who care about tonysucks Lion U$B boot. :pyth:

guys I'm very happy. hohaaa :thumbsup_anim::trumpet:

 

I'm still not installed lion cause I have to wait for new HDD to change partition table to GUID ;-) . btw, booting in installation screen is a big sucess for me and I'm sure installation progress will works well.

Share this post


Link to post
Share on other sites

I do Step by Step

 

and seems working well but in last step (boot from USB)

laptop frezzed on DSMOS has arived (pic attached)

 

My laptop spec:

Acer 5750G

core i3 2350M (sandy brig)

4G Kingston RAM 1333

NVDIA 610M (in Bios I changeedd Switchable to Integrated)

Intel 3000HD is second VGA (active VGA)

 

Please help me/

THANKS/

 

I think i can help, the only difference between my laptop and yours is that mine has not got the extra graphics from nvidia. yo need to add this to the root of your installer. go here this will supply you with an extra that will work with your created installer, on the last page.

http://www.insanelymac.com/forum/index.php?showtopic=278094&hl=&fromsearch=1

Share this post


Link to post
Share on other sites

hey everyone,

 

here are the machine specs as best i can get:

 

- Dell Inspiron 1525

  • CPU: Intel Pentium D T????
  • GPU: Intel GMA
  • RAM: 4GB Dual DDR2 PC5300 (2x2GB)
  • HD: Western Digital Caviar Blue 120GB
  • OS: Mac OSX Lion 10.7.3

ok so i followed the guide (http://www.osx86.net/10-7-lion/14385-guide-dell-inspiron-1525-10-7-3-near-perfect.html) and after running the install i can get into lion, but after install and running step 8-10 after the reboot it wont start, i'll post more detailed information later today, but basically i either get one of two problems, either i get a waiting for root device when i run boot with arch=i386 -v, or arch=i386 rd=disk0 (or 0s2 which is what it says in disk utility after the install), or i get a KP for AppleInterCPUPowermanagement, not sure if its something im doing wrong, basically i can re-install Lion and get back in but cant reboot. the baseimage i used was 10.7.3 not sure if that is causing the problem i havent been able to get my hands on a 10.7 vanilla image. boot flags look correct in com.apple.boot.plist (i think that is right followed from iAtKos)

 

i installed lion again and this time i didn't run through step 8-10 and install chameleon and guess what if i boot using the lionUSBinstaller key and select my lion install it boots no problem! so I'm guessing the issue is with whatever the script does to configure the boot loader/copying files etc..now mind me I'm totally new at this and have zero idea what I'm doing..any help anyone can provide would be appreciated..not sure how to configure so i can boot from the hd instead of using the usb stick installer key, if you need more machine specs let me know

Share this post


Link to post
Share on other sites

 

hello, I installed iatkos l3 successfully on my dell inspiron 1318 and at the first boot i get a kernel panic something about loading a kext.

I'm not sure what it means or even what I'm supposed to do. Can someone explain to me exactly what i have to do?Ok thanks :)

post-1088721-0-93206500-1356499293_thumb.jpg

Share this post


Link to post
Share on other sites

Hi MaLd0n an all people.

 

I was installed  Extra_Lion_DP4.pkg on my working system disk ((((   - and after reboot - no more working hackintosh ((( very stupid - i know (((

 

Do you know how to rollback this pkg ??

 

And there can i get InstallESD.dmg   ? is it here ??   --> HackBoot Lion http://www.insanelym...p...st&id=94070  ???

 

P.S. Sorry for my bad enlish

 

bye bye

Share this post


Link to post
Share on other sites

Hello,

Something must be wrong, as I cannot boot with Chameleon on USB:

Boot process stops and hangs in the middle, see screenshot.

 

Why do I need to delete the Packages folder and copy again? There are no links, Restore moves the files.

GA EP45-DS3LR

 

post-307057-0-92179200-1399886612_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×