Jump to content
MaLd0n

Lion installation via USB stick using Chameleon

1,467 posts in this topic

Recommended Posts

Followed your guide to a T

First up im using a asus striker 2 extreme mobo nvidia 790i chipset

 

Booted from usb no probs , installation started but once it came to the install on which drive i had no hdd to select in disc util ??

 

Anyway i managed to use my external usb hdd and installed it on there.

Booted up after installation completed and all thats happening is it just reboots my system ??

Does this mean it cant be done on a nvidia 790i chipset ??

 

See my nForce OS X Lion (10.7) APP STORE DOWNLOAD INSTALL GUIDE on a Series 6 or 7 nForce chipset / Intel CPU MOBO....... :)

Share this post


Link to post
Share on other sites
Advertisement

THANKS FOR A GREAT GUIDE

 

Installed ok here!!!!!

 

I used npci=0x2000 to boot into installer but after installation i used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.8.0 with dsdt and chimera. Now I have a working OSX Lion Hackintosh boot into 64bit with no need for npci=0x2000

 

Shutdown OK!

Restart OK!

Sleep doesn't work even with SleepEnabler.kext

 

 

Cinebench score

VGA OpenGL: 29.07

CPU: 5.09

 

My system build is Asus P7P55D, Intel Core i7 870, 16GB DDR3@1333 XMS3, ASUS GTX460 1GB and a NETGEAR GA311 Ethernet card. I am using an external usb audio card with official os x drivers so no need for voodoohda cause the onboard audio controller is disabled from BIOS.

Share this post


Link to post
Share on other sites

As I said before, I managed to get my system running and rebooting with this guide, but I did not manage to get my hardware regognized. Maybe I did something wrong with the dsdt.aml install. I just put it in the Extra Folder on my HDD.

 

Now I used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] in the UserDSDT mode and installed the custom DSDT prepared with the DSDT Auto-Patcher. Not my NVidia 8600GT, my Audio card and my DVD Drive gets regognized. I am still lacking essential hardware like my network card though. Do I have to install these kexts manually now? Why do so many guides tell me that my board works out of the box and then it does not regognize anything in my case? What am I doing wrong?

 

Heres my hardware again:

CPU: Intel E7200

Graphic: Nvidia 8600 GT

Mainboard: Gigabyte EP35-DS3R

RAM: 4GB OCZ DDR1066

Share this post


Link to post
Share on other sites
Now I used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] in the UserDSDT mode and installed the custom DSDT prepared with the DSDT Auto-Patcher. Not my NVidia 8600GT, my Audio card and my DVD Drive gets regognized. I am still lacking essential hardware like my network card though. Do I have to install these kexts manually now? Why do so many guides tell me that my board works out of the box and then it does not regognize anything in my case? What am I doing wrong?

 

what are the audio and network chipset models?

Share this post


Link to post
Share on other sites
Hey verdant

WoW

Great Job :)

 

 

dont use SleepEnabler.kext

send me original DSDT

 

Thanks MaLd0n :)

 

Please let me know if I have missed anyone that I should credit in my Acknowledgements section of my guide......

 

Enabling sleep via DSDT modding on nForce chipset MOBOs is still a major problem......see this post by iLeopod here.....any ideas you may have on this are most welcome......

 

BTW do you mind if I make as much reference as necessary to your IM DSDT topics and posts in my nForce Lion Install Guide section on DSDT modding of nForce MOBOs......?

Share this post


Link to post
Share on other sites

First off, love the guide. Took some getting used to, but I'm making progress. On the first page someone else had the same problem that I currently am having: the system uptime in nanoseconds problem. I was confused by your response the initial asker, and was wondering if you could re-iterate your response. Thank you!

Share this post


Link to post
Share on other sites
BTW do you mind if I make as much reference as necessary to your IM DSDT topics and posts in my nForce Lion Install Guide section on DSDT modding of nForce MOBOs......?

Go Go Go

I like it :)

 

First off, love the guide. Took some getting used to, but I'm making progress. On the first page someone else had the same problem that I currently am having: the system uptime in nanoseconds problem. I was confused by your response the initial asker, and was wondering if you could re-iterate your response. Thank you!

KP?

post a photo

Share this post


Link to post
Share on other sites
Go Go Go

I like it :)

 

 

KP?

post a photo

 

 

Well, somehow after 30 reboots, it just made it past it now, but now I'm getting the "Mac OS X can't be installed on this computer" error. I received this error before and replaced the OSInstall file and then I went through that series of "System uptime" errors. Any thoughts?

Share this post


Link to post
Share on other sites
dsdt.Tony_K.zip

if you use VoodooHda, use AppleHDADisabler in s/l/e

 

MaLd0n, thanks a lot for your help!

 

Now my appstore works, also I installed applehdadisabler and original voodoohda - it works! =) What are other ways besides voodoo?

 

Even sleep works now, except the network doesn't work after the sleep! Maybe you can tell me what's wrong? Or I should ask at lnx2mac?

Share this post


Link to post
Share on other sites

Thanks again MaLd0n, it's the second hackintosh I successfully build using your guide.

 

This time it was cheap because I did it with old components which I already had : Gigabyte GA-P35C-DS3R, Intel Pentium E2160 (dual-core 1.8 GHz, only 1MB of cache), 4x1GB DDR2, Gigabyte fanless Nvidia GeForce 9600 GT 512MB and a WD Caviar Green 1TB hard drive.

 

For now there's only FakeSMC.kext, RealtekR81xx.kext and NullCPUPowerManagement.kext in my /Extra/Extensions folder.

 

RealteakR81xx.kext was needed because the integrated network card wasn't working out of the box.

 

The NullCPUPowerManagement case is more strange, because I generated a DSDT.aml file with DSDT Auto-Patcher and enabler C- and P-States generation in my com.apple.Boot.plist but I get a kernel panic on AppleIntelCPUPowerManagement on reboot without it.

 

Anyone knows what's wrong? CPU too old? Should I buy a Pentium Dual Core E6xxx?

 

There are still a few small things to fix:

- Yellow icon for the hard drive. Is it just cosmetic or are there other things involved by this icon?

- I'm still using a PS2 keyboard, before buying an Apple keyboard.

- ALC889A soundcard.

 

There are many solutions to fix those, I already found them, but which ones would you recommend? I like when it's as vanilla and clean as possible.

Share this post


Link to post
Share on other sites

Answering myself as I made some progress! :-)

 

I fixed a few things using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.8.0:

- Yellow icon for the hard drive. Is it just cosmetic or are there other things involved by this icon?
Installed IOAHCIBlockStorageInjector in /Extra/Extensions
- I'm still using a PS2 keyboard, before buying an Apple keyboard.
Installed VoodooPS2Controller.kext in /System/Library/Extensions. It works but now I have to boot in 32-bit mode (added arch=i386 in my apple.com.Boot.plist). Hopefully I'll be able to get rid of that one when I'll have bought an Apple keyboard.
- ALC889A soundcard.
Tricky part.

 

As I generated a DSDT.aml file with DSDT Auto-Patcher, and as the patch description says it comes from MaLd0n and it fixes HDEF/ALC889A (among other things), I first tried with ALC8xxHDA only from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], described as "MacMan's Unified Audio Injector for Realteak (...) ALC889a high-definition audio codecs."

 

Upon myFix 1.3 and reboot, nothing gained, still no sound.

 

So, although the description of this package said "If you are not using a modified DSDT", which I do, "you must also use a HDAEnabler for your specific codec", I chose "ALC885/889a" under the "Non-DSDT HDAEnabler" section, ran myFix and rebooted. Still nothing.

 

So I manually deleted both files installed (/Extra/Extensions/ALC8xx.kext and /System/Library/Extensions/HDA(...)Enabler.kext) and installed VoodooHDA 0.2.72 under the Universal section, still from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. Ran myFix and rebooted.

 

Now I have sound but it's creepy, I have pops, the sound's dirty when it's loud.

 

So what should I do?

 

And there's still that question about NullCPUPowerManagement.kext, is it really needed with my CPU (Intel Pentium E2160)? How to get rid of it?

 

Thanks in advance! ;-)

Share this post


Link to post
Share on other sites

get stuck at this screen

 

dscf2916w726.jpg

 

my system is a p5q pro with an e8400 and a hd4870

 

tried it with a USB stick and HDD. When I use the USB stick I have to unplug the stick because it says "wait for root device" (yes I use ahci) when I plug it in back the installer continues its work but stucks at the same screen as i posted above

 

any help?

Share this post


Link to post
Share on other sites
get stuck at this screen

 

dscf2916w726.jpg

 

my system is a p5q pro with an e8400 and a hd4870

 

tried it with a USB stick and HDD. When I use the USB stick I have to unplug the stick because it says "wait for root device" (yes I use ahci) when I plug it in back the installer continues its work but stucks at the same screen as i posted above

 

any help?

Have you tried plugging your monitor on the other output of your graphics card? Sounds dumb but I recall there are inversions and false detections sometime.

Share this post


Link to post
Share on other sites

Hey Folks ... I tried today to install 10.7 in my system:

 

GA-P55A-UD3 Rev 2.0 BIOS F11

Sapphire HD6870

2x G.SKILL CL9 PC3-12800-4GBRL KIT

Vertex 3 MAX 10PS SSD 120GB

 

I'm using a 16GB A-DATA Series S102 USB3.0 memory thumb for the installation.

 

I downloaded Chameleon-2.0-RC5-r1083 and the Extra Lion DP4 installers, none of one allow me to install them to the memory thumb.

At first I thought, it has to do with the "ignore ownership on this volume" box, so first I left the box checked, then I unchecked it, but nothing helped :)

I used a GUID partition and restored the base system to it, then I also replaced the packages.

 

Is there any other point to consider, which I've lost in the way?

Share this post


Link to post
Share on other sites

Thanks MaLd0n for this guide, now i have a fully working Lion

 

I did had to do some extra work to get the Dual Display, Sound, Ethernet and SLEEP working but everything is ok now.

 

I have an

Asus P6T Deluxe V2

i7 930 Nehalem @2.8GHZ

Gainward nVidia GTX 275 @896MB

6GB Kingston DDR3 RAM

 

The problems i had were that after the install of the Lion i had only one monitor working, no ethernet, no sound, and no sleep.

 

What i did to get them all working for my config:

 

1. Video :

Edit /Extra/com.apple.Boot.plist and added this extra lines:

	<key>GraphicsEnabler</key>
<string>Yes</string>

 

2. Ethernet:

Copy Marvell88E8056.kext in /Extra/Extensions

Link also: http://ul.to/s1aqn5n4

 

3. Sound:

Copy AppleHDA.kext and AD2000b.kext in /Extra/Extensions

Link also: http://ul.to/bhto5qn6

 

4. Sleep

Copy SleepEnabler.kext in /Extra/Extensions

Link also: http://ul.to/75ykbwr1

I found this kext link posted by TomTheGeek here:

http://www.insanelymac.com/forum/index.php...t&p=1706710

 

After adding all the kexts, i just ran the KextUtility (i am actually using a Snow Leopard KextUtility and it seems to be working ok) let it run till it finished and restart after that.

 

All the resources are taken from this amazing forum and i wish you all to keep up the good work

 

For any questions, contact me and if i will be able to help i will

Marvell88E8056.kext.zip

Sound.zip

SleepEnabler.kext.zip

Share this post


Link to post
Share on other sites

My situation:

first HD, 2 partitions ... 2nd is working with 10.7 ... 1st (latest SL) doesn't boot anymore.

Now my questions:

how is chameleon working? I know there are some topics to configure chameleon.

== the hack boot sequence: first bios, then the HD; I think Chameleon should be next and then the default partition.

*Where is that proggie (which files or code is chameleon)?

*Where can I configure the cham bootparameters and their defaults?

*can I update the 1st partition to LION and how (no boot); and if, do I destroy any boot for 2nd partition?

*How can I check which version of chameleon is installed?

*When pressing the tab key at boot, I'm able to change to the working 2nd partition. I know that the startpartition can be changed in some parameters. Where?

 

Thank's for some links!

Best Mondi

Share this post


Link to post
Share on other sites

Hi, MalD0n,

 

i'm trying to put your DSDT from this post

into my Extra folder

 

and when starting to boot it comes some error like this

 

dsc00390zk.th.jpg

 

Uploaded with ImageShack.us

 

when i removed again this dsdt, it can boot normaly, but vga still slow/no quartz extreme

 

i used gma 965 driver from Snow Leopard for my Lion (default VGA driver from Lion makes my mouse LAG)

audio works with latest VoodooHDA

 

but,

no wireless/wi-fi detected

no LAN Ethernet detected

and video playback is very slow (QE/CE not working)

 

can you send me a driver for above ? or link its ok,

and can you correct my dsdt file?

 

see my latest send_me.zip, included my com.apple.Boot.plist,

and my machine full spec generate from AIDA64

 

and my laptop specs in my siggy

send_me.zip

Compaq_2210b_Summary_Machine.txt

Share this post


Link to post
Share on other sites
you need to patch the dsdt for power managment. maldon will do this for you. most likely :)

 

i wish i could learn all about dsdt patching :), also how to identify the correct device.

 

but i'm newbie here

Share this post


Link to post
Share on other sites
enbale HPET in bios setup

or

use NULLCPUPM

or

ForceHPET=Yes

 

is the DSDT file can be used anyway without any changes?

 

i'll try to use nullcpm or ForceHPET, because no HPET option in standard bios

 

thank you -_-

Share this post


Link to post
Share on other sites
If I set HPET in BIOS, I don't need NULLCPUM. Is it correct ?

Native PM = Correct Mac Model, LPC patch(if you need), HPET patch(if you need), P and C STATES

 

...

 

remove IRQs TMR, PIC, etc

Share this post


Link to post
Share on other sites
Native PM = Correct Mac Model, LPC patch(if you need), HPET patch(if you need), P and C STATES

 

...

 

remove IRQs TMR, PIC, etc

 

I've followed the guide completely, made sure HPET was enabled, added NullCPUPowerManagement.kext, and yet I'm still getting this error

vrpzte.jpg

 

Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×