Jump to content
MaLd0n

Lion installation via USB stick using Chameleon

1,467 posts in this topic

Recommended Posts

I'm having problems booting the installer USB stick. I have tried several different USB sticks, including a USB WD Passport Drive. No problem preparing the USB devices but when I try to boot, my system freezes during the BIOS post sequence.

 

BIOS POST Sequence as follows:

I see CPUID (XXXXX) PATCHID (XXXXXX)

Then the boot sequence stops...no error messages, it just stops loading.

Next I should see memory testing...etc. etc.

I don't it just hangs.

 

This happens (freezes) whenever the installer USB is plugged in.

 

I have tried various RC5 versions including the one linked from post #1. In fact if I install everything but the bootloader on the installer USB my system will POST and start normally, the freezing doesn't occur. Obviously I can't boot Mac OS X Base System but at least my system will POST and start SL.

 

This happens on both my gigabyte boards. P55-UD2 and my P55-UD4. They are similar systems but they have different GPUs and CPUs.

Share this post


Link to post
Share on other sites
Advertisement

Core i3 540

Asus p7p55D

2x2 GB corsar xms3 2000mhz

80gb for mac and 1TB for data and windows

 

i have got a msi gtx460 hawk but it was freezing so i got a spare ati x1600 256mb

 

the problem was solved thank mate ................ installing now 12mins remaining

 

the next problem is that when ever i try to run dsdt patcher he says that i need to install java runtime when i say ok... it open a software update and after waiting it says no update found.... tried manually software update its only says lion preview update 976.6mb..... what to do ...

Share this post


Link to post
Share on other sites
the next problem is that when ever i try to run dsdt patcher he says that i need to install java runtime when i say ok... it open a software update and after waiting it says no update found.... tried manually software update its only says lion preview update 976.6mb..... what to do ...

 

Win or Linux

fun.gif

Share this post


Link to post
Share on other sites

Is there any way to install without using the famous [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]? I am not able to install the lion in the partition.

Share this post


Link to post
Share on other sites
Is there any way to install without using the famous [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]? I am not able to install the lion in the partition.

 

 

This method doesn't use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url].

 

How far do you get? Are you still stuck at deleting the packages link?

Share this post


Link to post
Share on other sites
Win or Linux

 

Mac os

 

 

 

well i got a way without touching dsdt patcher but now the next problem is that i got 3 3d cards

 

7300gs 256mb

 

ati x1600 256mb

 

msi gtx 460 hawk

 

i got every driver working like sound / lan / but not able to see vga support ;)

 

also do i need to run dsdt if i want to get vga support??

Share this post


Link to post
Share on other sites
7300gs 256mb

msi gtx 460 hawk

 

Use GraphicsEnabler=Yes in boot.plist

 

send me your DSDT

Share this post


Link to post
Share on other sites
BUT WHY I CANT BOOT LION THE SAME WAY USING GRUB2?

No idea, it should work.

 

Did you replace the "boot" file by a recent one? (RC5 r759 or newer)

Share this post


Link to post
Share on other sites
No idea, it should work.

 

Did you replace the "boot" file by a recent one? (RC5 r759 or newer)

 

 

i did installed package from OP and after that that my grub failed to load than i updated grub using boot cd now i m again in SL but lion disk simply restart, when i choose it in grub menu

Share this post


Link to post
Share on other sites
This method doesn't use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url].

 

How far do you get? Are you still stuck at deleting the packages link?

 

What the link to packages and is ok. The problem now is that it recognizes the stick as if it were not boot.

 

Sorry, sorry for my English.

Share this post


Link to post
Share on other sites
i did installed package from OP and after that that my grub failed to load than i updated grub using boot cd now i m again in SL but lion disk simply restart, when i choose it in grub menu

The installer writes boot0 to MBR, don't use it, just replace the "boot" file, you can download binaries from this topic (r807)

http://www.insanelymac.com/forum/index.php?showtopic=231075

 

Put the "boot" file in the partition you set root in GRUB, replacing the RC3 one

menuentry "Mac OS X Chameleon" {
	 insmod hfsplus
	 set root=(hd0,X)
	 multiboot /boot
}

Share this post


Link to post
Share on other sites
Use GraphicsEnabler=Yes in boot.plist

 

send me your DSDT

 

 

mate i m not able to boot with gtx460...... is there is any solution and also that how can get my dsdt??

 

sorry for the noob ques:D

Share this post


Link to post
Share on other sites
The installer writes boot0 to MBR, don't use it, just replace the "boot" file, you can download binaries from this topic (r807)

http://www.insanelymac.com/forum/index.php?showtopic=231075

 

Put the "boot" file in the partition you set root in GRUB, replacing the RC3 one

menuentry "Mac OS X Chameleon" {
	 insmod hfsplus
	 set root=(hd0,X)
	 multiboot /boot
}

 

as i said

actually i already used installer and later realized it screwed ubuntu,so than i booted into ubuntu live cd and reinstalled grub2

than i booted into my ubuntu partition and updated grub

 

and everything was back to normal but

 

i can't boot into lion partition it just restart when i choose it in grub menu,

 

i don't think i have to still replace boot file as installer would hv done that no?

 

i didn't understand this one ,can you please explain a little ---

 

Put the "boot" file in the partition you set root in GRUB, replacing the RC3 one

menuentry "Mac OS X Chameleon" {
	 insmod hfsplus
	 set root=(hd0,X)
	 multiboot /boot
}

isn't the root part ion for grub is its own root directory?

 

also what is the kernel flag if i wants to boot in 32bit mode in this package,using usb ,i want to check if it still allow to boot in 32 bit mode.thx , and sorry for noob questions

 

your patients is apreciated

 

mate i m not able to boot with gtx460...... is there is any solution and also that how can get my dsdt??

 

sorry for the noob ques:D

 

for dsdt==http://www.insanelymac.com/forum/index.php?showtopic=235523

Share this post


Link to post
Share on other sites
i can't boot into lion partition it just restart when i choose it in grub menu,

 

i don't think i have to still replace boot file as installer would hv done that no?

 

i didn't understand this one ,can you please explain a little ---

 

isn't the root part ion for grub is its own root directory?

It depends on which partition you chose as destination in the installer. If you chose the Lion partition and the Chamelon entry in GRUB points to the boot file in Snow Leopard partition, it will use the old RC3 boot instead of the new one. You have to replace the boot file in Snow Leopard partition or add a new GRUB entry pointing to the boot file in Lion partition.

 

If you are sure GRUB is loading RC5 boot and Lion still doesn't work, then there's some other problem.

 

also what is the kernel flag if i wants to boot in 32bit mode in this package,using usb ,i want to check if it still allow to boot in 32 bit mode.thx , and sorry for noob questions

I'm not sure if "arch=i386" in kernel flags still works or if you need to add

	<key>arch</key>
<string>i386</string>

Share this post


Link to post
Share on other sites
It depends on which partition you chose as destination in the installer. If you chose the Lion partition and the Chamelon entry in GRUB points to the boot file in Snow Leopard partition, it will use the old RC3 boot instead of the new one. You have to replace the boot file in Snow Leopard partition or add a new GRUB entry pointing to the boot file in Lion partition.

 

If you are sure GRUB is loading RC5 boot and Lion still doesn't work, then there's some other problem.

 

 

I'm not sure if "arch=i386" in kernel flags still works or if you need to add

	<key>arch</key>
<string>i386</string>

 

WELL i chose lion partion in installer ,after that i updated grub than it started to show extra option in grub menu so i m pretty sure it is using rc5.

 

other than that my lion installation is ccc copy of lion installation that i made using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] boot loader on usb ,you think it could make any difference to chameleon failing?

Share this post


Link to post
Share on other sites
WELL i chose lion partion in installer ,after that i updated grub than it started to show extra option in grub menu so i m pretty sure it is using rc5.

That option added automatically by update-grub won't work, it will try to boot Mac OS kernel directly, not using Chameleon. You have to add an extra entry in /etc/grub.d/40_custom like the one in post #63, where X in (hd0,X) is the Lion partition, then run update-grub again.

 

other than that my lion installation is ccc copy of lion installation that i made using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] boot loader on usb ,you think it could make any difference to chameleon failing?

I don't think so, I did the same and it works.

Share this post


Link to post
Share on other sites
What the link to packages and is ok. The problem now is that it recognizes the stick as if it were not boot.

 

Sorry, sorry for my English.

 

What is your motherboard?

 

Are you stuck at BIOS POST?

Share this post


Link to post
Share on other sites
The problem now is that it recognizes the stick as if it were not boot.

Did you click on "Change Install Location" in the Chameleon installer? You have to select the USB stick as destination, or it will install to your running system.

Share this post


Link to post
Share on other sites
Did you click on "Change Install Location" in the Chameleon installer? You have to select the USB stick as destination, or it will install to your running system.

 

Yes, everything. The problem is that, when installed, does not recognize the partition.

Share this post


Link to post
Share on other sites
That option added automatically by update-grub won't work, it will try to boot Mac OS kernel directly, not using Chameleon. You have to add an extra entry in /etc/grub.d/40_custom like the one in post #63, where X in (hd0,X) is the Lion partition, then run update-grub again.

 

 

I don't think so, I did the same and it works.

 

i did as you said booting lion perfect from grub menu and in 32bit mode with apple plist file.

 

but just for GK, why my SL works direct from grub menu and lion wont although they are both added automatically to grub menu?

 

also i had hard time editing 40_custom file it require root preveleges, how can i do that next time easily from text editor, as of now it does not edit anuthing in grub.d folder, i hv to move file to desktop than edit and than paste it back using terminal.

 

thx for time and info.

 

P.S: :P you are genious :)

Share this post


Link to post
Share on other sites

Can I do this if I already have a working Snow Leopard setup with chameleon on another drive? I was going to try and install Lion on a spare hard drive I have.

Share this post


Link to post
Share on other sites
for dsdt==http://www.insanelymac.com/forum/index.php?showtopic=235523

 

mate i was able to boot via hard drive insalling chameleon and extra lion but i m not able to see graphics working ... what to do....

Share this post


Link to post
Share on other sites
Can I do this if I already have a working Snow Leopard setup with chameleon on another drive? I was going to try and install Lion on a spare hard drive I have.

Yep

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×