Jump to content
MaLd0n

Lion installation via USB stick using Chameleon

1,467 posts in this topic

Recommended Posts

This may seem a bit noobish but what is Extra DP4? I've installed with "Extra" and replaced it with the Quad Core Extra folder and everything is working perfectly (except the onboard wifi, but i gave up on that at Leopard level...) is there any benefit in installing DP4? I'm thinking not to fix what's not broke...

 

Graphics required EFI string for full ID

 

 

 

 

 

Specs:

PK5-E Wifi/AP

Core2Quad Q6600 @ 2.4GHz

8GB DDR2 Ram @ 800MHz

ASUS NVidia 9400GT

Share this post


Link to post
Share on other sites
Advertisement

so here's something strange... my onboard audio is showing in System Profiler but not in System Preferences, and is therefore unusable... anyone got any ideas? i didn't notice coz i use an external card but it's handy for headphones to have the onboard audio working, and just on principle...

 

Intel 1988b on a P5K-E wifi ap mobo

Share this post


Link to post
Share on other sites
eject or reboot

this is happening in some cases

 

 

send me files

http://www.insanelymac.com/forum/index.php...st&id=81816

 

sorry for being so noobish ;);) !

 

already installed it ( DP4 ) and used the DSDT, com.apple.boot.plist and Smbios.plist from my Snow partition !

 

can't run ' DSDT Auto-Patcher ', because of ' No ' Java app :) !

 

THX for this great Tutorial !!!

 

CooSee ' Ya

Share this post


Link to post
Share on other sites
so here's something strange... my onboard audio is showing in System Profiler but not in System Preferences, and is therefore unusable... anyone got any ideas? i didn't notice coz i use an external card but it's handy for headphones to have the onboard audio working, and just on principle...

 

Intel 1988b on a P5K-E wifi ap mobo

 

 

Try this kext in the extra/extension folder. It might work If your audio is similar to P5Q Pro Turbo.

 

 

so here's something strange... my onboard audio is showing in System Profiler but not in System Preferences, and is therefore unusable... anyone got any ideas? i didn't notice coz i use an external card but it's handy for headphones to have the onboard audio working, and just on principle...

 

Intel 1988b on a P5K-E wifi ap mobo

ViaHDA.kext.zip

Share this post


Link to post
Share on other sites
Here the send me file! Thank you for your help!

your DSDT is already edited

remove NUllCPUPowerManagement

add in boot.plist

<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

Share this post


Link to post
Share on other sites

Thanks for the guide MaLd0n...really nice job!!!!!! :) :):thumbsup_anim:

 

i have a problem during installation...after i select the disk for install and press

 

install button a message pops up saying that "essential software is missing "

 

can you help me with that?

 

I am using developers preview 11a390

 

Thanks for all!!!

Share this post


Link to post
Share on other sites

If you replaced the installer with the modified installer to be able to install chameleon or Extra, open the installation package again and re-replace it with the original OSInstall.mpkg

 

Thanks for the guide MaLd0n...really nice job!!!!!! :D :thumbsup_anim::thumbsup_anim:

 

i have a problem during installation...after i select the disk for install and press

 

install button a message pops up saying that "essential software is missing "

 

can you help me with that?

 

I am using developers preview 11a390

 

Thanks for all!!!

Share this post


Link to post
Share on other sites
If you replaced the installer with the modified installer to be able to install chameleon or Extra, open the installation package again and re-replace it with the original OSInstall.mpkg

 

thanks bingaling you were right i replace it again and it worked!!!!

 

I finished installing lion but it does not recognize ethernet card,audio and ps2 devices....can anyone help me with that?

 

my motherboard is asus p5k,i have found the kext for ethernet card(attansic l1) but i dont kow how to install it..

i tried putting it into system/library/extensionsbut it doesnt work..

Share this post


Link to post
Share on other sites

:yoji:

 

can't believe it ! everything is working now :wacko: !

 

thank you so much @ MaLd0n ! Come to Germany and celebrate with me :P !

 

these are the ' kexts ' i'am using in ' Extra / Extensions ' Folder:

 

FakeSMC - Revision 493 ( FakeSMC.kext - IntelThermal.kext - NVClockX.kext

SuperIOFamily.kext - IOAHCIBlockStorageInjector.kext < -- because of Orange Icons !

and

DSDT.aml ( MaLd0n modified ) - com.apple.Boot.plist - smbios.plist - from SnowLeopard partition

and in ' /System/Library/Extensions/ '

RealtekRTL81xx.kext < -- for NetWork - kXAudioDriver.kext < -- for the good Old ' Audigy 4 '

 

but, there's one exception! current iStatMenus didn't show the CPU temps ( maybe after reboot ) ! i can live with that :rolleyes: !

 

and what about the Update ' Lion Developer Preview Update 10.7 ' ? Somebody tried this already ?

 

CooSee ' Ya

Share this post


Link to post
Share on other sites
your DSDT is already edited

remove NUllCPUPowerManagement

add in boot.plist

<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>

 

 

After removing NUllCPUPowerManagement I have working sleep now. Thanks again for your help!

I think I know what you mean now by USB Fix because now I get a kernel panic when something is

plugged in my USB while booting up in Lion. Also CMOS reset is happening after wake from sleep when

I restart. Im sure there are fixes for this but I don't where exactly to find this?

Share this post


Link to post
Share on other sites

and what about the Update ' Lion Developer Preview Update 10.7 ' ? Somebody tried this already ?

 

! no Risk, no Fun !

 

did Backup with current ' CCC ' -_- and used ' SoftwareUpdate ' !

 

iTunes ( 75,8 MB ) and Developer Preview Update ( 656,6 MB )

 

Now using '11A494a' with 'Darwin 11.0.0' Kernel and everything works except 'iStat Menus' not showing 'CPU's and temps!

 

@ MaLd0n, if you've got time, can you look to my ' send_me ' file, maybe something is missing ? !!!

 

CooSee ' Ya

send_me.zip

post-305822-1309208690_thumb.png

post-305822-1309208903_thumb.png

Share this post


Link to post
Share on other sites
After removing NUllCPUPowerManagement I have working sleep now. Thanks again for your help!

I think I know what you mean now by USB Fix because now I get a kernel panic when something is

plugged in my USB while booting up in Lion. Also CMOS reset is happening after wake from sleep when

I restart. Im sure there are fixes for this but I don't where exactly to find this?

 

dont use USB Roll Back

reset cmos after wake

use search forum

 

@ MaLd0n, if you've got time, can you look to my ' send_me ' file, maybe something is missing ? !!!

 

dsdt.CooSee.zip

Share this post


Link to post
Share on other sites
After removing NUllCPUPowerManagement I have working sleep now. Thanks again for your help!

I think I know what you mean now by USB Fix because now I get a kernel panic when something is

plugged in my USB while booting up in Lion. Also CMOS reset is happening after wake from sleep when

I restart. Im sure there are fixes for this but I don't where exactly to find this?

 

 

 

The only fix I found for CMOS reset after wake from sleep is switching out the AppleRTC.kext with an older

AppleRTC.kext from Snow Leopard. But it works for now until something better comes along.

Share this post


Link to post
Share on other sites
thanks bingaling you were right i replace it again and it worked!!!!

 

I finished installing lion but it does not recognize ethernet card,audio and ps2 devices....can anyone help me with that?

 

my motherboard is asus p5k,i have found the kext for ethernet card(attansic l1) but i dont kow how to install it..

i tried putting it into system/library/extensionsbut it doesnt work..

 

 

Help.....anyone...pleaseeeee...

Share this post


Link to post
Share on other sites
http://cheetha.net/ I hope this application helps!

 

 

Thanks man i tried it but it did not worked...

 

is there a guide on how to install kextes or someone who can guide me through?

 

thanks

Share this post


Link to post
Share on other sites

i use this method: http://grafikdesign.wordpress.com/2008/02/...ll-a-kext-file/

 

thanks bingaling you were right i replace it again and it worked!!!!

 

I finished installing lion but it does not recognize ethernet card,audio and ps2 devices....can anyone help me with that?

 

my motherboard is asus p5k,i have found the kext for ethernet card(attansic l1) but i dont kow how to install it..

i tried putting it into system/library/extensionsbut it doesnt work..

 

i wouldn't for the moment, it killed my installation... had to restart from scratch. wait until the official release, get the dmg from appstore and then use the official upgrades, i'd say

 

Any advice for installing the update via software update?

 

no idea for the ps2 devices, but for the audio, use the modified ones from Snow Leopard. I use the attached ones- AD2000B (despite mine being 1988b) and modified HDA attached

 

Help.....anyone...pleaseeeee...

Archive.zip

Share this post


Link to post
Share on other sites
dsdt.CooSee.zip

 

thx @ MaLd0n

 

but didn't work :(

 

it's ok, i can live with that, thx again for your help ! ;)

 

CooSee ' Ya

post-305822-1309290872_thumb.png

Share this post


Link to post
Share on other sites
what does not work?

 

iStat it's not showing the CPU's and temps, look at the attachment in previous post !

 

maybe this is a ' FakeSMC ' problem ?

 

because with ' Snow ' everything's working with ' iStat ' and current ' FakeSMC ' !

 

CooSee ' Ya

Share this post


Link to post
Share on other sites
I was hoping that would work and make it easy for you but I use an entirely different method myself. The method I use is too drop the kext file in to "System/Library/Extensions" And then drop the entire Extensions folder on a program called "Kext Utility" until and wait until its finished repairing permissions. Then open "Disk Utility" and repair disk permissions again and wait until it finishes and restart.

You can also install most of these kexts in Extra/Extensions using the same method.

 

 

 

 

Here's Kext Utility

 

I have P5Q Pro Turbo and use this Network Kext and some of these kexts haven't worked with my Ethernet so If it fails to work then try the one I am using here.

Kext_Utility.zip

AttansicL1eEthernet.kext.zip

Share this post


Link to post
Share on other sites
iStat it's not showing the CPU's and temps, look at the attachment in previous post !

 

maybe this is a ' FakeSMC ' problem ?

 

because with ' Snow ' everything's working with ' iStat ' and current ' FakeSMC ' !

 

CooSee ' Ya

 

Put in S/L/E

FAKESMC.zip

double click in kextUtility

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×