Jump to content
MaLd0n

Lion installation via USB stick using Chameleon

1,467 posts in this topic

Recommended Posts

Why does usb disconnects in the middle of the installation process, and end up in an error ?? Have

 

tried diffrent usb stick, USB Hdd etc.

Share this post


Link to post
Share on other sites
Advertisement
PP: After wake up in Lion -> Graphics (HD4670) OpenGL fps drop from 21 to 8.. After restart .. immediately reset bios :huh: .. This just in Lion.

@MaLd0n Is there any decision to this issue .. :(

-> CMOS reset after wake, from here -> VGA drops after wake

PP: No any problem in SL .

Share this post


Link to post
Share on other sites

I tried this guide using DP4 but I get stuck at "still waiting for root device" during install.

 

I have a fully working install of 10.6.7 on a Supermicro X7DWAN mobo with dual 2.66 Ghz QC Xeons running at 3GHz, AHCI enabled.

Share this post


Link to post
Share on other sites

got a question if your running a macbios (gigabyte board) project now closed, will you still need a dsdt.aml or should the one integrated in the modded bios do? for me it works till 10.6.6, have not done 10.6.7 because of my autheros wifi card and my EP45T-USB3P audio issues running a gt 220 I dunno if that will have problems, heck if I can figure out the 4870 I got I'll use that lol. and I didn't want the hassle lol.

got any clues? if a bios patched for SL will do?

terramir

Share this post


Link to post
Share on other sites

Greetings, and thanks for all the work here guys! I was able to install DP4 via this method, however I could not boot from the USB, I managed to get to the original install by using my previous Snow Chameleon bootloader. Installation went fine i'm assuming, however now (of course) I cannot boot via the usb. Any thoughts or suggestions would be much appreciated. Sincerely ssprod

Share this post


Link to post
Share on other sites

thx for this guide.

prevents me from smashing my gts450 on the floor wich should replace my broken 9800 in sl. (yeah i wasnt up to date wich cards are running fine in sl :rolleyes: )

but after 1000 fermi freezes ,kp's and diffrent gf driver installations under 10.6. i thought it could be a good idea to try lion.

 

install runs fine with replaced osinstall on ga-ep35-ds3.

for ethernet and sound i need my old 10.6.7 files to get them working.

sleep/wake is not working for me at the moment.

and freezes of my geforce are gone.

 

 

strange thing is, i can still boot in my old snow leopard partition with the lion chameleon loader. (need to use bootflag -x but could have something to do with broken graphic drivers because of the gts450 problems)

did i miss something?! i thought the lion loader does not working with the snow leopard. or came out a new one?

Share this post


Link to post
Share on other sites

Just got a new GA-Z68X-UD4-B3 and i7 to replace my UD3P & Xeon.

Everything seems to be working nicely except sleep -

 

I can sleep fine, when I wake the USB keyboard doesn't work until I unplug and re-plug it. Also, the display seems to take a very long time to wake, but eventually does.

 

Thoughts? dsdt is from tonymac's database. USB 3 drivers from [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], although I tried with stock usb and with mb usb, no difference.

 

So close to having a really badass hackintosh!

 

UPDATE: Seems if I wake the computer with the USB keyboard, it will wake (display still takes quite a while), but the keyboard stops working...if I wake with a USB mouse, it will wake, and keyboard works fine. I cannot wake with bluetooth mouse....also usb drives plugged in result in the "not properly ejected" message upon wake.

 

Also, when I sleep and wake, upon the next reboot, my BIOS settings have reverted to default and must be reset.

 

What do I need to do - please help, and I'll return the favor whenever possible.

 

Extra/extensions contains:

ALC8xxHDA.kext

FakeSMC.kext

IOAHCIBlockStorageInjector.kext

 

 

Boot plist is:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>Boot Banner</key>

<string>No</string>

<key>EthernetBuiltIn</key>

<string>Yes</string>

<key>ForceWake</key>

<string>Yes</string>

<key>GenerateCStates</key>

<string>Yes</string>

<key>GeneratePStates</key>

<string>Yes</string>

<key>GraphicsEnabler</key>

<string>Yes</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>arch=X86_64</string>

<key>Rescan</key>

<string>Yes</string>

<key>Timeout</key>

<string>3</string>

</dict>

</plist>

Share this post


Link to post
Share on other sites
Trying several methods to get DP4 on a Gigabyte Z68 board. Keep coming up with network not working. See attached screenshot for error message saying that "Ethernet unrecognized." I've used both Tseug and MaldOn's methods and both giving same situation. I'm using a DSDT from TonyMac for my specific board. I can boot into the OS, but aside from that not much else seems to be working - No Sound, No Networking, etc. My config:

 

DP4

Gigabyte Z68MA-D2H-B3 with F3 Bios update

Core i7-2600k

Corsair 8GB RAM

Intel 3000HD on board memory (will add discrete gfx later once I get this stable)

 

I've tried using Lnx2's separate installer for the latest 0.67+ which I had read might be needed to recognize the latest Realtek ethernet on this board. Any other ideas?

 

 

Dave

 

Success!!! For anyone else with similar specs, I was finally able to get DP4 installed and working pretty well. I have full sound, networking, and even installed my Asus 6870 without issue. I won't go into a ton of detail since there are several good guides describing the install, but here's what I roughly did:

 

- Installed using Maldon method with USB drive, using his Extra files for Intel 1155, and latest Chameleon

- Used [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to install the following:

1) System Utilities - All

2) Audio Kexts - RealTek ALC8xxHDA + AppleRollbackHDA

3) Network - Realtek 2.0.6 official driver

 

After the Network driver installed in [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], I immediately got a message that the ethernet connection was found and I was able to get on the network. Before rebooting, I then ran the DSDT Autopatcher for the Z68. You have to have network access to use this, so you have to install the Realtek drivers before you can run this Autopatcher.

 

- After the Auto patcher creates the DSDT and places on the desktop, copy it to the Extra folder

- Reboot

 

Everything should be working after that. Hope this helps others!

Dave

Share this post


Link to post
Share on other sites

SOLUTION OF DELL m1530

 

Those who have been having unexpected freezes with dell systems please replace IO80211Family.kext, IOPCIFamily.kext and AppleAPCI.Kext from Snow Leopard.

 

Try from SL version 10.6.6, I tried other SL versions(older) and did not get very stable results.

 

The system is running quite stable with an exception of iTunes.

I have got

Graphics GeForce 8600M GT - Working

Audio HD Audio Controller [8086:284b]- Working

Touchpad with multitouch - Working

Ethernet 88E8048 PCI-E Fast Ethernet Controller [11ab:435a] - Working

Wireless BCM4312 802.11b/g [14e4:4315] - Working

Card Reader - Working

 

Any sync related functions are causing an immediate hang of application. iTunes on sync, Opening contacts in System preferences etc. Cannot place the reason...

 

If anyone is running into the same problems do share

Share this post


Link to post
Share on other sites
Success!!! For anyone else with similar specs, I was finally able to get DP4 installed and working pretty well. I have full sound, networking, and even installed my Asus 6870 without issue. I won't go into a ton of detail since there are several good guides describing the install, but here's what I roughly did:

 

- Installed using Maldon method with USB drive, using his Extra files for Intel 1155, and latest Chameleon

- Used [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] to install the following:

1) System Utilities - All

2) Audio Kexts - RealTek ALC8xxHDA + AppleRollbackHDA

3) Network - Realtek 2.0.6 official driver

 

After the Network driver installed in [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], I immediately got a message that the ethernet connection was found and I was able to get on the network. Before rebooting, I then ran the DSDT Autopatcher for the Z68. You have to have network access to use this, so you have to install the Realtek drivers before you can run this Autopatcher.

 

- After the Auto patcher creates the DSDT and places on the desktop, copy it to the Extra folder

- Reboot

 

Everything should be working after that. Hope this helps others!

Dave

 

This is essentially what I did - is sleep working correctly? When I sleep the computer, if I wake from USB keyboard the keyboard stops working until I replug. Also, the display takes a long time to wake, and any connected USB drives report the "not properly ejected" error. Lastly, when I restart the CMOS has been reset! If I do not sleep, the CMOS doesn't reset.

Share this post


Link to post
Share on other sites
SOLUTION OF DELL m1530

 

Those who have been having unexpected freezes with dell systems please replace IO80211Family.kext, IOPCIFamily.kext and AppleAPCI.Kext from Snow Leopard.

 

Try from SL version 10.6.6, I tried other SL versions(older) and did not get very stable results.

 

The system is running quite stable with an exception of iTunes.

I have got

Graphics GeForce 8600M GT - Working

Audio HD Audio Controller [8086:284b]- Working

Touchpad with multitouch - Working

Ethernet 88E8048 PCI-E Fast Ethernet Controller [11ab:435a] - Working

Wireless BCM4312 802.11b/g [14e4:4315] - Working

Card Reader - Working

 

Any sync related functions are causing an immediate hang of application. iTunes on sync, Opening contacts in System preferences etc. Cannot place the reason...

 

If anyone is running into the same problems do share

 

Can you recommend a more detailed installation scheme, please?

 

Can you upload the kexts you used?

 

Thanks...

Share this post


Link to post
Share on other sites

I have a GA ep45t ud3lr snow leopard works and installs with ease.....lion on the other hand is giving me trouble, usb is all setup it boot but then i can not enter any boot flags and its gets stuck at this screen

 

post-818282-1308863893_thumb.jpg

post-818282-1308863863_thumb.jpg

Share this post


Link to post
Share on other sites
This is essentially what I did - is sleep working correctly? When I sleep the computer, if I wake from USB keyboard the keyboard stops working until I replug. Also, the display takes a long time to wake, and any connected USB drives report the "not properly ejected" error. Lastly, when I restart the CMOS has been reset! If I do not sleep, the CMOS doesn't reset.

 

Sleep is working fine for me for all I can tell so far. Can't say that I've done too much experimenting with it, but it does enter sleep and wakes back up without issue. I didn't modify any other settings in the BIOS beyond making sure the HDD is in AHCI.

Dave

Share this post


Link to post
Share on other sites

If I can run Snow Leopard with no problems just using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] from multibest So what should I install to run a lion?

Share this post


Link to post
Share on other sites

Hi again...my DP3 works just fine...now i want to install DP4 , I follow the same things as DP3 but when it boot I see a gray screen and nothing happened ...any idea?

 

Somebody to suppose what is the reason HD4670 to fit perfectly in SL, but cant run in Lion USB install..?

bmas...my HD4670 works fine..I even switch card after boot and nothing happened , meaning no krnl panic or strange colors...works like charm.

Share this post


Link to post
Share on other sites

This guide is really straight forward and easy to follow. However, my motherboard is the P5Q Pro Turbo with a patched BIOS and I never needed the dsdt.aml fix in SL, I always just used sleep enabler for the sleep function to work. Is there any sleep fix for me for 10.7 Lion?

Share this post


Link to post
Share on other sites
This guide is really straight forward and easy to follow. However, my motherboard is the P5Q Pro Turbo with a patched BIOS and I never needed the dsdt.aml fix in SL, I always just used sleep enabler for the sleep function to work. Is there any sleep fix for me for 10.7 Lion?

 

 

I even went ahead and tried the dsdt auto patcher since the Asus P5Q Pro Turbo was listed there, but sleep still doesn't work and I don't notice any other benefits to having the dsdt.aml file in Extra?

Share this post


Link to post
Share on other sites

Thanks SO MUCH for the guide!!!!

 

Should anyone have an Asus P5K-E Wifi/AP board, and assuming you have Snow Leopard already installed, you can follow these instructions using another drive with two partitions to install Lion with ease.

 

Instead of a USB drive i use a drive with two partitions, one called Lion and the other Lion Install - follow the instructions, using the drive with SL and presumably Chameleon as the boot drive and avoid installing chameleon on the new drive for the moment. Replace the Extra with the appropriate one for your processor, place the created DSDT in Extra and reboot. No extra kexts required, just those in the Extra folder. At some point, I'll have to install Chameleon onto this drive to be able to use it as the main boot drive...

 

Network can easily be repaired by copying AppleYukon2 from Snow's S/L/E IONetworkingFamily to the desktop of Lion, deleting it from Lion's S/L/E IONetworkingFamily, then use sudo mv command to move it from the desktop to Lion's S/L/E IONetworkingFamily, repair permissions and restart.

 

woohoo!

Share this post


Link to post
Share on other sites
This guide is really straight forward and easy to follow. However, my motherboard is the P5Q Pro Turbo with a patched BIOS and I never needed the dsdt.aml fix in SL, I always just used sleep enabler for the sleep function to work. Is there any sleep fix for me for 10.7 Lion?

DONT USE SLEEPENABLER

 

NativePM + USB fix(if you need) = native sleep

use DSDT

Share this post


Link to post
Share on other sites

hello MaLd0n,

 

maybe there's something wrong with the ' Extra_Lion_DP4.pkg ' installer !

 

first try, the installer next button jumping directly to the installation type and i'am not able to choose the destination !

 

tried 5 or 6 times and finally it let me choose but the installer tells me that i can only choose the current ' Mac OS Volume ' destination and this is ' 10.6.8 ', all others have a exclamation mark !

 

this happens with the Chameleon installer, too ! can't choose destination ! it's weird !!!

 

sorry for my bad english !

 

what i'am missing ?

 

THX

 

CooSee ' Ya

Share this post


Link to post
Share on other sites
DONT USE SLEEPENABLER

 

NativePM + USB fix(if you need) = native sleep

use DSDT

 

 

I feel dumb for knowing exactly what you mean by USB Fix? Will this allow sleep to work correctly? I am using the dsdt.aml but still no sleep? Only my hard drives go to sleep but the fans, processor and everything is sill on and I can't wake so I have to push reset to restart the computer. Besides the sleep issue everything works perfectly so I will just wait for a solution. Thank you for the reply!

Share this post


Link to post
Share on other sites
hello MaLd0n,

 

maybe there's something wrong with the ' Extra_Lion_DP4.pkg ' installer !

 

first try, the installer next button jumping directly to the installation type and i'am not able to choose the destination !

 

tried 5 or 6 times and finally it let me choose but the installer tells me that i can only choose the current ' Mac OS Volume ' destination and this is ' 10.6.8 ', all others have a exclamation mark !

 

this happens with the Chameleon installer, too ! can't choose destination ! it's weird !!!

 

sorry for my bad english !

 

what i'am missing ?

 

THX

 

CooSee ' Ya

 

eject or reboot

this is happening in some cases

 

I feel dumb for knowing exactly what you mean by USB Fix? Will this allow sleep to work correctly? I am using the dsdt.aml but still no sleep? Only my hard drives go to sleep but the fans, processor and everything is sill on and I can't wake so I have to push reset to restart the computer. Besides the sleep issue everything works perfectly so I will just wait for a solution. Thank you for the reply!

send me files

http://www.insanelymac.com/forum/index.php...st&id=81816

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×