Jump to content
MaLd0n

Lion installation via USB stick using Chameleon

1,467 posts in this topic

Recommended Posts

i have X58A-UD7 with i7. Tried to install Lion DP4from USB, but it stops at boot and stalls on....

 

1) when i use Chameleon from this topic

 

after it generates P&C states, display says that "not Connected" and reboot

 

2) when i use Chameleon from Kext.com ( X58UD7 10.6.7 full 64bit Lion by Jaco)

 

"PCI configuration begin ]" < - this is what i see. Probably there is another [ before PCI.

 

 

I boot my Snow with TonyMac's [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] and it works very good.

 

Any ideas ?

 

Kari

Share this post


Link to post
Share on other sites
Advertisement

First, thanks to the community for putting out this great info!

But...I've got a problem. Getting "can't find mach_kernel" when I try to boot from USB. Followed all the steps to a T, then did the whole thing again in case I missed something...then one more time. Still the mach_kernel error.

 

Any ideas? Thanks-

Share this post


Link to post
Share on other sites
First, thanks to the community for putting out this great info!

But...I've got a problem. Getting "can't find mach_kernel" when I try to boot from USB. Followed all the steps to a T, then did the whole thing again in case I missed something...then one more time. Still the mach_kernel error.

 

Any ideas? Thanks-

 

Kernel is in Extra folder, copy it from there...

Share this post


Link to post
Share on other sites
i have X58A-UD7 with i7. Tried to install Lion DP4from USB, but it stops at boot and stalls on....

 

1) when i use Chameleon from this topic

 

after it generates P&C states, display says that "not Connected" and reboot

 

2) when i use Chameleon from Kext.com ( X58UD7 10.6.7 full 64bit Lion by Jaco)

 

"PCI configuration begin ]" < - this is what i see. Probably there is another [ before PCI.

 

 

I boot my Snow with TonyMac's [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] and it works very good.

 

Any ideas ?

 

Kari

 

 

The UD7 has two Lan, tries to qualify them all and two, I had also this problem

Share this post


Link to post
Share on other sites
Kernel is in Extra folder, copy it from there...

 

It's already there. Thanks though...still "can't find mach_kernel"

Share this post


Link to post
Share on other sites
whats changes have a kernel in the package??

 

thanks maldon.

mac_kernel in root and 32 bit install

Share this post


Link to post
Share on other sites
mac_kernel in root and 32 bit install

 

 

Thanks, install went fine - I don't have sound though, and the boot loader doesn't seem to be installing where it should, I'm still getting the old boot loader than I used with Snow Leopard, forcing me to still boot via USB stick. Motherboard is GA-ep45-up3p.

 

Help is VERY much appreciated.

Share this post


Link to post
Share on other sites
mac_kernel in root and 32 bit install

 

Hi Maldon.

First of all, thanks for your hard job and spending so much times for the hackintosh community...

 

Well, althought I reached the installation screen using previous installers, I could not even see it with this new one...

Installation stops at : PCI configuration

Motherboard is Asus Rampage III gene.

Could it be that lion can't be installed on this board ?

Regards

Share this post


Link to post
Share on other sites
Thanks, install went fine - I don't have sound though, and the boot loader doesn't seem to be installing where it should, I'm still getting the old boot loader than I used with Snow Leopard, forcing me to still boot via USB stick. Motherboard is GA-ep45-up3p.

Help is VERY much appreciated.

 

copy files(Extra folder, etc) to the root of HD(Lion)

 

Audio

use search forum

 

Hi Maldon.

First of all, thanks for your hard job and spending so much times for the hackintosh community...

 

Well, althought I reached the installation screen using previous installers, I could not even see it with this new one...

Installation stops at : PCI configuration

Motherboard is Asus Rampage III gene.

Could it be that lion can't be installed on this board ?

Regards

somehow

this problem is common

Use the search and see if you find a solution

Share this post


Link to post
Share on other sites

So, after much toiling the correct bootloader is working, also audio is working (yes "search" is your friend). Should have tried a little harder before asking...

 

I do have one remaining issue, which is I'm stuck at 1024x768. Motherboard is GA45-UD3P, graphics card is GeForce 9800 GTX+. Checked out the thread on graphics cards and lion, but nobody has mentioned mine.

Share this post


Link to post
Share on other sites

Hello,

After try many times to install Mac OS X Lion dp4 on my pc, I finally turn to this tutorial that seem clear. I followe the tutorial but I'm stuck after launch the installation. Here is a screenshot that should give you an idea:

 

img0165au.jpg

 

What should I do?

Thank you for help me.

Sorry for my bad english.

Share this post


Link to post
Share on other sites

Hi everyone,

 

I am trying to install Lion DP4 on my PC

Everything goes very well until I got into "Selecting partition to install Lion onto", all partitions are marked with exclamation, cannot to click on "Continue"

 

My HDD is MBR, not GPT. 3 partition, 2 NTFS, 1 HFS+ (active)

Share this post


Link to post
Share on other sites
Hello,

After try many times to install Mac OS X Lion dp4 on my pc, I finally turn to this tutorial that seem clear. I followe the tutorial but I'm stuck after launch the installation. Here is a screenshot that should give you an idea:

What should I do?

Thank you for help me.

Sorry for my bad english.

 

I have no idea

I hope someone can help you

 

Hi everyone,

 

I am trying to install Lion DP4 on my PC

Everything goes very well until I got into "Selecting partition to install Lion onto", all partitions are marked with exclamation, cannot to click on "Continue"

 

My HDD is MBR, not GPT. 3 partition, 2 NTFS, 1 HFS+ (active)

http://blog.nawcom.com/?p=751

Share this post


Link to post
Share on other sites

I have completed most of the steps successfully, everything loads but then it hangs at a line that says:

bootcachecontrol: unable to open /var/db/BootCache.playlist

 

If someone knows how to fix this I would appreciate any help.

 

Also I checked the folder and the file it talks about isn't there.

 

Thanks.

Share this post


Link to post
Share on other sites

Massive thanks to Maldon for this guide. I'm running DP4 on a G41M-ES2L board. Everything working smoothly. Might do a video walkthrough for others who are struggling? Anyone interested?

Share this post


Link to post
Share on other sites

I succesefully installed Lion DP4 on my PC, only problems are that menu bar isn't transparent and my webcam is not working. I have nVidia 8600GT graphic card and my webcam is Vimicro 305WC. Anyone knows how to fix it?

Share this post


Link to post
Share on other sites

Two questions;

 

Can I install on a separate hard drive using this method-USB stick using Chameleon?

 

and I was able to get the usb booted, when I get to the installer it says "There was a problem installing Mac OS X"

 

Any suggestions are appreciated

Share this post


Link to post
Share on other sites
My HDD is MBR, not GPT. 3 partition, 2 NTFS, 1 HFS+ (active)

 

You can't install into an MBR Partition. It has to be GUID .

 

You'd better do a bit more reading.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×