Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
fadaunder

Here DSDT for Hp Pavilion dv6560el

15 posts in this topic

Recommended Posts

Hi there, starting from a dsdt file that i've found on this forum, i ì've beggined to edit it, trying to get a better native support for my laptop ... Sincerly i think i'm at a good point, yesterday i've fixed HPET section, and the laptop fans stopped to run everytime, temperature of cpu is much lower, and my computer....feels like a real macbook ;))

 

But i'm still using voodooPowerMini & vodoobattery kext, and i'm not so happy about it, because of random kernel panics when disconnecting the power cable ....

 

So here is my dsdt , give it a try and let me know, and if you have a dsdt that makes you able to work without voodoo's kexts, post so we can merge the two dsdts.

 

Sorry for my english ;)

 

 

Hp dv6560el DSDT + HPET fix

Hp dv6560el DSDT + HPET fix (Pre_Compiled)

Share this post


Link to post
Share on other sites

Yep, it worked ... ! Reboot/Halt works well without SleepEnabler.kext .. i've removed before upgrading to 10.6.7 ...

what did you do if i can ask?

 

Never shout too loud! : I use this computer manly for making music, so cpu use during production is intense ...

The problem is that i have crackles, because my cpu usage now reach easly 100% with songs that i've made days ago, on this computer, without problems... maybe a problem with bad power states?

 

There is something that's wrong .... my ram works at 607mhz instead of 667 (now fixed that in com.boot.plist ), but my FSB clock is 725 Mhz, when it should be 800 ...

 

I've removed voodoPowerMini kext, then installed voodooHda to see if crackles go away, but i won't use that kext, autosensing is not working!

 

Now i've disinstalled voodooHda ... restored my old appleHda.kext ... and voilà ... audio now is not working at ALL ! :)

 

Very good! ...i'll search for audio dsdt native support .. (ALC268 integrated soundcard)

 

 

--------------

 

Reinstalled appleHda, voodoopower removed, now audio works and my audio software doesn't give problems.. but my cpu temp is around 53°C and doesn't get lower ... i will check all things related to fsb maybe the problem is "near" that ..

Share this post


Link to post
Share on other sites

Hi, really thanks for your suggestions.

 

Here is my kextstat ouput, but ioreg ecc.. doesn't give me any output ...

 

I don't know why, but my custom boot.plist were not loaded before ... now i've used lizard tool to edit and it worked ...i've enabled 64 bit support and now my pc works so smooth ... speed increse is noticeable! I don't know if it merit of 64 bit mode or P/C state enabled ...

 

Read the article you linked, but it says that works only for 32 bit mode ... and i don't want to come back to it :()

 

thank you mald0n!

kextstat.txt

Share this post


Link to post
Share on other sites
Everything seems ok , but temperature is still too high and reboot doesn't work (halt does)

ing

you're having problems with power management

ioreg -lw0 | grep CSTInfo

 

native PM and restart fix --> Chameleon RC5

 

Use correct smbios

Share this post


Link to post
Share on other sites

Chameleon RC5 Installed, (and FakeSMC too), but reboot isn't working and temperature still too high, with or without P/C States enabled...

 

Now

ioreg -lw0 | grep CSTInfo

 

gives this output:

 

"CSTInfo" = 19136773

 

What does it mean?

 

 

I've downloaded iStat, wich displays cpu temperatures, but only my HDD temp is showed ... not cpu's .. .

 

 

Summer is coming, and i don't want to burn :P

 

thanks!

Share this post


Link to post
Share on other sites
Chameleon RC5 Installed, (and FakeSMC too), but reboot isn't working and temperature still too high, with or without P/C States enabled...

 

Now

ioreg -lw0 | grep CSTInfo

 

gives this output:

 

"CSTInfo" = 19136773

 

What does it mean?

 

 

I've downloaded iStat, wich displays cpu temperatures, but only my HDD temp is showed ... not cpu's .. .

 

 

Summer is coming, and i don't want to burn :P

 

thanks!

 

for other temp reading you need the fakesmc plugins found on projectosx

Share this post


Link to post
Share on other sites
for other temp reading you need the fakesmc plugins found on projectosx

 

 

but temp reading is not so important .... the right power management is...

i don't know why temperature is still so high....i have only 3 programs opened (chrome, dreamweaver, a download manager), cpu use around 15%

 

I've cleaned the heatshink one week ago, so i think there is something wrong :/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×