Jump to content

8gb causing shutdowns/KP


1stewart
 Share

2 posts in this topic

Recommended Posts

Hello guys,

 

 

 

 

I've managed to get OSX running (almost) fine on my P.C. Using iPortable SL 10.6.2. Cloned to HDD and booting up fine with no arguments. The only modifications I've done is install the ATi 6XXX package to get my graphics card working properly.

 

However, the problem I'm having when booting both from HDD or USB is that, anything over 4GB of RAM is causing the system to shutdown with no errors shortly after selecting the device from the bootloader. With arguments I get a KP "panic pmap_steal_memory"@/SOURCECACHE.."

 

Memory is Kingston HyperX 2000 2GB modules. Mobo is Asrock X58 Xtreme 3. Tried a number of arguments including -force64, -s, -x, etc. The only results I've got are either a KP at different stages, or an instant shutdown

 

Sorry if I've missed something whilst searching, the results have been quite broad.

 

Regards,

 

Stewart

 

UPDATE:

 

Tried using max_valid_dma_addr= and setting it to the amount 8090 (whatever the bootloader is saying), mach_kernel (using an i7) and -force64. same problem ;)

Link to comment
Share on other sites

Got it working for anyone else with the same issue. Being a massive OSX lowbob I didn't realise it was running in 32bit mode. Set it to 64 following this guide:

 

http://www.overclock.net/mac/564147-how-enable-64-bit-default-os.html

 

Didn't have to set any boot flags except for mach_kernel (even though it's set in the boot file, my desktop would just freeze)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...