Jump to content

SOLVED:Dual Boot -Added to Win7-Broke OSX access


1 post in this topic

Recommended Posts

:)

SOLVED:

In Terminal: type sudo fdisk -u /dev/disk0

This Repairs the MBR without deleting the partition [with OSX].

The partition ID is still "EE" [unknown] not "AF" [HFS+] as many OPs say is required here.

But it works fine!

 

 

I CANNOT BOOT INTO OSX w/o [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] CDROM after adding utility to Win7.

I shouldn't make that kind of error, but I did. I need help fixing boot.

--------------------------------------------------------------------------------------------

I had a perfect 10.6.6 install on disk0 and Win 7 SP1 on disk2. Then I installed a Win7 backup/restore utility "Acronis" and broke things[details on request]. Chameleon no longer appears on booting. [Chameleon screen gave me access to both OSX and Win 7 before]

 

Instead-Boot now yields "MBR Error 3 MBR Error 1 Press Any Key to boot from floppy."

 

FYI: I built the system by installing OSX on the only system drive that was connected. Then I disconnected the OSX drive. Connected another drive and installed WIN7 on it. Reconnected OSX drive. Used [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] & [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.x

As of now:

Using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] I can boot into OSX or Wind 7 OK. Without [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]-

I cannot boot into OSX even by pointing the motherboard BIOS at the drive with OSX. Same "MBR 3" error appears.

 

 

I tried to fix the boot problems by re-running [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 3.4 using same Bootloader as previously [Chameleon prerelease] Did not fix anything.

 

I suspect that I need to use the terminal with FDISK to fix my OSX boot problem. I don't know what I need to do with FDISK. Because FDISK can wipe out my OSX install, I want to get it right & safe first try.

 

SUGGESTS FOR FIX PLEASE?

-------------------------------------------------------------------------------------------------

Screen captures that may provide helpful info

 

new-host:~ macosx86user$ sudo fdisk -e /dev/rdisk0

  • Password:
    Enter 'help' for information
    fdisk: 1> print
    Disk: /dev/rdisk0 geometry: 121601/255/63 [1953525168 sectors]
    Offset: 0 Signature: 0xAA55
    Starting Ending
    #: id cyl hd sec - cyl hd sec [ start - size]
    ------------------------------------------------------------------------
    1: EE 1023 254 63 - 1023 254 63 [ 1 - 1953525167] <Unknown ID>
    2: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
    3: 00 0 0 0 - 0 0 0 [ 0 - 0] unused
    4: 00 0 0 0 - 0 0 0 [ 0 - 0] unused

THIS TABLE SHOWS THE 5 partitions of DISK0 [includes EFI] & DISK1 [Win 7 install]

 

macosx86user$ diskutil list

/dev/disk0

#: TYPE NAME SIZE IDENTIFIER

0: GUID_partition_scheme *1.0 TB disk0

1: EFI 209.7 MB disk0s1

2: Apple_HFS 1TB Part A MAIN 300.0 GB disk0s2

3: Apple_HFS 1TB Part B TimeMach 250.0 GB disk0s3

4: Apple_HFS 1TB Part c MISC 150.2 GB disk0s4

5: Apple_HFS 1Tb Part D Experiment 299.3 GB disk0s5

/dev/disk1

#: TYPE NAME SIZE IDENTIFIER

0: FDisk_partition_scheme *300.1 GB disk1

1: Windows_NTFS win7 300gb 300.1 GB disk1s1

exit

_________________

GA-P55A-UD3 V 2.0 F11 bios, i5 650,ASUS Geforce 8400 512, 700 watt OCZ PSU, OCZ3G1333LV2G 2x2GB, Samsung 1TB 7200 rpm SATA drive, Dell Ultrasharp 2311 Monitor,Sony DVD burner, USB keyboards and mice, Wired Ethernet, Software used: [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], Retail 10.6.3, MacOSX 10.6.6 combo update...more

Link to comment
Share on other sites

 Share

×
×
  • Create New...