Jump to content
Sign in to follow this  
Followers 0
Goliath Developer

Acer Aspire D150 Netbook Installer / Maker

5 posts in this topic

Recommended Posts

Hiya People


im trying to install 10.6 from a retail snow leopard dvd using netbook installer to my netbook acer aspire D150.


ill talk you throught what i have tryed so far,


i tryed 10.6.1-10.6.2 from hazards dvd with the atom kernel this failed ill have to try again at some point.

*Update I have just tryed reinstalling again it failed with kernal panic using their atom kernal because of the voodoo hda enabler.


hazards 10.6.6 i think worked but I had to create a kernel from scratch (effort) cant remember ill have to reinstall again and then create a guide if i can do it.

*Update tryed reinstalling fails on install then freezes cannot view installer log atm.


I installed 10.5.6 xXx which worked kinda kernal panic with voodoo 9.5.0 rc1 no wifi ar5007 atheros, no eth0 this was just to test thou.


Right now the real test,


I got my Snow Retail Dvd restored it the usb hard drive then used 8.5pre netbook installer which seemed fine.


installed but took a while to boot so restarted with kernal flags -v cpus=1 -x and it worked,


I finally got to the setup screen so entered in the details and it was ok in safe mode.


I rebooted now just using -v cpus=1 and it loads up then when it loads my desktop it crash's not error on screen

not panics no nothing just turns off,

any thoughts or ideas

Share this post

Link to post
Share on other sites

Just a Update i have used a 10.6.3 retail disk with netinstaller 0.8.5 and it installs fine a 1 errors on boot below:

launchctl please convert the following to launchd dashboardadvisoryd.plist (still boots thou so this is fine)


Running a little slow just installing the wifi driver (its not working im looking at editing the kext when i get a chance).

*Update gave up on the wifi driver so i took the adapter out of the apple tv and it works perfect no configuring needed


also every 10 seconds the computer freezes until you move the mouse, to fix the freezing issue install 10.6.6 Combo Update, then boot back into the usb hard drive you used to install then use netbook installer 0.8.5 and prepair the drive.

Boot back in it as a come up with the error saying you need to reboot your computer this is fine eventually after the 3rd boot it goes fine and you have a good system.






:what is working

Keyboard and touch pad works (standard),


laptop display works,

after upgrade from 10.6.3 to 10.6.6 everything works fine on the os side of it (if you edit the systemversion.plist and change it to 10.6.7 no update needed),



:what isnt working

the wifi driver for ar5007,

the audio registers as voodoo hda but guess what it doesnt,

extrnal display does not work it screws up both displays im gonna try the gma950 from hazards 10.6.1-10.6.2 and will then update.

Share this post

Link to post
Share on other sites

I've basically got everything working apart from the wireless and sleep.

I'm using netbookinstaller r 0.8.4 RC1 and image of OS X 10.6 snow on external drive.


I've even updated to 10.6.3, but for some reason startup takes alot longer to get to desktop now.


Am still hunting for wireless kext, but think i will have to swap wireless card out with one that has kext.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.