Jump to content

SL Installed with NO hacking; hangs without BOOT CD


tunasampler
 Share

3 posts in this topic

Recommended Posts

Hey Guys, Well, after trying 7 different distros (2 Hazards/Iatkos 7/iDeneb/etc...) I accidently put in my retail copy of SL 10.6.3 and it loaded the install screen (something I had been unable to do) and installed SL without a hitch. I made it to the desktop and as of now, the only glitchy aspect of my computer is the sound. System Profiler says I have a Mac Mini...? Oh, and it sees my ram as DDR2 800 instead of DDR3 1600, does this mean it is only running at this speed, even if the BIOS reads it at DDR3 1600? Any ideas on why this worked? the ONLY tweaking I did to my PC was changed the Sata drive to AHCI in the BIOS. The only problem is that I have to boot with my chameleon boot cd, then select SL in the load screen. If I try to boot straight from SL, it hangs on the Grey Apple Logo screen. I guess I am just looking for ideas in general on why this worked, if anyone has had a similar experience, and how to maybe get it to boot directly from the HD. I figure if I cannot get it to boot directly from the HD, it is a small price to pay for a fully functional hackintosh. System specs: Azusa M4A87TD AMD Phenom II 840 @ 3.2 GHZ (quad core) 4 gigs Corsair RAM DDR3 1600 Wireless Network - USB Dongle Netgear Wg3111V3 (But am going to try to get a macbook mini pcie airport card and connect it to a pcie slot with a mini pcie to pcie adapter. I heard this works OOB and will be recognized (at least it is in 10.6.6.))

Link to comment
Share on other sites

  • 2 months later...

I am having the same problem using iAtkos. Install worked with no problem. When I try to boot i arrive at the chameleon bootloader, choose snow leopard and get the "hanging apple". I've tried booting with -s -v -x etc. When i choose either of those options I get a black screen. When I use osx86 mod cd then choose snow leopard boots within 15 seconds, no problem. Any Suggestions?

Link to comment
Share on other sites

Logic:

 

If your boot CD works but your Chameleon installation doesn't, then you need to configure the Chameleon installation on your hard drive to match the configuration on the boot CD.

 

Sounds simple, right?

 

On boot CDs, extra/extensions on preboot.dmg (or initrd.img if it's an older boot CD) holds the kernel extensions and possibly a patched kernel, also look in smbios.plist and com.apple.Boot.plist and see which flags are set and what gets loaded from where.

 

Most Boot CDs are set up to boot OS X on a variety of hardware, so there will be settings and files that are not necessary on your hardware - there could even be settings and files that are preventing something from working.

Experiment until you get it right. Until then you can use the CD to boot.

 

To learn more about how boot CDs are put together, find and read guides on how to make them. There are tons of guides out there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...