Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
jucytec

MBP Early 2011 enable ATI/INTEL switchable graphics in Boot Camp?

Recommended Posts

Is anyone working on getting the switchable graphics to load in Boot Camp? It'll be nice to run INTEL Drivers for most of the time when using MBP. Such a shame that Boot Camp drivers do not support or even show the Intel HD card under device list in Windows.

Share this post


Link to post
Share on other sites
Advertisement

Not sure if someone is working on it: the IGP is disabled by the BIOS emulator (that's why it doesn't shows up in the device list). The only way to enable it is to modify the BIOS (quite hard) or do a re-enable trick in the bootsector like this one (if there are any bytes left).

 

It's probably easier to spam Apple.

Share this post


Link to post
Share on other sites

How does the efi/bios emulation stop the Intel HD 3000 from being allocated resources?

 

If you suspend/resume win7 on a 2011 15/17" MBP, the Intel HD 3000 device is found, drivers installed but the device cannot be initialised as there are not sufficient resources. The device does not persist after reboot.

 

HD3000_2011_MBP15-1.jpg

 

 

It would be nice to able to enable resource allocation for the Intel GPU, with a little MBR patch!, to be able to use its quicksync features (I'm not bothered about switching b/w the AMD & Intel GPU).

Share this post


Link to post
Share on other sites

I'm pretty keen to investigate this - anyone know how to dump the efi bios emulator? code to disk so I can search for the code that's disabling the HD 3000.

Share this post


Link to post
Share on other sites

Hi,

 

The Intel integrated GPU on Core i3/5/7 can normally be enabled in BIOS mode with the following line in grub.cfg :

setpci -d 8086:0044 54.b=0b

You may need to customize to your CPU PCI ID, which can be obtained with "lspci"

 

metatech

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×