Jump to content
InsanelyMac Forum
The Jack of Clubs

aspire one aoa150 sleep and battery meter

Recommended Posts

i have an aspire one aoa150 here im trying to get snow leopard installed and fully working. i just got my asus eeepc 1005hab fully working. i figured the hardware is not really different enough, i could use the same guide i found at http://aregularguyincanada.blogspot.com/20...c-1005-hab.html and for the most part it worked. i used a different dsdt.aml and kexts for the networking than the eeepc. i got 10.6.6 installed with a kernel and sleepenabler meant for it. funny enough, the two things i didnt think i would have a problem with, im having a problem with.

 

sleep is not sleeping the computer. the screen goes black and it sits there on, not asleep. it cant be awoken. i have to force power it off.

 

it seems to know when it is or isnt running on battery, and gives timers for each. but the percentage in system preferences says 0% and if you check the option to put the meter in the menu bar, it immediately unchecks. what gives?

 

i have looked around and im not sure how to solve these issues. any feedback is more than appreciated.

Share this post


Link to post
Share on other sites
Advertisement

guy walks into a bar, says "ow".

 

i figured out the power meter, needed voodoo power kexts. still no sleep but it doesnt look like anybody has that working, or even trying to get it working anymore. the sdcard readers are not working, even with the jmicron kexts i found. anybody figure those out atleast?

Share this post


Link to post
Share on other sites

I think Chamelion RC5 with P and C states is the way to go if you want working sleep.

 

I haven't pulled it off myself, but someone else on here has...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • I did try that just now but it seems like the card is still active as it still shows up in system report! I have managed to get the battery meter working but as i said it works only when i unplug/plug the ac adapter. I have to do this once then the meter functions properly.
    • My BIOS has an option of enabling/disabling CSM! I think enabling CSM made my boot menu go non native resolution too!
    • I have a gigabyte Aorus ultra. I don't think so, everything should be uefi. Anything I should look at in particular? 
    • All right now : I have taked delivery of my new TBEX3  this afternoon : plugged and all is fine at startup, screen plugged on USB_C   My Settings recap :   1/ Bios recommended parameters for Thunderbolt + Pci devices set as Legacy 2/ I added arbitrary lines on my config.plist ( Thanks @Matthew82.) <dict> <key>Comment</key> <string>THUNDERBOLT 1577</string> <key>CustomProperties</key> <array> <dict> <key>Disabled</key> <false/> <key>Key</key> <string>model</string> <key>Value</key> <string>Thunderbolt EX3</string> </dict> <dict> <key>Disabled</key> <false/> <key>Key</key> <string>AAPL,slot-name</string> <key>Value</key> <string>Slot-4</string> </dict> <dict> <key>Disabled</key> <false/> <key>Key</key> <string>name</string> <key>Value</key> <string>Thunderbolt 3 Controller</string> </dict> <dict> <key>Disabled</key> <false/> <key>Key</key> <string>device_type</string> <key>Value</key> <string>Thunderbolt 3</string> </dict> <dict> <key>Disabled</key> <false/> <key>Key</key> <string>IOName</string> <key>Value</key> <string>Thunderbolt</string> </dict> </array> <key>PciAddr</key> <string>03:00.00</string>   3/ my SSDT  SSDT-TB3U2.aml.zip
    • Try using this SSDT without changing the name, it's not necessary rename it, Clover knows that it is, and what is does in the system. Also use DropOEM  as true: <key>DropOem</key> <true/>  


×