Jump to content

Laptop Nvidia 7400 Go Internal LCD Problems


bageleudi
 Share

2 posts in this topic

Recommended Posts

Hello,

 

I'm trying to build a hackintosh for some time now and have a huge problem with my graphics card.

 

My Laptop is a Samsung NP-X11TS01/SEG with these specs:

 

- Core 2 Duo T7200 2x 2.00GHz

• 2048MB (2x 1024MB)

• NVIDIA GeForce Go 7400 128MB max.512MB shared memory

• 14.1" WXGA glare TFT (1280x800)

 

I'm using a Retail Snow Leopard Installation 10.6 and everything works perfect except for the internal LCD.

During Installation I have to plug-in an external Monitor via VGA because the internal LCD Screen will got black after the grey Apple Logo. But with an external Screen pluged-in everything works and I can finish the installation.

 

After that, on the external Monitor everything works out of the box - I got QE working, I got full Resolution and also can change the Resolutions in Settings.

 

I am startig the System with boot options in Chameleon (Graphics Enabler=yes) If set to no, the system won't start.

 

I tried several Injectors (NVenabler, NVinject, NVcush....) but none of those gave me the internal screen of the laptop.

 

The last thing i did, I put my Device ID into NVDANV40Hal.kext and NVDAResman.kext. And that made my Internal Screen working. With the Hotkey on my keyboard i can switch to the external Monitor, i can switch to mirror mode and back to the internal screen. So i thougth that everything is working like a charm.

BUT! QE isn't working, and I also got stock with just one Resolution (1024x768) :)

 

And that is where I am Now! And I don't know what to do next. I read a lot of threads in forums but none of them could help me :) First i thought I had the same problem like some Sony VAIO users - who could not get the internal LCD to work - but I'm not sure about that since i got mine working except for QE and full Resolution.

 

Is there a chance for me to get it working? I'm out of ideas right now, and i hope that someone here has some ideas for me how to get that thing working on my internal screen.

 

Maybe it has something to do with display-cfg? or NVCAP? I don't know.... :(

 

I would really appreciate if someone could help me. If you need some more infos, just tell me.

 

I'm sorry for the long thread and my poor english (I'm from germany ;) )

 

Thanks in advance

 

Eddy

 

PS. I could not post this thread in the hardware->graphics->nvidia section, so I don't know if its right here.

Link to comment
Share on other sites

  • 2 weeks later...

Problem Solved! :D

 

I installed the "newest" bios (from 2008 :P ) and since then everything works just like a charm out of the box!

 

So I got my full resolution, and QE ist working!

 

The only problem left is the sleepmode - I can't get it working. the laptop goes into sleepmode - but never wakes up.

 

With sleepenabler.kext it also won't wake up, but when i restart the system with the power button - I get a grey view of the desktop with some points at the bottom - which i guess should be the screen when waking up? But it never does!

 

The system won't start, but reboots everytime. Without the sleepenabler.kext I'm not sure what happens, when I try to wakeup the system - I think the hdd starts working again - and the display also changes from beeing off to blackscreen - but it never shows me the desktop again...

 

Any ideas about that? I'm on SL 10.6.6 now :D

 

bageleudi

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...