Jump to content
Mammoth

[Guide] Mammoth Method v2.00 - HP DVx 10.6.x: Fast, Easy, Comprehensive Installation. /// NEW MAMMOTH BOOT CD for i5 & i3 \\\

1,567 posts in this topic

Recommended Posts

ALL MIIFs UPDATED TO v.02

 

Please, if you can and will, try a complete install using the new MIIFs. I would like to verify as soon as possible that all the problems have been solved so others won't have problems.

 

Thanks

Share this post


Link to post
Share on other sites
Advertisement
ALL MIIFs UPDATED TO v.02

 

Please, if you can and will, try a complete install using the new MIIFs. I would like to verify as soon as possible that all the problems have been solved so others won't have problems.

 

Thanks

 

Also on another note when we can look at the mouse issue ive noticed when i use my sound controls on the laptop they work however the value on the menu bar doesnt change, also sometimes when i push play/pause it doesnt always work the first time, probably something that cant really be fixed but thought i would ask about the volume thing anyways

Share this post


Link to post
Share on other sites
Also on another note when we can look at the mouse issue ive noticed when i use my sound controls on the laptop they work however the value on the menu bar doesnt change, also sometimes when i push play/pause it doesnt always work the first time, probably something that cant really be fixed but thought i would ask about the volume thing anyways

 

On the Trackpad, have you looked at the Trackpad Preference Pain in System Preferences? Try setting it like this:

 

Select the following:

 

Clicking

 

Dragging

 

and

 

Drag Lock (tap again to release)

 

Let me know if that helps.

Share this post


Link to post
Share on other sites
On the Trackpad, have you looked at the Trackpad Preference Pain in System Preferences? Try setting it like this:

 

Select the following:

 

Clicking

 

Dragging

 

and

 

Drag Lock (tap again to release)

 

Let me know if that helps.

 

i have had everything selected except drag lock, i selected drag lock and tried teh mouse and the same thing still happens??

Share this post


Link to post
Share on other sites
i have had everything selected except drag lock, i selected drag lock and tried teh mouse and the same thing still happens??

 

Wait, are you talking about a mouse or the Trackpad?

Share this post


Link to post
Share on other sites
Wait, are you talking about a mouse or the Trackpad?

 

trackpad, i think your last post sent the forum into an ips error lol.. You think we might be able to squash this faster with a different means of communication??

 

also if i try to click on mouse in preferences it says no mouse found!

Share this post


Link to post
Share on other sites

@Mammoth,

I am going to try install afresh using the new files!! Will check if the Audio,Brightness and HDMI have started working! Then I have a perfect install!!! Cant wait! please help me out when you get time! Sadly our Audio ID's are different. Hopefully if Taptun can help me out here!! About the Brightness and HDMI! Mammoth! will wait for you!

 

EDIT: Audio,Brightness and HDMI still not working!!!

Share this post


Link to post
Share on other sites

Just want to report that I successfully installed via the Mammoth method (earlier today, before the update). As far as I recall, the only issue I had was the CIIF/Cham thing, but that was minor.

 

I have not tried *everything* everything, but I am simply blown away how much works! I'm posting this reply on the system now :guitar: Can't wait until my new wifi card arrives to make it all complete!

 

One issue I do have is that my Blu-Ray drive seems to access periodically, even though there is no disc in it.

 

This is probably a total n00b question, but are the "alt" keys supposed to act as "Option" keys? I thought so, but that seems not the case here.

 

Thanks x1000 Mammoth! Your hard work is appreciated! Thought I would NEVER get OSX running on this damn thing!

Share this post


Link to post
Share on other sites

plz tell me what wifi card you will buy cuz i want to buy one but dont know which will work with me thanx

another thing did the processor temp show with you in i state ?

 

final your work mammoth you are our hero thanx man

Share this post


Link to post
Share on other sites

wael,

 

I ordered one of these: Broadcom BCM94322 / Dell DW 1510 PCIe

 

and no, the processor temperature does not show, just the harddrive.

 

plz tell me what wifi card you will buy cuz i want to buy one but dont know which will work with me thanx

another thing did the processor temp show with you in i state ?

Share this post


Link to post
Share on other sites

well i checked my mouse again been trying desperatly to get it to work correctly and i deselected dragging and now the mouse works perfect…so i dont know whats going on that it wont work correctly with the dragging correctly but im happy now if i need to drag something ill physically click then drag!! Im still convinced something is wrong here however as like i said earlier if i have 2 finger scrolling selected it allows me to scroll with the printed bar on the trackpad but no 2 finger scrolling anywhere, and if i uncheck that then i cannot scroll at all with the trackpad!

Share this post


Link to post
Share on other sites
wael,

 

I ordered one of these: Broadcom BCM94322 / Dell DW 1510 PCIe

 

and no, the processor temperature does not show, just the harddrive.

thanx man i just ordered one from ebay 20$ but are you sure it will work ?

about temp of processor it was working with me in 10.6.4 from previous guise is there any way to monitor processor temp ?

Share this post


Link to post
Share on other sites
thanx man i just ordered one from ebay 20$ but are you sure it will work ?

about temp of processor it was working with me in 10.6.4 from previous guise is there any way to monitor processor temp ?

 

This is something we have to work on. There is information in the guides about it. The links to the FakeSMC pages is what we need to start exploring and figure out how to get all of this working on our DVx machines. This will have to be a team effort.

 

well i checked my mouse again been trying desperatly to get it to work correctly and i deselected dragging and now the mouse works perfect…so i dont know whats going on that it wont work correctly with the dragging correctly but im happy now if i need to drag something ill physically click then drag!! Im still convinced something is wrong here however as like i said earlier if i have 2 finger scrolling selected it allows me to scroll with the printed bar on the trackpad but no 2 finger scrolling anywhere, and if i uncheck that then i cannot scroll at all with the trackpad!

 

Have you tried using BetterTouch yet? Plenty of mouse/Trackpad related features in it.

 

Just want to report that I successfully installed via the Mammoth method (earlier today, before the update). As far as I recall, the only issue I had was the CIIF/Cham thing, but that was minor.

 

I have not tried *everything* everything, but I am simply blown away how much works! I'm posting this reply on the system now ;) Can't wait until my new wifi card arrives to make it all complete!

 

One issue I do have is that my Blu-Ray drive seems to access periodically, even though there is no disc in it.

 

This is probably a total n00b question, but are the "alt" keys supposed to act as "Option" keys? I thought so, but that seems not the case here.

 

Thanks x1000 Mammoth! Your hard work is appreciated! Thought I would NEVER get OSX running on this damn thing!

 

Awesome Fewlio!

 

Thanks for letting us know you got it to work, even with .01 MIIF that had the problem (fixed in .02 now).

 

More would have worked and better without the .01 bug. You MIGHT want to try the install again with .02. Results may be even better than what you have now. ;)

 

The optical drive routine access issue has been around for a while; even my desktop Hacs do it. There are posts out there on it, I've just never looked into it.

 

On the key assignments, there is information about that in the guides.

Share this post


Link to post
Share on other sites

hi Mammoth!

 

is it possible to try the DVx with a hp dv7 i5, or should i wait for a proper dv7 MIIF?

 

thanks

Share this post


Link to post
Share on other sites
hi mammoth!

 

is it possible to try the DVx with a hp dv7 i5, or should i wait for a proper dv7 MIIF?

 

thanks

 

I'm glad you're asking and willing to test. It seems the i5's have been particularly tricky. I am getting ready to work on getting us all some more patch packs, but what you could try is this:

 

 

NOTE FOR EVERYONE USING AUTO-PATCHER

 

MaLd0n has said that when creating a clean DSDT, it is VERY important to boot your machine WITHOUT a DSDT.aml loaded! Info here:

 

http://www.insanelymac.com/forum/index.php...howtopic=235523

 

Now, some machines may not be able to boot or run properly without a DSDT, so the best approach may be to use Ubuntu to create your clean DSDT. Then once you have the clean DSDT.aml file, you can add it to your MIID in the /Extra/ folder, then try to boot your machine with it.

 

 

@EVERYONE

 

I would really like it if those of you with i3 and i5 based machines would try this and let us all know if it works. If you can boot your machines with the MIID using these clean DSDTs from Ubuntu, then it's pretty easy to create the Patch Packs (at least for NIXin it is :(. If you can boot into the OS X Installer, then of course see if you can do and install.

 

@Mammoth,

I am going to try install afresh using the new files!! Will check if the Audio,Brightness and HDMI have started working! Then I have a perfect install!!! Cant wait! please help me out when you get time! Sadly our Audio ID's are different. Hopefully if Taptun can help me out here!! About the Brightness and HDMI! Mammoth! will wait for you!

 

EDIT: Audio,Brightness and HDMI still not working!!!

 

I don't know if I said this already or not, but CONGATS on finally being able to install OS X on your machine, wooo whooo! :)

 

Are you saying you already reinstalled with the v.02 MIIF and those things still aren't working? If so, then yes, I hope Taptun will be able to create an audio string ID and if so, I will add it to the MIIF.

 

For the Brightness issue, go to that thread (link is in the guides) and work with them on it. Let us know your success and again, well with any advancements you make, I will add it to the MIIF.

 

Just to update I highly recommend AGAINST installing iStat Pro. I just experienced a kernel panic mentioning "unlocking an unlocked mutex" sounded very strange. Quick google and here is an insanelymac thread:

 

http://www.insanelymac.com/forum/index.php...43204&st=40

 

Seems iStat Pro is the culprit when used in conjunction with hard drives such as ours. Be warned...

 

iStat Pro was not singled out as the culprit in that thread. There are many parts to using iStat pro such as FakeSMC (and all of it's many new add-on files). I have been running iStatPro on my machine for months and have never seen even 1 KP from it.

 

I'm sure it is something with one of FakeSMC's hardware sensors (and we all need to know that the new FakeSMC is still under development).

 

Thank you for your hard work to make this guide. Just that, do you have any ETA for the dv6t MIIF (my configuration is in my signature). THank you!

 

Thank you for your appreciation! :) It always helps to know you are helping people and they appreciate you, which gives encouragement to continue on with this craziness!

 

I am turning my attention to Patch-packs, which will lead to working DSDTs, which then allows for creating new MIIFs.

 

Everyone should start creating their clean DSDTs (especially for i3 and i5 machines) and posting them in the thread along with your system information and the output from MaLd0n's RUN_ME script. That will help a lot!

 

UPDATE: Actually, I just had a thought - post the above mentioned info here, but if you would email it to me too, I won't have to go searching through the thread to find it. Having it easily accessible in my email will really help me to create Patch-packs and MIIFs faster.

 

MammothV200@gmail.com

Share this post


Link to post
Share on other sites

I have now made a own DSDT file from autopatcher with the updated files from post 1

 

It looks like my card reader is not working, but wow so great overall my mac is working

 

I have attached some files from my system, but is not installed with the new updated MIIF

 

Mammuth or other super member, do you see any strange in these files ?

 

BR

 

Peter

send_me.zip

dsdt.aml.zip

Share this post


Link to post
Share on other sites
Not sure l necessarily agree, if you check my reply later on you'll notice that simply renaming the taptun10_6_3 kernel to taptun10_6_6 it boots perfectly. No change in file location or nothing. Very strange...

 

Yes, I think you are correct. I believe this is now corrected for anybody who will be installing with .02 MIIFs.

 

I have now made a own DSDT file from autopatcher with the updated files from post 1

 

It looks like my card reader is not working, but wow so great overall my mac is working

 

I have attached some files from my system, but is not installed with the new updated MIIF

 

Mammuth or other super member, do you see any strange in these files ?

 

BR

 

Peter

 

Hi Peter_sm,

 

You really shouldn't have to worry about DSDT or new MIIF. The DV8 MIIF should be perfect for your system.

 

I would highly recommend you do the installation again with the v.02 MIIF. The results should be stellar.

 

DV6

6:00 PM -8:00 GMT Release Day! 2011-03-21 Coming soon!

 

when ? :) its from my dv6 3152ss

 

Hello Kone_Dejota,

 

Sorry I haven't been able to respond to you before, BUSY! :(

 

You should use Ubuntu to create a clean DSDT for your machine and then post it here.

 

Also, create an InsanelyMac signature for your account with all your system information.

Share this post


Link to post
Share on other sites
Hi Peter_sm,

 

You really shouldn't have to worry about DSDT or new MIIF. The DV8 MIIF should be perfect for your system.

 

I would highly recommend you do the installation again with the v.02 MIIF. The results should be stellar.

 

Mammuth, I have did a few SW update is it possible to update manually with the new MIIF what is new ? I thinking just install the kext that's are updated? but is the new MIIF so much better I think I did a new install

Share this post


Link to post
Share on other sites

Hey mammoth/guys.

 

I'm worried about doing the install on my machine without proper dsdt.

Is there / could anyone provide me with the proper dsdt file for my machine?

model number is in my signature.

 

thanks a squillion.

Brad

Share this post


Link to post
Share on other sites
Hi Mammoth,

 

Here is my Clean DSDT for my DV6122ea.

 

I hope this helps your patch packs.

 

All the best

 

NSCXP2005

 

PS I have emailed you this as well

 

DSDT_CLEAN_dv6122ea.zip

 

Awesome, thanks!

 

Have you tried to use this DSDT on your MIID to see if you can boot into the OS X Installer, or tried to install? If not, give it a try.

 

Hey mammoth/guys.

 

I'm worried about doing the install on my machine without proper dsdt.

Is there / could anyone provide me with the proper dsdt file for my machine?

model number is in my signature.

 

thanks a squillion.

Brad

 

People need to generate their own clean DSDTs and the guides tell you how to do it. Once you have that, you can use that safely to attempt an install.

 

Mammuth, I have did a few SW update is it possible to update manually with the new MIIF what is new ? I thinking just install the kext that's are updated? but is the new MIIF so much better I think I did a new install

 

There were scripts that needed to be run and didn't, so I would do a clean install now, rather than later. I know it's kind of a pain, put you will know for sure then that your install was perfect.

Share this post


Link to post
Share on other sites

As sent by email to Mammoth (wasn't able to post on the forums before):

 

Well, tried today to install various combinations: (MIID already created)

 

1 - used your new MIID, to no avail!

 

2 - tried to use the 1.3.0 vanilla kernel with cpus=1 and arch=i386 , didn't work!

 

3 - used dsdt.aml generated by autopatcher, in both cases. With and without, same result!

 

 

It seems to always reboot at the same point... is there a way to block it, so I can see where it hangs?

 

Btw, my BIOS is F1.C , in HP site, there isn't a newer one.

 

 

--------

 

Will update my sig, but for reference, my laptop is an DV6-2170ep, i5 2.4ghz, geforce 320M 1gb.

Share this post


Link to post
Share on other sites

i can supply my auto-patched dsdt for anyone here, i used windows to pull it then used nixin auto patcher to compile it, sound and qe/ci is working it seems to run pretty cool with everything running fine as far as i can tell!!

 

DSDT.zip

dv7 i7-720qm GT320M F.1C A bios

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×