Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
DaviDemon

[Guide] Installing Mac OS X Lion (Developer Preview)

Please answer the poll!  

62 members have voted

  1. 1. Did this help you?

    • Yes
      28
    • No
      18
    • Somewhat helped
      16
    • Destroyed my system
      4

158 posts in this topic

Recommended Posts

Installing Mac OS X Lion (Developer Preview)

 

This is an installation guide, which is not perfect, however it may or may not aid you in installing the recent release of Mac OS X Lion (Developer Preview). I prefer to receive feedback on how my guide was, by answering the poll question.

 

If you have any concerns or questions, post here or ask one of the other members who have helped me, i.e. usr-sse2, blackosx and a few more I forgot (sorry!).

 

Good luck to all those who try this out! If it fails and blows up your machine, please refrain from flaming and intentionally abusing people verbally.

 

Thanks!

 

Last Revised: 05.03.11

 

- Simplified some instructions

 

- Added credits

 

- Miscellaneous

 

- Added working kexts with descriptions

 

- Added a few tips

 

- Changed the document format

 

Hackintosh_Guide.pdf

Share this post


Link to post
Share on other sites

How about USB support?

I got Lion installed, with correct DSDT, but "EHCI controller unable to take control from BIOS"

So basically no USB mass-storage support, and the EHCI driver is not loaded correctly (but mice & keyboards work.)

Also the RTC seem to be off, the clock slows down by about 30 minutes after a few hours.

THe rest are fine, use the old school enablers for gfx, the realtek ethernet driver port.

 

EDIT: Did I say anything about my config? i5-750 stock with Gigabyte P55-US3L. Works perfectly with SL.

Share this post


Link to post
Share on other sites
I think you should add a credit to usr-sse2 for coming up with the original installation method.

 

 

Hmm yeah true, I will add it in now.

Share this post


Link to post
Share on other sites
How about USB support?

 

Also the RTC seem to be off, the clock slows down by about 30 minutes after a few hours.

THe rest are fine, use the old school enablers for gfx, the realtek ethernet driver port.

 

EDIT: Did I say anything about my config? i5-750 stock with Gigabyte P55-US3L. Works perfectly with SL.

 

USB Support should be enabled with proper DSDT edits, as mine does.

 

You say the clock slows down after 30 min? I have a different problem; the clock/graphics/video are all way too fast. Granted I have not had Lion running for a few hours. So I ask, is your system clock and videos/gfx too fast for you as well?

 

Edit: I this even occurs when I returned CPU/RAM to stock frequencies.

Share this post


Link to post
Share on other sites
USB Support should be enabled with proper DSDT edits, as mine does.

 

You say the clock slows down after 30 min? I have a different problem; the clock/graphics/video are all way too fast. Granted I have not had Lion running for a few hours. So I ask, is your system clock and videos/gfx too fast for you as well?

 

Edit: I this even occurs when I returned CPU/RAM to stock frequencies.

Got the same USB EHCI-Errors (P55-USB3),

using a DSDT from Snow, Snow boots up without any Errors..

 

i dont know, which part i have to change... 8(

 

Someone can help?

(Using the DSDT from Tonymacs (DSDT-F8.aml for P55-USB3)

 

Thanks. Rene

Share this post


Link to post
Share on other sites
Cheers for the guide. :wacko: Where did you add your DSDT though?

 

I didn't use a DSDT in my process. It seems to give me HPET errors so I don't use it. Everything is fine-ish. HDD is detected as external, I use IOAHCIStorageBlockInjector.kext to make it look internal, and for sound I use a USB headset. Shutdown/Sleep/Restart all fail. Lol.

 

But til then, I'm okay with the system up and running without a DSDT.

 

But if you do, then place it in the DSDT folder in your [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] USB stick, i.e. "[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] USB Stick > efi > dsdt", place in "dsdt" folder.

 

If it gives you errors, then boot into a working OS, load up the stick and delete the file. :P

 

Good luck!

Share this post


Link to post
Share on other sites

hi :)

 

finally!!! it was necessary to dare it and hushed up the whizz makes, thank you very much! Very good tuto and very simple, the only one who worked for me ! ;)

 

Many persons bragged to have achieved the installation but no one able of making a tuto to help those as me!

 

Bravo on this blow!!! :D

Share this post


Link to post
Share on other sites
hi :)

 

finally!!! it was necessary to dare it and hushed up the whizz makes, thank you very much! Very good tuto and very simple, the only one who worked for me ! ;)

 

Many persons bragged to have achieved the installation but no one able of making a tuto to help those as me!

 

Bravo on this blow!!! :D

 

Aahaha. Nice.

 

No worries man. People were probably getting a bit too excited about Lion and forgot about the people who helped them. Except for those tech-nerds who got it themselves. :D

 

Anyways, is everything working fine for you? Sound and stuff? You can post stuff here so it'll help those in the future!

Share this post


Link to post
Share on other sites
Got the same USB EHCI-Errors (P55-USB3),

using a DSDT from Snow, Snow boots up without any Errors..

 

i dont know, which part i have to change... 8(

 

Someone can help?

(Using the DSDT from Tonymacs (DSDT-F8.aml for P55-USB3)

 

Thanks. Rene

 

Enjoy! USB works fine, but the problems of correct identification system bus frequency to get rid of me so far failed.

dsdt.aml.zip

Share this post


Link to post
Share on other sites

Indeed on, gladly !!! :D

 

Thus for me the installation very well took place (approximately 10 minutes)!

 

I have a P5KPL AM, the sound, the Ethernet do not work, I owed used AttansicL1eEthernet.kext to put on my network !

 

For the sound, I used VoodooHDA.kext but the sound is moved !

 

I also have a Sapphire HD48300 512 mb but not managed to have QE/CI !!!

 

Well, I continue to persevere !!! ;)

Share this post


Link to post
Share on other sites

Well, I'm sorry that I can't help you to get EVERYTHING working, but at least you got something to start with!

Maybe the drivers have something to do with device id...

 

I dunno. I'm no expert.

Share this post


Link to post
Share on other sites

;) no problem , I am already satisfied that I managed finally to install it !!! :D

 

 

I have already added device id of my graphics board in ATI4800Controller.kext and ATIRadeonX2000.kext , my video card is recognized well but without QE/CI !!!

Share this post


Link to post
Share on other sites

how about a full tutorial on the boot manager [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] v1.2

it does not work on all x86 pc.

Share this post


Link to post
Share on other sites

The tuto of DaviDemon is very simple and complete and it works!!!

 

You also have the link towards [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to be used so that this tuto can end in the success!!!

 

:(

Share this post


Link to post
Share on other sites

Following this tutorial stoped on Part 3 (Installing Mac OS X Lion). Boot process of install USB stick stoped on "Still waiting for root device...". Adding efi drivers HFSPlus and AHCI (e.g. extracted from XPC boot image - Applelife.ru) to modules folder on [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] helped.

Share this post


Link to post
Share on other sites

hi ;)

 

do again the tuto since the beginning, you have something of the missing !!!

 

use 2 well key usb for this tuto, if you can it !!!!

 

 

personally , I added nothing or took away nothing from its tuto , just followed step by step , and it was good !!! ;)

Share this post


Link to post
Share on other sites
Following this tutorial stoped on Part 3 (Installing Mac OS X Lion). Boot process of install USB stick stoped on "Still waiting for root device...". Adding efi drivers HFSPlus and AHCI (e.g. extracted from XPC boot image - Applelife.ru) to modules folder on [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] helped.

 

 

Alright cool, maybe I'll try expand on different boot loaders and drivers. Congrats though.

Share this post


Link to post
Share on other sites
Alright cool, maybe I'll try expand on different boot loaders and drivers. Congrats though.

DaviDemon,

Thank you for this, but it's not working for me. I DO appreciate how you've put it together. I am not a complete novice, but have tried all the methods in the other section and yours.

First it's unclear here: in your step #4 the formatted usb drive. Is it mbr or guid partition that's formatted to “Mac OS Extended (Journaled). ( I chose mbr)

Next, in step #14:

I use terminal a little, but the practice of setting permissions after pasting kexts is not something I'm used to, so ,

"type the following (drag and drop FakeSMC.kext):

 

sudo su

chown –R 0:0 FakeSMC.kext

chmod –R 755 FakeSMC.kext

I tried, and tried, and googled and tried some more, I understand your not giving terminal lessons, but, I swear, I cannot get this to take. I changed and dragged the proper directory over to terminal, after copying the kext to the extension folder on usb stick, Is there a simple explanation you can give me. And the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] stick, I use an asus board, so maybe that's the problem, but I've tried xpc, xpc w/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] alone, and all I get upon booting are the words in RED, "MBR" with a warning to remove disk and press any key to restart, but maybe it's my asus board, I've been reading alot of asus people saying they're having problems with the usb stick not booting. Thank's again, I'm sure I will figure it out later on. I did manage to at least get it on fusion and workstation. I just wanted to give it a quality graphics try. thanks again, johnm

Share this post


Link to post
Share on other sites
DaviDemon,

Thank you for this, but it's not working for me. I DO appreciate how you've put it together. I am not a complete novice, but have tried all the methods in the other section and yours.

First it's unclear here: in your step #4 the formatted usb drive. Is it mbr or guid partition that's formatted to “Mac OS Extended (Journaled). ( I chose mbr)

Next, in step #14:

I use terminal a little, but the practice of setting permissions after pasting kexts is not something I'm used to, so ,

"type the following (drag and drop FakeSMC.kext):

 

sudo su

chown –R 0:0 FakeSMC.kext

chmod –R 755 FakeSMC.kext

I tried, and tried, and googled and tried some more, I understand your not giving terminal lessons, but, I swear, I cannot get this to take. I changed and dragged the proper directory over, after copying the kext to the extension folder on usb stick, Is there a simple explanation you can give me. And the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] stick, I use an asus board, so maybe that's the problem, but I've tried xpc, xpc w/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] alone, and all I get iupon booting are the words in RED, "MBR" with a warning to remove disk and press any key to restart, but maybe it's my asus board, I've been reading alot of asus people saying they're having problems with the usb stick not booting. Thank's again, I'm sure I will figure it out later on. I did manage to at least get it on fusion and workstation. I just wanted to give it a quality graphics try. thanks again, johnm

 

Alright, sorry for being unclear. I will update the PDF soon.

 

First, Use GUID partition, as it works well with Mac OS.

 

Second, this is what I really mean:

 

sudo su

chown -R 0:0 [then drag the FakeSMC.kext in "System > Library> Extensions" directory into the "Terminal.app" window, and press Enter]

chmod - R 755 [same process as above]

 

I also use an ASUS motherboard, are you installing [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] properly? My mobo boots from USB/CD perfectly, so I'm not sure what is wrong here.

 

I hope it goes well over there.

Share this post


Link to post
Share on other sites

Yeah, Thanks, I'll keep trying, I'm sure appreciative of your help, as, the other thread was little pieces that didn't fit together. I'm gonna try again! johnm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×